Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: 11.2 RC1 - Disable touchpad tap to click

  1. #1

    Default 11.2 RC1 - Disable touchpad tap to click

    I've just installed 11.2 RC1, and for the most part it is fantastic. However, I cannot find a way to disable touchpad tapping. Originally my xorg.conf contained the following section, to which I added the last line setting MaxTapTime to zero:

    Section "InputDevice"
    # Driver "mouse" will be disabled unless 'Option "AutoAddDevices" "off"'
    # is set in "ServerFlags" section.
    Driver "mouse"
    Identifier "Mouse[1]"
    Option "Buttons" "5"
    Option "Device" "/dev/input/mice"
    Option "Name" "SynPS/2 Synaptics TouchPad"
    Option "Protocol" "explorerps/2"
    Option "Vendor" "Sysp"
    Option "ZAxisMapping" "4 5"
    Option "MaxTapTime" "0"
    EndSection
    Adding "AutoAddDevices" "off" to the ServerFlags section didn't help, it only disabled touchpad scrolling but not tap to click.

    I then tried adding the following section to xorg.conf:
    Section "InputDevice"
    Driver "synaptics"
    Identifier "Mouse[1]"
    Option "Buttons" "5"
    Option "Device" "/dev/input/mice"
    Option "Emulate3Buttons" "on"
    Option "InputFashion" "Mouse"
    Option "Name" "Synaptics; Touchpad"
    Option "Protocol" "explorerps/2"
    Option "SHMConfig" "on"
    Option "Vendor" "Sysp"
    Option "ZAxisMapping" "4 5"
    Option "MaxTapTime" "0"
    EndSection
    This also failed to disable touchpad tapping. I've searched extensively but I can't find anything to fix this problem. So now I'm at the mercy of the more knowledgeable people in this forum. Any ideas on how to disable touchpad tapping that doesn't require manually disabling it with gsynaptics every time X11 restarts? Any help would be greatly appreciated. This tapping business is driving me insane.

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,319
    Blog Entries
    15

    Default Re: 11.2 RC1 - Disable touchpad tap to click

    Quote Originally Posted by FiveInchTaint
    I've just installed 11.2 RC1, and for the most part it is fantastic.
    However, I cannot find a way to disable touchpad tapping. Originally my
    xorg.conf contained the following section, to which I added the last
    line setting MaxTapTime to zero:

    >
    > Section "InputDevice"
    > # Driver "mouse" will be disabled unless 'Option "AutoAddDevices"
    > "off"'
    > # is set in "ServerFlags" section.
    > Driver "mouse"
    > Identifier "Mouse[1]"
    > Option "Buttons" "5"
    > Option "Device" "/dev/input/mice"
    > Option "Name" "SynPS/2 Synaptics TouchPad"
    > Option "Protocol" "explorerps/2"
    > Option "Vendor" "Sysp"
    > Option "ZAxisMapping" "4 5"
    > Option "MaxTapTime" "0"
    > EndSection
    >


    Adding "AutoAddDevices" "off" to the ServerFlags section didn't help,
    it only disabled touchpad scrolling but not tap to click.

    I then tried adding the following section to xorg.conf:
    >
    > Section "InputDevice"
    > Driver "synaptics"
    > Identifier "Mouse[1]"
    > Option "Buttons" "5"
    > Option "Device" "/dev/input/mice"
    > Option "Emulate3Buttons" "on"
    > Option "InputFashion" "Mouse"
    > Option "Name" "Synaptics; Touchpad"
    > Option "Protocol" "explorerps/2"
    > Option "SHMConfig" "on"
    > Option "Vendor" "Sysp"
    > Option "ZAxisMapping" "4 5"
    > Option "MaxTapTime" "0"
    > EndSection
    >


    This also failed to disable touchpad tapping. I've searched
    extensively but I can't find anything to fix this problem. So now I'm
    at the mercy of the more knowledgeable people in this forum. Any ideas
    on how to disable touchpad tapping that doesn't require manually
    disabling it with gsynaptics every time X11 restarts? Any help would be
    greatly appreciated. This tapping business is driving me insane.
    Hi
    What DE are you using? In Gnome it's in the Control Center -> Mouse ->
    Touchpad tab where this can be set/changed.

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.2 RC 1 (i586) Kernel 2.6.31.3-1-desktop
    up 16:20, 1 user, load average: 0.22, 0.18, 0.18
    ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME


  3. #3

    Default Re: 11.2 RC1 - Disable touchpad tap to click

    Sorry, should have specified that. I'm using KDE.

  4. #4
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: 11.2 RC1 - Disable touchpad tap to click

    On 10/24/2009 12:26 PM, FiveInchTaint wrote:
    >
    > Sorry, should have specified that. I'm using KDE.


    I have not found a KDE method to disable tapping that works and sticks
    other that copying xorg.conf from 11.1 to 11.2.

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,319
    Blog Entries
    15

    Default Re: 11.2 RC1 - Disable touchpad tap to click

    Quote Originally Posted by FiveInchTaint
    Sorry, should have specified that. I'm using KDE.
    Hi
    What about in the KDE control panel (preferences??), nothing there to
    change the features?

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.2 RC 1 (i586) Kernel 2.6.31.3-1-desktop
    up 16:40, 1 user, load average: 0.17, 0.09, 0.09
    ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME


  6. #6

    Default Re: 11.2 RC1 - Disable touchpad tap to click

    Quote Originally Posted by malcolmlewis View Post
    Hi
    What about in the KDE control panel (preferences??), nothing there to
    change the features?
    Unfortunately, there is no GUI method for disabling tapping in KDE. I honestly don't understand why this is the case, but for whatever reason the KDE folks have decided that touchpad tapping is Teh Awesome!!! and nobody in their right mind would want to turn it off.

  7. #7

    Default Re: 11.2 RC1 - Disable touchpad tap to click

    Well, I think I may have found a solution. I created the following shell script:
    #! /bin/sh
    synclient MaxTapTime=0
    synclient MaxDoubleTapTime=0
    I then moved the script to the ~/.kde4/Autostart directory and made it executable. That seems to have done the trick. I originally tried to set it up to run at startup from the KDE Autostart section in the system setting window, but that didn't work no matter how I set it up (i.e. to run at startup, pre-KDE startup, as a shell script, or as a program). Additionally, I think the script has to have .sh as it's suffix to run from the ~/.kde4/Autostart directory, but I may be wrong. In any case, this seems to be working for me-touchpad tapping has been disabled for the last several restarts. That said, it would be still be awfully nice if future versions of KDE provided a simple GUI tool to do this.

  8. #8

    Default Re: 11.2 RC1 - Disable touchpad tap to click

    To update my last post, my solution is no longer working. It seems that now I can't get autostart to reliably run my script at startup. I have placed my shell script in the ~/.kde4/Autostart directory, as well as the ~/.kde4/env and ~/.kde4/share/autostart directories, and it still won't run. And as before, using the KDE GUI autostart setup doesn't work either. So once again, I'm stuck without any way to shut off touchpad tapping. Any advice would be greatly appreciated, because if I don't get this figured out soon, I'm going to have to dump 11.2.

  9. #9
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,319
    Blog Entries
    15

    Default Re: 11.2 RC1 - Disable touchpad tap to click

    Quote Originally Posted by FiveInchTaint
    To update my last post, my solution is no longer working. It seems that
    now I can't get autostart to reliably run my script at startup. I have
    placed my shell script in the ~/.kde4/Autostart directory, as well as
    the ~/.kde4/env and ~/.kde4/share/autostart directories, and it still
    won't run. And as before, using the KDE GUI autostart setup doesn't
    work either. So once again, I'm stuck without any way to shut off
    touchpad tapping. Any advice would be greatly appreciated, because if I
    don't get this figured out soon, I'm going to have to dump 11.2.
    Hi
    Since you seem to have two issues, why not report it as a bugs, else
    wait a few days and install RC2? Or else use Gnome as it works fine
    here <ducking>

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.2 RC 1 (i586) Kernel 2.6.31.3-1-desktop
    up 7:15, 2 users, load average: 0.11, 0.14, 0.10
    ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME


  10. #10
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,695
    Blog Entries
    1

    Default Re: 11.2 RC1 - Disable touchpad tap to click

    I wonder if this KDE 4.X kcm_touchpad tool might work for you.

    The Packman repo has 'touchfreeze' available for openSUSE 11.X as well.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •