Results 1 to 5 of 5

Thread: QT4-Apps under GTK

  1. #1
    astrapi NNTP User

    Default QT4-Apps under GTK

    Hello,

    i use openSUSE 11.1 with gnome 2.24. I have installed qgtkstyle. Because of that, QT4-Apps (vlc, virtualbox) use under gnome the gtk-theme.

    Now, i have installed openSUSE Factory (11.2). This comes with QT 4.5.3. The QGtkStyle is integradet in this. Now, the QT-Apps dont use the GTK-theme.

    In the "QT-4-Settings" under 11.1 there an option "GTK". At 11.2 it is missing.

    What can i do?

  2. #2
    astrapi NNTP User

    Default QT4-Apps under GTK in 11.2 RC1

    Hello,

    i use openSUSE 11.1 with gnome 2.24. I have installed qgtkstyle. Because of that, QT4-Apps (vlc, virtualbox) use under gnome the gtk-theme.

    Now, i have installed openSUSE Factory (11.2). This comes with QT 4.5.3. The QGtkStyle is integradet in this. Now, the QT-Apps dont use the GTK-theme.

    In the "QT-4-Settings" under 11.1 there an option "GTK". At 11.2 it is missing.

    What can i do?

  3. #3

    Default Re: QT4-Apps under GTK in 11.2 RC1

    Quote Originally Posted by astrapi View Post
    What can i do?
    Wait and vote : https://bugzilla.novell.com/show_bug.cgi?id=557159

  4. #4

    Default Re: QT4-Apps under GTK in 11.2 RC1

    Is there a work-around in the mean-time? Has anyone built their own version on the OBS? Seems a bit odd that they'd remove one of the main features for cross-toolkit integration. I wondered why the one or two Qt apps I have on my Gnome install had started to look out of place!

  5. #5

    Default Re: QT4-Apps under GTK

    Not noticed any update on this and we're now well in to release, so I've tracked down my password, logged in and voted for the bug.

    I just tried looking in the Software Search for other builds, but "qt4" brings up loads of sub-libraries so it'd be a lot of poking and potentially wasted effort to find another build with it enabled. Google doesn't turn up much either (other than Ubuntu change logs saying that they added the GTK dev lib as a build dependency to enable the GTK support!)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •