Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: noise in the headphones

  1. #1

    Default noise in the headphones

    Hi, my problem is that there is an awful noise in my headphones. If, for example, i'm trying to play mp3 in amarok, i still can hear music but it is strongly mixed with noise (just like white noise). I tried to mute every channel in the Kmix - no use.

    I'm running Suse 11.1 on dell inspiron 1520 laptop. what to do?

  2. #2
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,345

    Default Re: noise in the headphones

    On Fri, 23 Oct 2009 16:06:01 +0000, counterspy wrote:

    > Hi, my problem is that there is an awful noise in my headphones. If, for
    > example, i'm trying to play mp3 in amarok, i still can hear music but it
    > is strongly mixed with noise (just like white noise). I tried to mute
    > every channel in the Kmix - no use.
    >
    > I'm running Suse 11.1 on dell inspiron 1520 laptop. what to do?


    I've seen this with various laptops I have used - one question comes to
    mind: Do you notice the noise only when the laptop is plugged in, or do
    you notice it both when it's plugged in and when it's on battery power?

    What I've been able to track down is that it's poor grounding either in
    the laptop or in the power; I typically only hear it when the laptop is
    plugged in and the system isn't properly grounded. It's like a 60 cycle
    hum.

    Jim

    --
    Jim Henderson
    openSUSE Forums Moderator

  3. #3

    Default Re: noise in the headphones

    The noise exists even when laptop is on the battary

  4. #4
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,345

    Default Re: noise in the headphones

    On Fri, 23 Oct 2009 17:16:01 +0000, counterspy wrote:

    > The noise exists even when laptop is on the battary


    Do you hear the noise with different headphones or through the built-in
    speakers?

    Jim



    --
    Jim Henderson
    openSUSE Forums Moderator

  5. #5

    Default Re: noise in the headphones

    Yes, i hear the noise with 3 different headphones, and no, i don't hear it from built in speakers. I found out that moving the Kmix slider corresponding to PC Beep significantly changes the level of the noise (the lowest level of PC Beep -> the lowest level of noise but still inappropriate). Maybe it's possible to disable PC Beep completely (muting it from Kmix does not help)?

  6. #6
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,345

    Default Re: noise in the headphones

    On Fri, 23 Oct 2009 19:36:01 +0000, counterspy wrote:

    > Yes, i hear the noise with 3 different headphones, and no, i don't hear
    > it from built in speakers. I found out that moving the Kmix slider
    > corresponding to PC Beep significantly changes the level of the noise
    > (the lowest level of PC Beep -> the lowest level of noise but still
    > inappropriate). Maybe it's possible to disable PC Beep completely
    > (muting it from Kmix does not help)?


    Can you disable the beep in the firmware?

    Maybe someone who's more familiar with the sound system will jump in with
    other ideas - what you described sounded very similar to the 60 cycle hum
    I have experienced myself, but beyond that, I'm just kinda shooting in
    the dark here. :-)

    Jim



    --
    Jim Henderson
    openSUSE Forums Moderator

  7. #7
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,138
    Blog Entries
    40

    Default Re: noise in the headphones

    This sort of problem can be difficult to sort, as there could be a hardware problem contributing to it. Are you able to operate this laptop with another operating system, and if so, does that other operating system have the problem? Or perhaps are you able to operate this laptop with a live CD, and if so does that liveCD have the problem? The intent here is to see if we can eliminate hardware as being the problem.

    Assuming the problem is NOT there with another OS, or not there with a liveCD, then its possibly your PCs openSUSE configuration. In which case to progress further a lot more information on your audio setup on your PC would help, which can be provided by running a diagnostic script and by running some commands. That may provide information such that a misconfiguration can be guessed at.

    Hence assuming this is not hardware, can you open a terminal and with your PC connected to the internet, run twice in a terminal:
    /usr/sbin/alsa-info.sh
    the first time run that with root permissions and select YES to the question do you wish to update? You need root permissions so the update to /usr/sbin directory can take place. The second time run it as a regular user, and select the SHARE/UPLOAD option. When the diagnostic script is complete, it will upload diagnostic information to the alsa web site and it will give you a URL. Please post that URL here. Just the URL.

    Then please also run the following in a terminal (and post here the output):
    rpm -qa '*alsa*'
    rpm -qa '*pulse*'
    rpm -q libasound2
    uname -a
    cat /etc/modprobe.d/sound

  8. #8

    Default Re: noise in the headphones

    all right
    1. I've got WinXP on the laptop and no noise in the headphones there

    2. Link to alsa-info:
    http://www.alsa-project.org/db/?f=5c...db0d83ce7fa067

    3. rpm -qa '*alsa*'
    Code:
    alsa-plugins-1.0.18-6.13
    alsa-plugins-jack-1.0.18-6.13
    alsa-tools-1.0.18-1.16
    alsamixergui-0.9.0rc1-584.91
    alsa-firmware-1.0.17-1.42
    alsa-plugins-pulse-1.0.18-6.13
    alsa-driver-kmp-default-1.0.21.20091021_2.6.27.29_0.1-1.1
    alsa-oss-1.0.17-1.43
    alsa-devel-1.0.18-8.12.1
    alsa-1.0.18-8.12.1
    alsa-driver-unstable-kmp-default-1.0.21.20091014_2.6.27.29_0.1-2.3
    alsa-utils-1.0.18-6.4
    alsa-docs-1.0.18-8.12.1
    alsa-oss-32bit-1.0.17-1.37
    alsa-tools-gui-1.0.18-1.16
    alsa-tools-devel-1.0.18-1.16
    4. rpm -qa '*pulse*'
    Code:
    pulseaudio-0.9.14-2.2.1
    pulseaudio-module-lirc-0.9.14-2.2.1
    pulseaudio-module-jack-0.9.14-2.2.1
    pulseaudio-module-x11-0.9.14-2.2.1
    pulseaudio-esound-compat-0.9.14-2.2.1
    alsa-plugins-pulse-1.0.18-6.13
    pulseaudio-lang-0.9.14-2.2.1
    libxine1-pulse-1.1.16.3-2.pm.6.10
    libpulse-mainloop-glib0-0.9.14-2.2.1
    libpulse-browse0-0.9.14-2.2.1
    pulseaudio-utils-0.9.14-2.2.1
    pulseaudio-module-zeroconf-0.9.14-2.2.1
    libpulse0-0.9.14-2.2.1
    pulseaudio-module-bluetooth-0.9.14-2.2.1
    5. rmp -q libasound2
    Code:
    libasound2-1.0.18-8.12.1
    6. uname -a
    Code:
    Linux linux-7e5n 2.6.27.29-0.1-default #1 SMP 2009-08-15 17:53:59 +0200 x86_64 x86_64 x86_64 GNU/Linux
    7. cat /etc/modprobe.d/sound
    Code:
    options snd slots=snd-hda-intel
    # u1Nb.uFfEBSd3JdA:82801H (ICH8 Family) HD Audio Controller
    alias snd-card-0 snd-hda-intel
    that's all i think. waiting for conclusions.

  9. #9
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,138
    Blog Entries
    40

    Default Re: noise in the headphones

    Quote Originally Posted by counterspy View Post
    3. rpm -qa '*alsa*'
    alsa-plugins-1.0.18-6.13
    alsa-plugins-jack-1.0.18-6.13
    alsa-tools-1.0.18-1.16
    alsamixergui-0.9.0rc1-584.91
    alsa-firmware-1.0.17-1.42
    alsa-plugins-pulse-1.0.18-6.13
    alsa-driver-kmp-default-1.0.21.20091021_2.6.27.29_0.1-1.1
    alsa-oss-1.0.17-1.43
    alsa-devel-1.0.18-8.12.1
    alsa-1.0.18-8.12.1
    alsa-driver-unstable-kmp-default-1.0.21.20091014_2.6.27.29_0.1-2.3
    alsa-utils-1.0.18-6.4
    alsa-docs-1.0.18-8.12.1
    alsa-oss-32bit-1.0.17-1.37
    alsa-tools-gui-1.0.18-1.16
    alsa-tools-devel-1.0.18-1.16
    OK, I see a mistake immediately, ... you have alsa-driver-unstable-kmp-default-1.0.21.20091014_2.6.27.29_0.1-2.3 installed on your PC in addition to alsa-driver-kmp-default-1.0.21.20091021_2.6.27.29_0.1-1.1. Why install an "unstable" kernel/module driver? That can lead to unstable/unpredictable results.

    This may or may not be contributing to the problem. I don't know. But IMHO you should fix this as it is not correct, and it can lead to problems that are difficult to understand,.

    So I recommend you remove that unstable alsa-driver-unstable-kmp-default-1.0.21.20091014_2.6.27.29_0.1-2.3 . You may need to re-install alsa-driver-kmp-default-1.0.21.20091021_2.6.27.29_0.1-1.1 (or the more recent version which is now on the multidia web site) if you lose sound afterward.

    Next, I note you still have the older 1.0.17/1.0.18 alsa application rpms with the 1.0.21 kernel module. IMHO that can lead to compatibility problems. You should update those !

    So, AFTER removing alsa-driver-unstable-kmp-default-1.0.21.20091014_2.6.27.29_0.1-2.3 then , ensure your OSS repository has a very LOW priority (which menas a very high number for priority - maybe set it to 100 or 105 - you can put its value back afterward). Also, remove your installation CD/DVD from your repository list. Then update your alsa applications by sending in a terminal, with your pc connected to the internet, copy and paste and execute the following 6 commands in sequence, one at a time!
    Code:
    zypper ar http://download.opensuse.org/repositories/multimedia:/libs/openSUSE_11.1/ multimediaalsa
    Code:
    zypper install alsa alsa-docs alsa-plugins alsa-plugins-jack alsa-tools alsa-firmware alsa-plugins-pulse alsa-oss alsa-devel alsa-utils alsa-oss-32bit alsa-tools-gui alsa-tools-devel libasound2
    Code:
    zypper rr multimediaalsa
    Code:
    zypper ar http://download.opensuse.org/repositories/multimedia:/audio:/KMP/openSUSE_11.1_Update/ multimediakmp
    Code:
    zypper install alsa-driver-kmp-default
    Code:
    zypper rr multimediakmp
    then restart your PC and test. If after updating alsa, and after restarting, you still have audio problems I need to do a quality check of what you have installed, so again give the output of:
    rpm -qa '*alsa*'

  10. #10

    Default Re: noise in the headphones

    Nice, man Everything is working, no noise but clear sound!!
    Thanks a lot!

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •