Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: Eclipse doesn't accept mouse clicks on buttons

  1. #1

    Default Eclipse doesn't accept mouse clicks on buttons

    11.2RC1

    I just downloaded the newest Eclipse, just to be sure, but I had the same problem with some older version.

    Start Eclipse, and for example try to create a new project. Enter the project's name and click Next. The button recognizes that it's being clicked (e.g. gets focus, changes color etc) but nothing happens. Pressing enter works (as the button has focus now). The same thing happens on the next screen with the Finish button.

    Can anyone confirm this behaviour?
    --
    Davor Čengija

  2. #2
    Jrg von Frantzius NNTP User

    Default Re: Eclipse doesn't accept mouse clicks on buttons

    On 10/23/2009 03:56 PM, dcengija wrote:
    > 11.2RC1
    >
    > I just downloaded the newest Eclipse, just to be sure, but I had the
    > same problem with some older version.
    >
    > Start Eclipse, and for example try to create a new project. Enter the
    > project's name and click Next. The button recognizes that it's being
    > clicked (e.g. gets focus, changes color etc) but nothing happens.
    > Pressing enter works (as the button has focus now). The same thing
    > happens on the next screen with the Finish button.
    >
    > Can anyone confirm this behaviour?
    >
    >
    >

    Yes, same here. Luckily, the keyboard accelerators (Alt+...) still work ;-)

    I also noticed that the "Install new software..." dialog would sometimes
    not show any contents. Switching off compositing effects seems to help here.

  3. #3

    Default Re: Eclipse doesn't accept mouse clicks on buttons

    Hm, I just succeeded to reproduce the problem with the desktop effects turned off, so I guess it's not related to compositing.

    I bet on gtk-qt link :-)
    --
    Davor Čengija

  4. #4
    Jrg von Frantzius NNTP User

    Default Re: Eclipse doesn't accept mouse clicks on buttons

    It may be this one: https://bugs.eclipse.org/bugs/show_bug.cgi?id=288909
    There GTK 2.17 is the culprit.

    On 10/23/2009 04:36 PM, dcengija wrote:
    > Hm, I just succeeded to reproduce the problem with the desktop effects
    > turned off, so I guess it's not related to compositing.
    >
    > I bet on gtk-qt link :-)
    >
    >
    >



  5. #5
    Marco NNTP User

    Default Re: Eclipse doesn't accept mouse clicks on buttons

    Am 23.10.2009 16:27, schrieb Jrg von Frantzius:
    > It may be this one: https://bugs.eclipse.org/bugs/show_bug.cgi?id=288909
    > There GTK 2.17 is the culprit.
    >
    > On 10/23/2009 04:36 PM, dcengija wrote:
    >> Hm, I just succeeded to reproduce the problem with the desktop effects
    >> turned off, so I guess it's not related to compositing.
    >>
    >> I bet on gtk-qt link :-)
    >>
    >>
    >>

    >


    Same problem here, no Effects enabled. Its very annoying and need to be
    fixed asap. If its GTK related, I hoping even more that there will be a
    QT port for swt.

  6. #6

    Default Re: Eclipse doesn't accept mouse clicks on buttons

    Quote Originally Posted by Jrg von Frantzius View Post
    It may be this one: https://bugs.eclipse.org/bugs/show_bug.cgi?id=288909
    There GTK 2.17 is the culprit.
    Ah... This looks really bad, almost a showstopper for me.

    I have similar problems with Lotus Notes (Eclipse RCP based).

    I'll file a bug report for opensuse.
    --
    Davor Čengija

  7. #7
    Marco NNTP User

    Default Re: Eclipse doesn't accept mouse clicks on buttons

    Am 23.10.2009 18:06, schrieb dcengija:
    >
    > Jrg von Frantzius;2054726 Wrote:
    >> It may be this one:
    >> https://bugs.eclipse.org/bugs/show_bug.cgi?id=288909
    >> There GTK 2.17 is the culprit.
    >>

    >
    > Ah... This looks really bad, almost a showstopper for me.
    >
    > I have similar problems with Lotus Notes (Eclipse RCP based).
    >
    > I'll file a bug report for opensuse.


    Could you please post the link to the bugreport after you could do it.

    I agree that this is a showstopper. Its almost impossible to work like this.


  8. #8
    rick0 NNTP User

    Default Re: Eclipse doesn't accept mouse clicks on buttons

    same here... (same problem in Aptana) on RC1

  9. #9

    Default Re: Eclipse doesn't accept mouse clicks on buttons

    Here's the bug repport:
    https://bugzilla.novell.com/show_bug.cgi?id=549849

    Please join the discussion, as this is really important issue.
    --
    Davor Čengija

  10. #10

    Default Re: Eclipse doesn't accept mouse clicks on buttons

    I use aptana and have had this problem in ubuntu 9.10, opensuse 11.2 and fedora 12... For me it's a showstopper since i use aptana daily, but hopefully this will be fixed. However you can also just select the button and press enter and it will work.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •