Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: ATI Redeon HD 4550 very jerky display

  1. #1

    Default ATI Redeon HD 4550 very jerky display

    Hi I just changed my graphics card. The computer came with an nVidia GT220 which has no Linux driver.

    I installed the proprietory ATI driver and get the full screen resolution - so static images look great - but anything moving (scrolling screens, movies, moving windows on the display, etc.) is very jerky. One click up on the scroll bar of a text based web page took 7 seconds to jerk its way up.

    Then I tried the drivers at http://www2.ati.com/suse/11.1. The result was slightly better but only just.

    The computer is a Dell Studio XPS i7 Core, with 8GB RAM running oprnSUSE 11.1.

    Movies are unwatchable unless I make the window very small - less than 800x600.

    If I boot Vista moving images are fast and clear.

    Any help or suggestions would be appreciated.

    Here's my /etc/X11/XF86Config file:

    # /.../
    # SaX generated X11 config file
    # Created on: 2009-10-23T09:43:54+1100.
    #
    # Version: 8.1
    # Contact: Marcus Schaefer <sax@suse.de>, 2005
    # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
    #
    # Automatically generated by [ISaX] (8.1)
    # PLEASE DO NOT EDIT THIS FILE!
    #

    Section "ServerLayout"
    Identifier "Layout[all]"
    Screen 0 "Screen[0]" 0 0
    InputDevice "Keyboard[0]" "CoreKeyboard"
    InputDevice "Mouse[1]" "CorePointer"
    Option "Clone" "off"
    Option "Xinerama" "off"
    EndSection

    Section "Files"
    InputDevices "/dev/gpmdata"
    InputDevices "/dev/input/mice"
    FontPath "/usr/share/fonts/misc:unscaled"
    FontPath "/usr/share/fonts/local"
    FontPath "/usr/share/fonts/75dpi:unscaled"
    FontPath "/usr/share/fonts/100dpi:unscaled"
    FontPath "/usr/share/fonts/Type1"
    FontPath "/usr/share/fonts/URW"
    FontPath "/usr/share/fonts/Speedo"
    FontPath "/usr/share/fonts/PEX"
    FontPath "/usr/share/fonts/cyrillic"
    FontPath "/usr/share/fonts/latin2/misc:unscaled"
    FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/Type1"
    FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
    FontPath "/usr/share/fonts/baekmuk:unscaled"
    FontPath "/usr/share/fonts/japanese:unscaled"
    FontPath "/usr/share/fonts/kwintv"
    FontPath "/usr/share/fonts/truetype"
    FontPath "/usr/share/fonts/uni:unscaled"
    FontPath "/usr/share/fonts/CID"
    FontPath "/usr/share/fonts/ucs/misc:unscaled"
    FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
    FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/misc:unscaled"
    FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/Type1"
    FontPath "/usr/share/fonts/misc/sgi:unscaled"
    FontPath "/usr/share/fonts/xtest"
    FontPath "/opt/kde3/share/fonts"
    EndSection

    Section "Module"
    Load "dbe"
    Load "freetype"
    Load "extmod"
    Load "glx"
    Load "dri"
    EndSection

    Section "ServerFlags"
    Option "AIGLX" "on"
    Option "AllowMouseOpenFail" "on"
    Option "IgnoreABI" "on"
    Option "ZapWarning" "on"
    EndSection

    Section "InputDevice"
    Identifier "Keyboard[0]"
    Driver "kbd"
    Option "Protocol" "Standard"
    Option "XkbLayout" "us"
    Option "XkbModel" "microsoftpro"
    Option "XkbRules" "xfree86"
    EndSection

    Section "InputDevice"
    Identifier "Mouse[1]"
    Driver "mouse"
    Option "Buttons" "14"
    Option "Device" "/dev/input/mice"
    Option "Name" "Logitech 2.4GHz Cordless Desktop"
    Option "Protocol" "explorerps/2"
    Option "Vendor" "Sysp"
    Option "ZAxisMapping" "4 5"
    EndSection

    Section "Modes"
    Identifier "Modes[0]"
    ModeLine "1920x1080" 148.0 1920 2008 2052 2200 1080 1084 1089 1125
    EndSection

    Section "Monitor"
    Identifier "Monitor[0]"
    VendorName "DEL"
    ModelName "DELL ST2310"
    UseModes "Modes[0]"
    DisplaySize 510 287
    HorizSync 30.0 - 83.0
    VertRefresh 43.0 - 76.0
    Option "CalcAlgorithm" "XServerPool"
    Option "DPMS"
    Option "PreferredMode" "1920x1080"
    EndSection

    Section "Device"
    Identifier "Device[0]"
    Driver "fglrx"
    VendorName "ATI"
    BoardName "RV710 (RV710 9540)"
    Option "XAANoOffscreenPixmaps" "true"
    Option "Capabilities" "0x00000000"
    Option "OpenGLOverlay" "off"
    Option "FSAAScale" "0"
    Option "FSAAEnable" "off"
    Option "VideoOverlay" "on"
    BusID "PCI:5:0:0"
    EndSection


    Section "Screen"
    Identifier "Screen[0]"
    Device "Device[0]"
    Monitor "Monitor[0]"
    DefaultDepth 24
    SubSection "Display"
    Depth 15
    Modes "1920x1080" "1680x1050" "1600x1024" "1600x1000" "1400x1
    050" "1600x900" "1280x1024" "1440x900" "1280x960" "1366x768" "1360x768" "1280x80
    0" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "
    768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "1920x1080" "1680x1050" "1600x1024" "1600x1000" "1400x1
    050" "1600x900" "1280x1024" "1440x900" "1280x960" "1366x768" "1360x768" "1280x80
    0" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "
    768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1920x1080" "1680x1050" "1600x1024" "1600x1000" "1400x1
    050" "1600x900" "1280x1024" "1440x900" "1280x960" "1366x768" "1360x768" "1280x80
    0" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "
    768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "1920x1080" "1680x1050" "1600x1024" "1600x1000" "1400x1
    050" "1600x900" "1280x1024" "1440x900" "1280x960" "1366x768" "1360x768" "1280x80
    0" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "
    768x576" "640x480"
    EndSubSection
    EndSection

    Section "DRI"
    Group "video"
    Mode 0660
    EndSection

    Section "Extensions"
    Option "Composite" "on"
    EndSection

  2. #2

    Default Re: ATI Redeon HD 4550 very jerky display

    djmills wrote:

    >
    > Hi I just changed my graphics card. The computer came with an nVidia
    > GT220 which has no Linux driver.
    >
    > I installed the proprietory ATI driver and get the full screen
    > resolution - so static images look great - but anything moving
    > (scrolling screens, movies, moving windows on the display, etc.) is very
    > jerky. One click up on the scroll bar of a text based web page took 7
    > seconds to jerk its way up.
    >
    > Then I tried the drivers at http://www2.ati.com/suse/11.1. The result
    > was slightly better but only just.
    >


    These are the same symptoms I'm getting with 11.2 RC1 and using the default
    driver. The card is ATI Radeon HD 2400. I also had the same trouble with
    nVidia GeForce FX 5200 in 11.2 M8 but it's OK in RC1.

    I'm getting none of the problems in 11.1 with the default driver.

    See http://bugzilla.novell.com/show_bug.cgi?id=547603

    --
    Graham P Davis, Bracknell, Berks., UK. E-mail: newsman not newsboy
    "I wear the cheese. It does not wear me."

  3. #3
    Join Date
    May 2009
    Location
    Nieuwegein, Netherlands
    Posts
    27

    Default Re: ATI Redeon HD 4550 very jerky display

    Try removing all the Options from the "Device" section in your xorg.conf file. They are not required for the fglrx driver. In fact I think the VideoOverlay option is the culprit, it should be off.

    Te be sure the new settings are used, best is to remove the file amdpcsdb from /etc/ati, on the commandline enter 'aticonfig --initial' and restart your computer. (You need to have root permissions to remove the file and to execute the command. If hou don know how, open a terminal, enter 'su' and provide the root password.)

    Good luck

    Admo

  4. #4

    Default Re: ATI Redeon HD 4550 very jerky display

    Hi Admo, thanks for the advice.

    I removed those Options from Device, removed the amdpcsdb file (there was also an amdpcsdb.default file which I didn't touch) and ran aticonfig --initial. Then I rebooted.

    aticonfig --initial changed the xorg.conf file but didn't re-instate the Options in Device.

    Unfortunately things haven't improved at all. Watching a movie is still a jerky mess.

    Any other ideas?

    The new xorg.conf file is:

    # /.../
    # SaX generated X11 config file
    # Created on: 2009-10-23T21:28:11+1100.
    #
    # Version: 8.1
    # Contact: Marcus Schaefer <sax@suse.de>, 2005
    # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
    #
    # Automatically generated by [ISaX] (8.1)
    # PLEASE DO NOT EDIT THIS FILE!
    #

    Section "ServerLayout"
    Identifier "Layout[all]"
    Screen 0 "Screen[0]" 0 0
    InputDevice "Keyboard[0]" "CoreKeyboard"
    InputDevice "Mouse[1]" "CorePointer"
    Option "Clone" "off"
    Option "Xinerama" "off"
    EndSection

    Section "Files"
    InputDevices "/dev/gpmdata"
    InputDevices "/dev/input/mice"
    FontPath "/usr/share/fonts/misc:unscaled"
    FontPath "/usr/share/fonts/local"
    FontPath "/usr/share/fonts/75dpi:unscaled"
    FontPath "/usr/share/fonts/100dpi:unscaled"
    FontPath "/usr/share/fonts/Type1"
    FontPath "/usr/share/fonts/URW"
    FontPath "/usr/share/fonts/Speedo"
    FontPath "/usr/share/fonts/PEX"
    FontPath "/usr/share/fonts/cyrillic"
    FontPath "/usr/share/fonts/latin2/misc:unscaled"
    FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/Type1"
    FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
    FontPath "/usr/share/fonts/baekmuk:unscaled"
    FontPath "/usr/share/fonts/japanese:unscaled"
    FontPath "/usr/share/fonts/kwintv"
    FontPath "/usr/share/fonts/truetype"
    FontPath "/usr/share/fonts/uni:unscaled"
    FontPath "/usr/share/fonts/CID"
    FontPath "/usr/share/fonts/ucs/misc:unscaled"
    FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
    FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/misc:unscaled"
    FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/Type1"
    FontPath "/usr/share/fonts/misc/sgi:unscaled"
    FontPath "/usr/share/fonts/xtest"
    FontPath "/opt/kde3/share/fonts"
    EndSection

    Section "Module"
    Load "freetype"
    Load "glx"
    Load "dbe"
    Load "extmod"
    Load "dri"
    EndSection

    Section "ServerFlags"
    Option "AIGLX" "on"
    Option "AllowMouseOpenFail" "on"
    Option "IgnoreABI" "on"
    Option "ZapWarning" "on"
    EndSection

    Section "InputDevice"
    Identifier "Keyboard[0]"
    Driver "kbd"
    Option "Protocol" "Standard"
    Option "XkbLayout" "us"
    Option "XkbModel" "microsoftpro"
    Option "XkbRules" "xfree86"
    EndSection

    Section "InputDevice"
    Identifier "Mouse[1]"
    Driver "mouse"
    Option "Buttons" "14"
    Option "Device" "/dev/input/mice"
    Option "Name" "Logitech 2.4GHz Cordless Desktop"
    Option "Protocol" "explorerps/2"
    Option "Vendor" "Sysp"
    Option "ZAxisMapping" "4 5"
    EndSection

    Section "Modes"
    Identifier "Modes[0]"
    ModeLine "1920x1080" 148.0 1920 2008 2052 2200 1080 1084 1089 1125
    EndSection

    Section "Monitor"
    Identifier "Monitor[0]"
    VendorName "DEL"
    ModelName "DELL ST2310"
    UseModes "Modes[0]"
    DisplaySize 510 287
    HorizSync 30.0 - 83.0
    VertRefresh 43.0 - 76.0
    Option "CalcAlgorithm" "XServerPool"
    Option "DPMS"
    Option "PreferredMode" "1920x1080"
    EndSection

    Section "Device"
    Identifier "Device[0]"
    Driver "fglrx"
    VendorName "ATI"
    BoardName "RV710 (RV710 9540)"
    BusID "PCI:5:0:0"
    EndSection

    Section "Screen"
    Identifier "Screen[0]"
    Device "Device[0]"
    Monitor "Monitor[0]"
    DefaultDepth 24
    SubSection "Display"
    Depth 15
    Modes "1920x1080" "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1600x900" "1280x102
    4" "1440x900" "1280x960" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "12
    80x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "1920x1080" "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1600x900" "1280x102
    4" "1440x900" "1280x960" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "12
    80x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1920x1080" "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1600x900" "1280x102
    4" "1440x900" "1280x960" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "12
    80x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "1920x1080" "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1600x900" "1280x102
    4" "1440x900" "1280x960" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "12
    80x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    EndSection

    Section "DRI"
    Group "video"
    Mode 0660
    EndSection

    Section "Extensions"
    Option "Composite" "on"
    EndSection


    I'm happy to supply my /var/log/Xorg.0.log file if that would help (it wouldn't let me add it to this post as it made it too long).

    Thanks, David.

  5. #5

    Default Re: ATI Redeon HD 4550 very jerky display

    ATI released a new driver - ati-driver-installer-9-10-x86.x86_64.run. I uninstalled all previous versions - both Yast2 installed ones and the one from the previous ati download.

    But still things are no better.

  6. #6

    Default Re: ATI Redeon HD 4550 very jerky display

    Hmmm, you've already tried some of my ATI suggestions, but here are the others:

    1. Your xorg.conf file has a lot of extra stuff in it. In my system, I removed most of the font paths; also the modules and mode entries--no need with EDID these days. Check your /var/log/Xorg.0.log file for errors and warnings.

    2. I assume you did not run sax2. ATI recommends aticonfig and amdcccle.

    3. The compiz user forum has a longrunning thread regarding setting up ATI cards. Worth a look; google user djdoo.

    4. See your /usr/share/ati/fglrx-install.log file for install info.

    What does htop say when your system gets unresponsive?

    HTH

  7. #7

    Cool Re: ATI Redeon HD 4550 very jerky display

    Hi HTH, Thank you VERY VERY MUCH!

    During my multiple attempts to install both the openSUSE's versions of the ATI drivers and ATI's themselves I never got any messages suggesting that the install hadn't worked. Indeed I went from only having a screen resolution of 1280x1024 to the full 1920x1080.

    This led me to believe that the install had worked.

    But your suggestion of looking into /usr/share/ati/fglrx-install.log led me to find the culprit. It had a message that it couldn't find /usr/src/linux/include/linux/version.h and some other stuff. So I installed kernel-source and reinstalled the ATI 9.10 driver. This time /usr/share/ati/fglrx-install.log had a lot of stuff that it didn't before including instructions to

    cd /lib/modules/fglrx
    ./make_install.sh

    Then I rebooted and now web page scrolling is lightning fast, watching movies is clear and smooth, etc. Basically all works as expected.

    So thanks to all for their help.

  8. #8

    Default Re: ATI Redeon HD 4550 very jerky display

    OK, next issue. No desktop effects are working. OpenGL seems to be missing. How do I enable OpenGL with the ATI driver?

  9. #9
    Join Date
    May 2009
    Location
    Nieuwegein, Netherlands
    Posts
    27

    Default Re: ATI Redeon HD 4550 very jerky display

    Hi djmills,

    Good you git things working so far. Why do you think OpenGL is the problem? OpenGL should not be the problem, because the necessary librairies are installed with the ATI-driver.

    Did you enable desktop effects? If not, you first should enable it. It is not clear to me if you are using KDE or Gnome. In KDE in the menu go to 'Personal Settings', click Desktop, and in Desktop effects check "Enable desktop effects". In Gnome in the menu select 'Control Centre', in the 'Look and Feel' group select Desktop Effects and enable the Desktop effects. By the way, Alt+Shift+F12 makes it possible to toggle desktop effects on and off. Maybe you can try if desktop effects is suspended by pressing this key-combination.

    If desktop effects still is not working, check the /var/log/Xorg.0.log file for errors. This provides more information where the problem is. If you see errors, send the log file.

    Admo

  10. #10

    Default Re: ATI Redeon HD 4550 very jerky display

    Hi, I did enable Desktop effects. I'm using KDE 4.1.3.

    I get the message "Failed to activate desktop effects using the given configuration options. Settings will be reverted to their previous values.

    Check your X configuration. You may also consider changing advanced options, especially changing the compositing type." I have tried all combinations of the possible settings and none work.

    One page I found on the web on another forum suggested that OpenGL might be the culprit in this circumstance.

    Or have you got any other ideas?

    Thanks,

    David.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •