Results 1 to 4 of 4

Thread: Dnsmasq and dhcpclient problem

  1. #1

    Default Dnsmasq and dhcpclient problem

    I had Dnsmasq server running for a while now and only thing I changed since on the DNS/DHCP server is running fwbuilder script at startup in init. The fwbuilder script is still the same script I have been using since setting up Dnsmasq. The client terminal is having trouble reaching the outside world.

    Default-Gateway: 192.168.0.1

    What I can do on the client terminal:
    ping 192.168.0.1 Works
    host google.com Works
    ping 74.125.45.100 Fail

    From the server terminal:
    ping 192.168.0.3 Works
    ssh 192.168.0.3 Works

    Code:
    comp2:~ # route
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    192.168.0.0     *               255.255.255.0   U     0      0        0 eth0
    link-local      *               255.255.0.0     U     0      0        0 eth0
    loopback        *               255.0.0.0       U     0      0        0 lo
    default         netsrv.comp1.lo 0.0.0.0         UG    0      0        0 eth0
    comp2:~ #
    In dnsmasq.conf I had set:
    dhcp-option=3,192.168.0.1

    I don't know why dhcp-client is setting default router to
    default netsrv.comp1.lo 0.0.0.0 UG 0 0 0 eth0

    Anyone who has insight to this issue of why it's doing this please, I would appreciate the info/help... Thank You...

  2. #2

    Default Re: Dnsmasq and dhcpclient problem

    Server Terminal: Fedora 11
    Client Terminal: Opensuse 11.1

  3. #3
    PV NNTP User

    Default Re: Dnsmasq and dhcpclient problem

    On Thu October 22 2009 11:16 pm, lhorace wrote:

    >
    > Server Terminal: Fedora 11
    > Client Terminal: Opensuse 11.1
    >
    >

    lhorace;

    What do you get with:
    Code:
    /sbin/route -n
    ?
    --
    P. V.
    "We're all in this together, I'm pulling for you." Red Green

  4. #4

    Default Re: Dnsmasq and dhcpclient problem

    Thanks P.V.
    The problem was on Server Terminal. ipv4_foward was at 0. I use fwbuilder Firewall script during system boot up, it sets up iptables (Nat,firewall, and ipv4_foward). I don't know why ipv4_foward was still at 0 and i'm investigation the issue. Again 'route -n' was what I was specifically looking for, thanks for that tip =)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •