Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Problem : uname -r returns outdated kn version

  1. #1

    Default Problem : uname -r returns outdated kn version

    Hi !

    It's been a while before, I noticed that every time I needed to compile a kernel module, the headers were not matching current kernel. e.g. today the kernel 2.6.29 is installed (for sure) on my osuse 11.1, but uname -r returns 2.6.19 and before the install with Yast2.

    Now that can be resolved using yast and downgrading kernel-sources to the 2.6.19 release, quite embarassing because 2.6.19 kernel-syms seem not available anymore..


  2. #2
    palladium NNTP User

    Default Re: Problem : uname -r returns outdated kn version

    as far as i know it is possible to have many kernels installed at the
    same time...but, only one can be booted at a time..

    do this, in a terminal:

    sudo cat /boot/grub/menu.lst

    give your root password when asked, and copy past the results back to
    here..

    --
    palladium

  3. #3

    Default Re: Problem : uname -r returns outdated kn version

    Code:
    # Modified by YaST2. Last modification on Wed Sep 30 02:59:53 CEST 2009
    default 4
    timeout 30
    gfxmenu (hd0,6)/boot/message
    ##YaST - activate
    
    ###Don't change this comment - YaST2 identifier: Original name: linux###
    title openSUSE 11.1 - 2.6.27.29-0.1 (default)
        root (hd0,6)
        kernel /boot/vmlinuz-2.6.27.29-0.1-default root=/dev/disk/by-id/ata-SAMSUNG_SP1614N_S016J10X225162-part7 resume=/dev/disk/by-id/ata-SAMSUNG_SP1614N_S016J10X225162-part6 splash=silent showopts vga=0x317
        initrd /boot/initrd-2.6.27.29-0.1-default
    
    ###Don't change this comment - YaST2 identifier: Original name: failsafe###
    title Failsafe -- openSUSE 11.1 - 2.6.27.29-0.1 (default)
        root (hd0,6)
        kernel /boot/vmlinuz-2.6.27.29-0.1-default root=/dev/disk/by-id/ata-SAMSUNG_SP1614N_S016J10X225162-part7 showopts ide=nodma apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe vga=0x317
        initrd /boot/initrd-2.6.27.29-0.1-default
    
    ###Don't change this comment - YaST2 identifier: Original name: linux###
    title openSUSE 11.1 - 2.6.27.29-0.1 (pae)
        root (hd0,6)
        kernel /boot/vmlinuz-2.6.27.29-0.1-pae root=/dev/disk/by-id/ata-SAMSUNG_SP1614N_S016J10X225162-part7 resume=/dev/disk/by-id/ata-SAMSUNG_SP1614N_S016J10X225162-part6 splash=silent showopts vga=0x317
        initrd /boot/initrd-2.6.27.29-0.1-pae
    
    ###Don't change this comment - YaST2 identifier: Original name: failsafe###
    title Failsafe -- openSUSE 11.1 - 2.6.27.29-0.1 (pae)
        root (hd0,6)
        kernel /boot/vmlinuz-2.6.27.29-0.1-pae root=/dev/disk/by-id/ata-SAMSUNG_SP1614N_S016J10X225162-part7 showopts ide=nodma apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe vga=0x317
        initrd /boot/initrd-2.6.27.29-0.1-pae
    
    ###Don't change this comment - YaST2 identifier: Original name: windows###
    title Windows
        rootnoverify (hd0,0)
        chainloader +1

  4. #4
    palladium NNTP User

    Default Re: Problem : uname -r returns outdated kn version

    well, i'm stumped..

    i wonder how uname learns the kernel version...i had thought it would
    look inside the kernel, but apparently it is reading from file name..

    my GUESS is you have (somehow) an actual 2.6.19 kernel (on the inside)
    that is named 2.6.29 on the outside..

    would you know how to CAREFULLY look in your /boot directory, and look
    at what kernels you have there, what they are named and how that
    compares to their internals (CAREFUL, do not change them)..

    --
    palladium

  5. #5

    Thumbs down Re: Problem : uname -r returns outdated kn version

    Code:
     ls -i /boot/
    952161 backup_mbr                            953377 symtypes-2.6.27.29-0.1-default.gz
    952145 boot                                  952164 symtypes-2.6.27.29-0.1-pae.gz
    952144 boot.readme                           953378 symvers-2.6.27.29-0.1-default.gz
    953273 config-2.6.27.29-0.1-default          952165 symvers-2.6.27.29-0.1-pae.gz
    952158 config-2.6.27.29-0.1-pae              953190 System.map-2.6.27.29-0.1-default
    952131 grub                                  952149 System.map-2.6.27.29-0.1-pae
    952146 initrd                                953396 vmlinux-2.6.27.29-0.1-default.gz
    953675 initrd-2.6.27.29-0.1-default          952166 vmlinux-2.6.27.29-0.1-pae.gz
    952168 initrd-2.6.27.29-0.1-pae              952148 vmlinuz
    952147 message                               953402 vmlinuz-2.6.27.29-0.1-default
    953318 symsets-2.6.27.29-0.1-default.tar.gz  952167 vmlinuz-2.6.27.29-0.1-pae
    952163 symsets-2.6.27.29-0.1-pae.tar.gz
    Quote Originally Posted by palladium
    my GUESS is you have (somehow) an actual 2.6.19 kernel (on the inside)
    that is named 2.6.29 on the outside..
    That's what I thought too... Anyway these all kernels are coming from official suse repos..

  6. #6
    palladium NNTP User

    Default Re: Problem : uname -r returns outdated kn version

    but you didn't look inside yet...try, in a terminal

    sudo cat /boot/vml* | grep -a 2.6.19

    which should return nothing...

    and,

    sudo cat /boot/vml* | grep -a 2.6.29

    which should return a lot (of garbage looking code)

    but, STILL i say i'm stumped and just trying to entertain the REAL
    gurus (reading and laughing as i flounder), until they decide to step
    in and help..

    --
    palladium

  7. #7

    Default Re: Problem : uname -r returns outdated kn version

    now I see what you pointed out : yes there are 2.6.27.29 but there's no 2.6.27.19 in.
    Code:
    ls -l /boot
    ....
    lrwxrwxrwx 1 root root      29 sept. 30 03:04 vmlinuz -> vmlinuz-2.6.27.29-0.1-default
    ....
    
    linux-jsxl:/home/tiana/Documents # uname -r
    2.6.27.19-3.2-default
    linux-jsxl:/home/tiana/Documents # ls /boot/vml* | grep -a 2.6.27.
    /boot/vmlinux-2.6.27.29-0.1-default.gz
    /boot/vmlinux-2.6.27.29-0.1-pae.gz
    /boot/vmlinuz-2.6.27.29-0.1-default
    /boot/vmlinuz-2.6.27.29-0.1-pae
    linux-jsxl:/home/tiana/Documents # ls /boot/vml* | grep -a 2.6.
    /boot/vmlinux-2.6.27.29-0.1-default.gz
    /boot/vmlinux-2.6.27.29-0.1-pae.gz
    /boot/vmlinuz-2.6.27.29-0.1-default
    /boot/vmlinuz-2.6.27.29-0.1-pae
    linux-jsxl:/home/tiana/Documents # cat /boot/vml* | grep -a 2.6.27.
    ,��Jvmlinux-2.6.27.29-0.1-default�;TSW�7
                                           ɾ@C�*▒$t�u;��F8��`�-
    �����/�x���0m�)����zap�|
          ��C�?ra�~z�+��߼0x}▒��Rx9��CW���{;7������{G�����[�ݨ��φ�܉��pyn�+s�}?���`��#�>���9n���������u�"��p;�ɷ:��})|����▒���t(��N=▒��τ/[�L�ij��/D>�\�zT﯄��7"����M���?���N��φr�����P����f%���
                         ��0��
                              c�:��=��ȃ�����Jvmlinux-2.6.27.29-0.1-pae�<mtוO�Ȗl�Q�����R6��I��>ǃm0_�:��e7��HZh
    �d㸜��=g��Yd��"�!9�1    58<�    ���/vm�9{����9���{����_��{��G�3▒
                                                                    d▒��D�������(��'�� ed��og��n�3��Y��<
    2.6.27.29-0.1-default (geeko@buildhost) #1 SMP 2009-08-15 17:53:59 +0200VGACGA/MDA/HGCEGA�$�$;%`&&m%�%`1P1▒1]0i0Y0VESABIOSY0$$o&�0�(�&�0�*W+�DDPP2P+PPP"P<PP+PU�ZZ��@u��▒�؎�����Ѝ���]��%����������+����
                                           +%��
                                               ���������V��d�%��d�%�d�%����^����������+%���*%���J�;tSU�7�K��)/��)��Ԗu▒-��1��"ⴥ��*J�rXF9����1�(�v���+�N��uu�SҰ#/}Н�����⺯����~�}iKa�sf��=ͻ�����������&}n��R�NGF��▒��f%y�|�J){�#v▒�A���q+{Ȭa��}��~6��}�2|H��DB*l$16�A�3�Av^�K�q�#Ɵ#�/�/�/�/�/�/�/���.C[S����6^�>=���2�sG�yGh�z�) �jұr�j2�b`��d�Z�� �WZ�1k�#�o��4�n#B�N��k�ۀ�a�ۉ�bR�>q�eR@���*j��QRCڮD�I���{���W   �(�׺jHV�p7o�{��!�2>9�0��"�6��ӱ7��o{2��C������d>ׇ����x���P��g2tV�J������Z��Sd�{
                                                                                 A6��FŞݵ���=��k@˰���
               �!m��7;9e��6ĤS��g�{�L���,
                                        �2�����K�9Y�^
                                                     �-�)�9EdH-���N�$l��#�]�I��� �Z�=�tWV������W0�Uķ�#�▒�ӞSޡ����Z�-��eħ�s)�>
    2.6.27.29-0.1-default (geeko@buildhost) #1 SMP 2009-08-15 17:53:59 +0200VGACGA/MDA/HGCEGA�$�$;%`&&m%�%`1P1▒1]0i0Y0VESABIOSY0$$o&�0�(�&�0�*W+�DDPP2P+PPP"P<PP+PU�ZZ��@u��▒�؎�����Ѝ���]��%����������+����
                                           +%��
                                               ���������V��d�%��d�%�d�%����^����������+%���*%���J�;tSU�7�K��)/��)��Ԗu▒-��1��"ⴥ��*J�rXF9����1�(�v���+�N��uu�SҰ#/}Н�����⺯����~�}iKa�sf��=ͻ�����������&}n��R�NGF��▒��f%y�|�J){�#v▒�A���q+{Ȭa��}��~6��}�2|H��DB*l$16�A�3�Av^�K�q�#Ɵ#�/�/�/�/�/�/�/���.C[S����6^�>=���2�sG�yGh�z�) �jұr�j2�b`��d�Z�� �WZ�1k�#�o��4�n#B�N��k�ۀ�a�ۉ�bR�>q�eR@���*j��QRCڮD�I���{���W   �(�׺jHV�p7o�{��!�2>9�0��"�6��ӱ7��o{2��C������d>ׇ����x���P��g2tV�J������Z��Sd�{
                                                                                 A6��FŞݵ���=��k@˰���
               �!m��7;9e��6ĤS��g�{�L���,
                                        �2�����K�9Y�^
                                                     �-�)�9EdH-���N�$l��#�]�I��� �Z�=�tWV������W0�Uķ�#�▒�ӞSޡ����Z�-��eħ�s)�>
    2.6.27.29-0.1-pae (geeko@buildhost) #1 SMP 2009-08-15 17:53:59 +0200VGACGA/MDA/HGCEGA�$�$;%`&&m%�%p1`1(1i0u0e0VESABIOSe0$$o&�0�(�&�0�*W+� D DPP2P+PPP"P<PP+PU�ZZ��@u��▒�؎�����Ѝ���]��%����������+�����%��
                                             ���������V��dP&��dP&�dP&����^�����������%��w�%A��J�<mtוO��H��Q�����R6��I��>+�m0_�:��e7��H▒h
    �d㸜��=g��Yd��"�!9�1    58      ���-��������ECڜ���=�͛��׻��;3�=����s
                                                                       #1��N�(gw�  �=�ȣd��og��*n7����߃m~d��qОI�%�9��"����

  8. #8
    palladium NNTP User

    Default Re: Problem : uname -r returns outdated kn version

    broumbroum23 wrote:
    > now I see what you pointed out : yes there are 2.6.27.29 but there's no
    > 2.6.27.19 in.


    then the questions are:

    From where is uname getting its wrong information? and
    Why can't you get your booted kernel and kernel headers to match?

    and, again i say: i'm stumped..

    --
    palladium

  9. #9
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,339
    Blog Entries
    15

    Default Re: Problem : uname -r returns outdated kn version

    Quote Originally Posted by broumbroum23
    Code:
    --------------------
    ls -i /boot/
    952161 backup_mbr 953377
    symtypes-2.6.27.29-0.1-default.gz 952145
    boot 952164
    symtypes-2.6.27.29-0.1-pae.gz 952144
    boot.readme 953378
    symvers-2.6.27.29-0.1-default.gz 953273
    config-2.6.27.29-0.1-default 952165
    symvers-2.6.27.29-0.1-pae.gz 952158
    config-2.6.27.29-0.1-pae 953190
    System.map-2.6.27.29-0.1-default 952131
    grub 952149
    System.map-2.6.27.29-0.1-pae 952146
    initrd 953396
    vmlinux-2.6.27.29-0.1-default.gz 953675
    initrd-2.6.27.29-0.1-default 952166
    vmlinux-2.6.27.29-0.1-pae.gz 952168
    initrd-2.6.27.29-0.1-pae 952148 vmlinuz 952147
    message 953402
    vmlinuz-2.6.27.29-0.1-default 953318
    symsets-2.6.27.29-0.1-default.tar.gz 952167 vmlinuz-2.6.27.29-0.1-pae
    952163 symsets-2.6.27.29-0.1-pae.tar.gz --------------------

    palladium Wrote:
    > my GUESS is you have (somehow) an actual 2.6.19 kernel (on the inside)
    > that is named 2.6.29 on the outside..

    That's what I thought too... Anyway these all kernels are coming from
    official suse repos..
    Hi
    If you run the command ls -la on /boot. Are vmlinuz and initrd
    softlinks to the 29-0.1 kernel?

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.2 RC 1 (i586) Kernel 2.6.31.3-1-desktop
    up 14:06, 2 users, load average: 0.38, 0.22, 0.12
    ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME


  10. #10

    Unhappy Re: Problem : uname -r returns outdated kn version

    yes, they do.
    I ain't no kernel developer, and I can't figure out where the error is to be found. looking at the uname manpage and doc would lead me to the utsname.h source file...
    Visit my OBS repository w/ various packages (java apps, some devices modules) !
    http://download.opensuse.org/repositories/home://broumbroum23/
    openSUSE_11.1_oss/
    openSUSE_11.2_oss/


Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •