Results 1 to 3 of 3

Thread: virtualbox-ose installs wrong kernel module package?

  1. #1

    Default virtualbox-ose installs wrong kernel module package?

    When I install virtualbox-ose on 11.2 RC1, virtualbox-ose-kmp-desktop is automatically selected for install. However, this package does not contain the right kernel module for the default kernel. To install the right kernel module I had to install virtualbox-ose-kmp-default. Only then, after a "modprobe vboxdrv", the kernel module was found and I could use virtualbox.

    Is the dependency incorrect or is it me that is doing something wrong?

    By the way, I am using the Gnome build.

    Kind regards, Pieter.

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: virtualbox-ose installs wrong kernel module package?

    H landgenoot.

    There's something going on around the kernels. RC1 installer defaults to kernel-desktop. Did installing the kmp require the install of kernel-default as well? You should see that at boot in GRUB.

    Please open a terminal window and post output of:

    rpm -qa | grep kernel
    AND
    rpm -qa | grep virtual

    That way we can see what you have installed.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Re: virtualbox-ose installs wrong kernel module package?

    > H landgenoot.

    Hoi ,

    Thanks for the info, I may have a clue what is going wrong and if my theory is right, it is all my own mistake. Initially I did not know which virtualbox packages I had to install and I installed several of them. Their installation (or the installation of their dependencies) changed my GRUB settings: I now had multiple "openSuse 11.2 xyz" entries. I got the feeling that this was not the way to proceed and I removed all virtualbox packages. But if I remember correctly, my GRUB settings were not restored and I had to do that manually. What if the installation of one of the packages changed the GRUB entry "OpenSuse 11.2" to use the default kernel instead of the desktop one? I have removed all "openSuse 11.2 xyz" entries except the one labeled "Opensuse 11.2" ... So when I select that one, I get the default kernel. This would explain my problems with the later attempts at using Virtualbox, whose package assumes I am using the desktop kernel.

    This scenario seems plausible (to me at least). The only way to verify my theory is to reinstall 11.2. I might do that when RC2 comes out. Until then I assume it has all been my own wrong doing. Thanks for the pointer in the (probably) right direction.

    Kind regards, Pieter.

    For the sake of completeness, here is the requested output of "rpm -qa | grep kernel" is

    linux-kernel-headers-2.6.31-2.4.noarch
    kernel-syms-2.6.31.3-1.1.i586
    kernel-desktop-2.6.31.3-1.1.i586
    kernel-debug-2.6.31.3-1.1.i586
    kernel-desktop-devel-2.6.31.3-1.1.i586
    kernel-firmware-20090821-3.1.noarch
    kernel-default-2.6.31.3-1.1.i586
    kernel-default-devel-2.6.31.3-1.1.i586
    kernel-source-2.6.31.3-1.1.noarch
    kernel-xen-devel-2.6.31.3-1.1.i586
    kernel-debug-devel-2.6.31.3-1.1.i586
    kernel-pae-2.6.31.3-1.1.i586
    kernel-pae-devel-2.6.31.3-1.1.i586

    The output of "rpm -qa | grep virtual" is

    virtualbox-ose-3.0.6-8.1.i586
    virtualbox-ose-kmp-default-3.0.6_2.6.31.3_1-8.1.i586
    xorg-x11-driver-virtualbox-ose-3.0.6-8.1.i586
    virtualbox-ose-guest-tools-3.0.6-8.1.i586
    virtualbox-ose-kmp-desktop-3.0.6_2.6.31.3_1-8.1.i586

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •