Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Machine switch off

  1. #1
    Join Date
    Jul 2009
    Location
    Switzerland
    Posts
    210

    Default Machine switch off

    Dear All,
    Since a certain time (?), I have to give the root password to be able to switch my machine off.
    In addition, most of the times, but not every, the machine just reboots and doesn't switch off.
    What is wrong ?
    Thanks You in advance
    Jerome

  2. #2
    palladium NNTP User

    Default Re: Machine switch off

    > What is wrong ?

    to me it sounds like you found Personal Settings > Configure Desktop >
    System Administration > Login Manager > Shutdown > Administrator
    Mode, gave your root password and then changed the "Allow Shutdown
    Local from "everybody" to "only root"

    and, on the same page you no longer have in the
    Commands Halt block: /sbin/halt
    and in the Commands Reboot block: /sbin/reboot

    but i'm just guessing...i guess a root owned file or two could have
    corrupted...

    --
    palladium

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,804

    Default Re: Machine switch off

    We need definitely more information. What openSUSE level, which desktop (or none). How do you try to shur down, from where (ther are myriads of ways to to interface to shut down).???
    Henk van Velden

  4. #4
    Join Date
    Jul 2009
    Location
    Switzerland
    Posts
    210

    Default Re: Machine switch off

    Hello,
    I feel sorry for that but I run a suse in french.
    What is "personal settings"?
    Do you mean yast?
    I just don't know where to configure my desktop.
    Thank you in advance
    Jerome

  5. #5
    palladium NNTP User

    Default Re: Machine switch off

    no, not YaST

    ok, see, there are SO many variables (and, since you have not said i
    don't even know if you are running 11.0, 11.1, 11.2, SLED, Gnome,
    KDE3, KDE4, or XP!!) but if you are running a KDE, then TRY this:

    hold down the left Alt key and then press and release the F2 key...a
    blank should pop up, in it type

    kcontrol

    if you are lucky a window will pop up where you can nav to System
    Administration > Login Manager > Shutdown > Administrator
    Mode

    and, after giving the root password you can REset it to allow everyone
    to shutdown and to halt when told to..

    --
    palladium

  6. #6
    Join Date
    Jul 2009
    Location
    Switzerland
    Posts
    210

    Default Re: Machine switch off

    Hello,
    I run suse 11.1 with gnome configuration
    Thank You

  7. #7
    Join Date
    Jul 2009
    Location
    Switzerland
    Posts
    210

    Default Re: Machine switch off

    Dear All,
    Can Anyone help on this matter?
    Thank You in advance
    Jerome

  8. #8
    Join Date
    Jul 2009
    Location
    Switzerland
    Posts
    210

    Default Re: Machine switch off

    Something more I found,
    In the window where I have to insert the su password to shut shown,there is a link rg.freedesktop.consolekit.system.stop-multple-users

    I f I open it, I find a menu where to customise my desktop. Everything is locked. Also tried logging as root, unsuccessfully.
    How can I access to that ?
    Many Thanks in advance for Your help.
    Jerome

  9. #9

    Default Re: Machine switch off

    My guess might be in yast.
    Open the terminal as su fire-up /sbin/yast2 security
    Under boot settings change the option in shutdown behavior of login manager to all users.
    People who do not break things first will never learn to create anything

  10. #10
    Join Date
    Jul 2009
    Location
    Switzerland
    Posts
    210

    Default Re: Machine switch off

    Hello,
    Sorry but it didn't change anything.
    Modify the freedesktop consolekit parameters is still not possible.
    Any other good idea?

    Thank You in advance
    Jerome

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •