Page 1 of 4 123 ... LastLast
Results 1 to 10 of 31

Thread: sound stop working after updating on asus k50in

  1. #1

    Question sound stop working after updating on asus k50in

    sound stopped working after i updated multimedia based on oldcpu's guide. but the system login and logout sounds are still there. If i play youtube, there is no sound. I updated alsa based on soundtroublshooting page, didn't help. here are the infos:

    ~/Desktop> speaker-test -c2 -l5 -twav

    speaker-test 1.0.18

    Playback device is default
    Stream parameters are 48000Hz, S16_LE, 2 channels
    WAV file(s)
    ALSA lib pcm_dmix.c:1008snd_pcm_dmix_open) unable to open slave
    Playback open error: -16,Device or resource busy
    ALSA lib pcm_dmix.c:1008snd_pcm_dmix_open) unable to open slave
    Playback open error: -16,Device or resource busy


    Your ALSA information is located at http://www.alsa-project.org/db/?f=35...ee6af6295f88fb

    Linux linux-wh0i 2.6.27.29-0.1-default #1 SMP 2009-08-15 17:53:59 +0200 x86_64 x86_64 x86_64 GNU/Linux

    ~/Desktop> rpm -qa | grep alsa
    alsa-utils-1.0.18-6.4
    alsa-1.0.18-8.12.1
    alsa-oss-32bit-1.0.17-1.37
    alsa-driver-kmp-default-1.0.21.20091020_2.6.27.29_0.1-1.3
    alsa-firmware-1.0.17-1.51
    alsa-plugins-pulse-1.0.18-6.13
    alsa-oss-1.0.17-1.43
    alsa-plugins-1.0.18-6.13

    ~/Desktop> cat /etc/modprobe.d/sound
    alias snd-card-0 snd-hda-intel
    alias sound-slot-0 snd-hda-intel
    asus k50in core2duo 6500 2.1Ghz, 4G, nVidia G102M 512MB,
    opensuse 11.1 64bit KDE
    windows vista

  2. #2

    Default Re: sound stop working after updating on asus k50in

    one more question: what is relation between alsa, pulseaudio and phonon? which one are we using and troubleshooting?
    asus k50in core2duo 6500 2.1Ghz, 4G, nVidia G102M 512MB,
    opensuse 11.1 64bit KDE
    windows vista

  3. #3

    Default Re: sound stop working after updating on asus k50in

    update:
    speaker-test is working: i can hear "front left" "front right".
    but still youtube and last.fm plays are silent.
    asus k50in core2duo 6500 2.1Ghz, 4G, nVidia G102M 512MB,
    opensuse 11.1 64bit KDE
    windows vista

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,565
    Blog Entries
    38

    Default Re: sound stop working after updating on asus k50in

    Quote Originally Posted by weisuse View Post
    update:
    speaker-test is working: i can hear "front left" "front right".
    but still youtube and last.fm plays are silent.
    Congratulations on sorting your sound with the speaker test !!

    That pretty much shows basic sound is functioning. wrt youtube it could be a flash problem. Do you have flash-player installed? Keep that installed, but if you have libflashsupport installed, remove that. Restart firefox. Does it work now ?

  5. #5

    Default Re: sound stop working after updating on asus k50in

    although speaker-test works, but youtube didn't work. I thought might be flash related (which was working before multimedia packman update), or might be firefox-flash combo problem. So I use konqueror to try youtube, no luck either. OK,it's not firefox. The video is fine with youtube, so i don't think it's flash problem.

    At this point, i know: login/out music OK, speaker-test OK, amarok OK(yes!), youtube and lastfm SILENT (both flash). My theory was the speaker-test and amarok are using different sound system (pulseaudio??) from flash (alsa??). THis theory might be naive. But i do see the message right after logging in saying ALC662 not working.. change to pulseaudio.. something like that.

    So i decided to play with yast-harware-sound setting. i deleted old configuration, re-added new one. But there is no MCP79, so used something close. That didn't help. I continue to edit setting by changing model option based on the alc662 info you posted in another thread, until I change to asus-mode3. Now the youtube has SOUND!!! although I'm not sure it's the model option who solved the problem, Does it make sense to you.

    Just found out, after I used youtube, the speaker-test stopped, just hang at "0 - Front Left", no sound no progress (even after I close the youtube page in firefox. How do I completely disconnect youtube from occupying the device?

    It's late here, I will find out tomorrow morning if everything still works.

    Thanks.
    asus k50in core2duo 6500 2.1Ghz, 4G, nVidia G102M 512MB,
    opensuse 11.1 64bit KDE
    windows vista

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,565
    Blog Entries
    38

    Default Re: sound stop working after updating on asus k50in

    Quote Originally Posted by weisuse View Post
    But i do see the message right after logging in saying ALC662 not working.. change to pulseaudio.. something like that.
    There is a bug in openSUSE-11.1 that it gives false messages about sound not working and falling back .... so one needs to take any such messages with a grain of salt.

    Quote Originally Posted by weisuse View Post
    I continue to edit setting by changing model option based on the alc662 info you posted in another thread, until I change to asus-mode3. Now the youtube has SOUND!!! although I'm not sure it's the model option who solved the problem, Does it make sense to you.
    It suggests 2 possibilities to me.
    1. the asus-mode3 worked and it was what you needed, or
    2. restarting alsa with either no model option specified, or with a reasonably accurate model option (asus-mode3 in this case) is what worked, but if you had restarted alsa with no model option it might also have worked.

    Quote Originally Posted by weisuse View Post
    Just found out, after I used youtube, the speaker-test stopped, just hang at "0 - Front Left", no sound no progress (even after I close the youtube page in firefox. How do I completely disconnect youtube from occupying the device?
    If you wish to hit the nail with a hammer, type with root permissions "rcalsasound restart" and then restart your mixer. Restarting alsa should kill any processes that are accessing the audio.

    Don't forget the idea of removing libflashsupport if flash in particular gives you problems.

  7. #7

    Question Re: sound stop working after updating on asus k50in

    It suggests 2 possibilities to me.
    1. the asus-mode3 worked and it was what you needed, or
    2. restarting alsa with either no model option specified, or with a reasonably accurate model option (asus-mode3 in this case) is what worked, but if you had restarted alsa with no model option it might also have worked.
    you are right with possibility#2.
    This morning I boot the machine. Still the old problem (speaker-test fine, youtube silent). Then only thing I did was "rcalsasound restart" under root. That fixed the problem and youtube has sound immediately. It might not matter which model I chose (I haven't change anything).

    But still, when youtube starts to work, the speaker-test stopped working. As I explained before, speaker-test just hang there. Same is for Amarok.

    again, restarting sound driver will fix it.

    What should I do, so that I don't have to restart sound everytime I log in to the system.
    asus k50in core2duo 6500 2.1Ghz, 4G, nVidia G102M 512MB,
    opensuse 11.1 64bit KDE
    windows vista

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,565
    Blog Entries
    38

    Default Re: sound stop working after updating on asus k50in

    Quote Originally Posted by weisuse View Post
    you are right with possibility#2.
    This morning I boot the machine. Still the old problem (speaker-test fine, youtube silent). Then only thing I did was "rcalsasound restart" under root. That fixed the problem and youtube has sound immediately. It might not matter which model I chose (I haven't change anything).

    But still, when youtube starts to work, the speaker-test stopped working. As I explained before, speaker-test just hang there. Same is for Amarok.

    again, restarting sound driver will fix it.

    What should I do, so that I don't have to restart sound everytime I log in to the system.
    We could setup your PC to run 'rcalsasound restart' every time it boots but IMHO thats not the way to go about this.

    Instead IMHO logically what you need to do is figure out why sound is not working at any particular time.

    First, some openSUSE sound basics ... Sound-concepts - openSUSE ... Linux sound servers/daemons in general do not share audio, but rather when one application is using the audio device, others can not share the device. The exceptions to this are applications that use the alsa API (not to be confused with the alsa driver) and recently pulse audio will also allow applications to share audio. However, pulse audio is buggy.

    If two applications are both using the alsa API, they can play audio at the same time. If both are using OSS, or aRts or some other API then only one application at a time can use the audio.

    So IMHO logically you need to determine what application is using the audio device when you are experiencing audio problems. The command I recommend you use for that is:
    Code:
     lsof /dev/dsp* /dev/audio* /dev/mixer* /dev/snd/*
    Run that command when you are happy with the audio. Copy and paste the output into a text file and save that information. Label it clearly so that you know what the circumstances were when you ran it.

    Then when your sound is not behaving the way you expect, run that command again. Copy and paste the output into a text file. Label it clearly so that you know what the circumstances were when you ran it.

    Do that as many times as required, and then compare the files. What application had seized your sound device when sound was not working properly ?

    Once you have that information, you can proceed and take other measures. Things like changing the output audio mode to "alsa" from 'audio' or from 'oss' or from 'pulse' ... etc ...

    Reference: SDB:AudioTroubleshooting - openSUSE - determining which application is using the sound device

  9. #9

    Default Re: sound stop working after updating on asus k50in

    Totally agree with you. I want to find out why too.

    I don't have "lsof", instead I used ls or ls-l, is that OK?

    # ls-l /dev/dsp* /dev/audio* /dev/mixer* /dev/snd/*
    crw-rw----+ 1 root audio 14, 4 2009-10-21 09:18 /dev/audio
    crw-rw----+ 1 root audio 14, 3 2009-10-21 09:18 /dev/dsp
    crw-rw----+ 1 root audio 14, 0 2009-10-21 09:18 /dev/mixer
    crw-rw----+ 1 root audio 116, 7 2009-10-21 09:18 /dev/snd/controlC0
    crw-rw----+ 1 root audio 116, 6 2009-10-21 09:18 /dev/snd/hwC0D0
    crw-rw----+ 1 root audio 116, 5 2009-10-21 09:18 /dev/snd/pcmC0D0c
    crw-rw----+ 1 root audio 116, 4 2009-10-21 10:23 /dev/snd/pcmC0D0p
    crw-rw----+ 1 root audio 116, 3 2009-10-21 09:18 /dev/snd/pcmC0D1p
    crw-rw----+ 1 root audio 116, 8 2009-10-21 09:18 /dev/snd/seq
    crw-rw----+ 1 root audio 116, 2 2009-10-21 09:18 /dev/snd/timer
    Right now the sound has been fine for speaker-test, amarok and youtube (one after one test), since my 2nd rcalsasound restart. I will investigate more and save the info when the problem occurs again.

    Things like changing the output audio mode to "alsa" from 'audio' or from 'oss' or from 'pulse' ... etc ...
    I have no idea about these changes yet, but will find out with time.

    thanks for the support, really helpful and keep me from thinking about switching to ubuntu. I have ubuntu-9.04-64bits for my desktop, which is running pretty well, but never able to make the flash work well with firefox (need often restart firefox to make flash work again, although I installed flash 64 alpha). Here this suse-64 is much better for the flash-firefox combo.
    asus k50in core2duo 6500 2.1Ghz, 4G, nVidia G102M 512MB,
    opensuse 11.1 64bit KDE
    windows vista

  10. #10
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,565
    Blog Entries
    38

    Default Re: sound stop working after updating on asus k50in

    Quote Originally Posted by weisuse View Post
    Totally agree with you. I want to find out why too.

    I don't have "lsof", instead I used ls or ls-l, is that OK?
    I don't know. Why not install lsof ? Simply (with root permissions):
    Code:
    zypper install lsof

Page 1 of 4 123 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •