Results 1 to 6 of 6

Thread: Probing EDD and Editing menu.lst

  1. #1
    Join Date
    Jan 2009
    Location
    South Burlington, Vermont
    Posts
    32

    Default Probing EDD and Editing menu.lst

    I get a message during boot that says the system is probing EDD and that I can avoid this by setting EDD to off. By searching other threads I was able to figure out that /boot/grub/menu.lst is the file I want to edit.

    When I'm in a terminal window after executing su I type:

    kwrite /boot/grub/menu.lst

    The terminal just freezes up.

    I tried to open Kwrite from Dolphin (in superuser mode) and found that "KDEInit couldn't launch /usr/bin/kwrite"

    How can I edit menu.lst?

    I'm using OpenSuse 11.0

  2. #2

    Default Re: Probing EDD and Editing menu.lst

    You shouldn't 'su' then run graphical programmes - you can end up causing subtle and hard to fix system damage, and things often won't work.

    Either use 'kdesu kwrite /boot/grub/menu.lst'

    Or switch to root user with 'su -', then run 'kwrite /boot/grub/menu.lst'

    'su -' switches to root's environment, as well as changing the user.

  3. #3
    Join Date
    Nov 2008
    Location
    China, Nanjing
    Posts
    11

    Default Re: Probing EDD and Editing menu.lst

    are you sure the kwrite has been installed on your system?

  4. #4
    Join Date
    Jan 2009
    Location
    South Burlington, Vermont
    Posts
    32

    Default Re: Probing EDD and Editing menu.lst

    Thanks for your responses.

    The absence of Kwrite was something I thought of as well. I should have mentioned that I had confirmed its presence.

    kdesu worked like a charm. I was able to view /boot/grub/menu.lst

    The plot thickens. It appears that edd is already set to off.

    Here's my /boot/grub/menu.lst

    # Modified by YaST2. Last modification on Thu Aug 20 17:44:37 EDT 2009
    default 0
    timeout 8
    ##YaST - generic_mbr
    gfxmenu (hd0,5)/boot/message
    ##YaST - activate

    ###Don't change this comment - YaST2 identifier: Original name: linux###
    title openSUSE 11.1 - 2.6.27.29-0.1
    root (hd0,5)
    kernel /boot/vmlinuz-2.6.27.29-0.1-default root=/dev/disk/by-id/ata-WDC_WD1200JB-00FUA0_WD-WMAET1541264-part6 resume=/dev/disk/by-id/ata-WDC_WD1200JB-00FUA0_WD-WMAET1541264-part5 splash=silent showopts vga=0x317
    initrd /boot/initrd-2.6.27.29-0.1-default

    ###Don't change this comment - YaST2 identifier: Original name: failsafe###
    title Failsafe -- openSUSE 11.1 - 2.6.27.29-0.1
    root (hd0,5)
    kernel /boot/vmlinuz-2.6.27.29-0.1-default root=/dev/disk/by-id/ata-WDC_WD1200JB-00FUA0_WD-WMAET1541264-part6 showopts ide=nodma apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe vga=0x317
    initrd /boot/initrd-2.6.27.29-0.1-default

    ###Don't change this comment - YaST2 identifier: Original name: windows###
    title Windows
    rootnoverify (hd0,0)
    chainloader +1

    ###Don't change this comment - YaST2 identifier: Original name: floppy###
    title Floppy
    rootnoverify (fd0)
    chainloader +1

  5. #5

    Default Re: Probing EDD and Editing menu.lst

    edd=off only appears in the failsafe boot - you'd want to copy it to the other boot (assuming you know what you're doing - I confess I have no idea what it does...)

  6. #6
    Join Date
    Jan 2009
    Location
    South Burlington, Vermont
    Posts
    32

    Default Re: Probing EDD and Editing menu.lst

    Problem solved. thank you.

    Now I get it. menu.lst list the options available for booting up.

    I copied edd=off into the mode a usually boot up into and it works fine.

    edd apparently gives the user the ability to specify the video mode for the boot messages. I never look at those messages anyway so I'd just as soon have the boot process take place without having to specify how to display them.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •