Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: Yast issues

  1. #1
    Join Date
    Oct 2008
    Location
    Santiago, Chile
    Posts
    655

    Default Yast issues

    Well, since about a week ago, when doing "update if newer version available", i cant get Yast to install these newer packages, even if the repository has a lower priority.

    Doing # zypper update shows "nothing to do".

    Code:
    #  | Alias           | Nombre                             | Activado | Actualizar
    ---+-----------------+------------------------------------+----------+-----------
    1  | Packman         | Packman                            | Si       | Si
    2  | alsa_kmp_1      | alsa kmp                           | Si       | Si
    3  | alsa_optional   | alsa optional                      | Si       | Si
    4  | ati_1           | ati                                | No       | No
    5  | boinc           | boinc                              | No       | No
    6  | compiz          | compiz                             | No       | No
    7  | games           | games                              | No       | No
    8  | gnomepidgin     | gnomepidgin                        | No       | No
    9  | kde_community   | kde community                      | Si       | Si
    10 | kde_desktop     | kde desktop                        | Si       | Si
    11 | openSUSE 11.1-0 | openSUSE 11.1-0                    | No       | No
    12 | pidgin          | Pidgin for Fedora Core 11.1 - i386 | Si       | No
    13 | printing        | printing                           | Si       | Si
    14 | repo-debug      | openSUSE-11.1-Debug                | No       | No
    15 | repo-non-oss    | openSUSE-11.1-Non-Oss              | Si       | Si
    16 | repo-oss        | openSUSE-11.1-Oss                  | Si       | Si
    17 | repo-source     | openSUSE-11.1-Source               | No       | No
    18 | repo-update     | openSUSE-11.1-Update               | Si       | Si
    19 | zypper          | zypper                             | No       | No

  2. #2
    Join Date
    Oct 2008
    Location
    Santiago, Chile
    Posts
    655

    Default Re: Yast issues

    sorry, here comes the repo list with url's

    Code:
    #  | Alias           | Nombre                             | Activado | Actualizar | URI                                                                    
    ---+-----------------+------------------------------------+----------+------------+---------------------------------------------------------------------------------------
    1  | Packman         | Packman                            | Si       | Si         | http://ftp.uni-erlangen.de/pub/mirrors/packman/suse/11.1/              
    2  | alsa_kmp_1      | alsa kmp                           | Si       | Si         | http://download.opensuse.org/repositories/multimedia:/audio:/KMP/openSUSE_11.1_Update/
    3  | alsa_optional   | alsa optional                      | Si       | Si         | http://download.opensuse.org/repositories/multimedia:/libs/openSUSE_11.1/
    4  | ati_1           | ati                                | No       | No         | http://www2.ati.com/suse/11.1/                                         
    5  | boinc           | boinc                              | No       | No         | http://download.opensuse.org/repositories/home:/enzokiel/openSUSE_11.1_Update/
    6  | compiz          | compiz                             | No       | No         | http://download.opensuse.org/repositories/X11:/XGL/openSUSE_11.1/      
    7  | games           | games                              | No       | No         | http://download.opensuse.org/repositories/home:/accAgon/openSUSE_11.1/ 
    8  | gnomepidgin     | gnomepidgin                        | No       | No         | http://download.opensuse.org/repositories/GNOME:/Community/openSUSE_11.0/
    9  | kde_community   | kde community                      | Si       | Si         | http://download.opensuse.org/repositories/KDE:/KDE4:/Community/openSUSE_11.1_KDE_42/
    10 | kde_desktop     | kde desktop                        | Si       | Si         | http://download.opensuse.org/repositories/KDE:/42/openSUSE_11.1/       
    11 | openSUSE 11.1-0 | openSUSE 11.1-0                    | No       | No         | cd:///?devices=/dev/sr0,/dev/sr1                                       
    12 | pidgin          | Pidgin for Fedora Core 11.1 - i386 | Si       | No         | http://rpm.pidgin.im/fedora/$releasever/i386/                          
    13 | printing        | printing                           | Si       | Si         | http://download.opensuse.org/repositories/Printing/openSUSE_11.1/      
    14 | repo-debug      | openSUSE-11.1-Debug                | No       | No         | http://download.opensuse.org/debug/distribution/11.1/repo/oss/         
    15 | repo-non-oss    | openSUSE-11.1-Non-Oss              | Si       | Si         | http://download.opensuse.org/distribution/11.1/repo/non-oss/           
    16 | repo-oss        | openSUSE-11.1-Oss                  | Si       | Si         | http://download.opensuse.org/distribution/11.1/repo/oss/               
    17 | repo-source     | openSUSE-11.1-Source               | No       | No         | http://download.opensuse.org/source/distribution/11.1/repo/oss/        
    18 | repo-update     | openSUSE-11.1-Update               | Si       | Si         | http://download.opensuse.org/update/11.1/                              
    19 | zypper          | zypper                             | No       | No         | http://download.opensuse.org/repositories/zypp:/Code11-Branch/openSUSE_11.1/

  3. #3
    Join Date
    Oct 2008
    Location
    Santiago, Chile
    Posts
    655

    Default Re: Yast issues

    Yast2 broken - openSUSE Forums


    Could that post help me? If i uninstall and install yast again?

  4. #4
    Join Date
    Jun 2008
    Location
    Delta Quadrant
    Posts
    1,453

    Default Re: Yast issues

    > Could that post help me? If i uninstall and install yast again?

    Well technically you don't have a YaST issue, you have a zypper issue.
    IMHO you've got too many repos. You could try and do a zypper dup, but with
    all those repos who knows what you'd end up with.




  5. #5
    Join Date
    Oct 2008
    Location
    Santiago, Chile
    Posts
    655

    Default Re: Yast issues

    Most of them are disabled so i doubt they could be a problem.


    Edit: Did a little sweeping and i ended up like this:

    Code:
    #  | Alias           | Nombre                | Activado | Actualizar | URI
    ---+-----------------+-----------------------+----------+------------+-------------------------------------------------------------------------------------
    1  | Packman         | Packman               | Si       | Si         | http://ftp.uni-erlangen.de/pub/mirrors/packman/suse/11.1/
    2  | ati_1           | ati                   | No       | No         | http://www2.ati.com/suse/11.1/
    3  | boinc           | boinc                 | No       | No         | http://download.opensuse.org/repositories/home:/enzokiel/openSUSE_11.1_Update/
    4  | kde_community   | kde community         | Si       | Si         | http://download.opensuse.org/repositories/KDE:/KDE4:/Community/openSUSE_11.1_KDE_42/
    5  | kde_desktop     | kde desktop           | Si       | Si         | http://download.opensuse.org/repositories/KDE:/42/openSUSE_11.1/
    6  | openSUSE 11.1-0 | openSUSE 11.1-0       | No       | No         | cd:///?devices=/dev/sr0,/dev/sr1
    7  | repo-debug      | openSUSE-11.1-Debug   | No       | No         | http://download.opensuse.org/debug/distribution/11.1/repo/oss/
    8  | repo-non-oss    | openSUSE-11.1-Non-Oss | Si       | Si         | http://download.opensuse.org/distribution/11.1/repo/non-oss/
    9  | repo-oss        | openSUSE-11.1-Oss     | Si       | Si         | http://download.opensuse.org/distribution/11.1/repo/oss/
    10 | repo-source     | openSUSE-11.1-Source  | No       | No         | http://download.opensuse.org/source/distribution/11.1/repo/oss/
    11 | repo-update     | openSUSE-11.1-Update  | Si       | Si         | http://download.opensuse.org/update/11.1/

  6. #6
    Join Date
    Oct 2008
    Location
    Santiago, Chile
    Posts
    655

    Default Re: Yast issues

    Besides, i dont think its a zypper issue, i tried using Smart and it did offer me newer packages.

    Only issue on Yast is that when doing the update if newer.." It wont show the version numbers on blue, hence it wont offer me to update them

  7. #7
    Join Date
    Oct 2008
    Location
    Santiago, Chile
    Posts
    655

    Default Re: Yast issues

    Should i reinstall yast?

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Yast issues

    Quote Originally Posted by assas1n View Post
    Besides, i dont think its a zypper issue
    What is your logic for saying you do not think it a zypper issue, when zypper update of all of the alsa apps failed, and only some worked (from another thread on this). ALL of those alsa apps, that you tried to update with zypper (and if failed) should have worked. YaST had NOTHING to do with that failure.

    Or is there something else you are not telling us?

  9. #9
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Yast issues

    Quote Originally Posted by assas1n View Post
    Should i reinstall yast?
    I think thats a mistake as I think you have misdiagnosed the problem.

  10. #10
    Join Date
    Oct 2008
    Location
    Santiago, Chile
    Posts
    655

    Default Re: Yast issues

    Im just assuming "smart" works as a zypper front end aswell, if thats the case, then zypper is not totally screwed.

    Just checked Yast and strangely, im starting to get those blue letters after all, did nothing new, since im just waking up from a good night sleep. Ill see what happens later

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •