Results 1 to 7 of 7

Thread: Canon driver

  1. #1

    Default Canon driver

    I am running 11.2 rc1 and everything is fine.
    Except, I am using a Canon mx300 printer. Under 11.1 and milestone8 I used the Pixma mp150 driver with great success.
    But I cannot find it under 11.2 rc1.
    Can anyone help me on where I get this driver and how, (remember I am new to all this and feeling my way around).
    Thanks

  2. #2
    Join Date
    Jul 2009
    Location
    Rockyford Alberta Canada
    Posts
    1,388

    Default Re: Canon driver

    Quote Originally Posted by garagestmarien View Post
    I am running 11.2 rc1 and everything is fine.
    Except, I am using a Canon mx300 printer. Under 11.1 and milestone8 I used the Pixma mp150 driver with great success.
    But I cannot find it under 11.2 rc1.
    Can anyone help me on where I get this driver and how, (remember I am new to all this and feeling my way around).
    Thanks
    Canon supports Linux on many of it's drivers. You can try googling for the Canon site until either you find the Linux driver from Canon or someone else here is able to respond with more info.
    When your up to your a** in Alligators it's pretty hard to remember you intended to drain the swamp (author unknown)

  3. #3

    Default Re: Canon driver

    Hi,
    I tried downloading drivers from canon in rpm format, but have lots of trouble with yast saying different things are missing.
    What, I don't understand, is why is the Pixma range missing from 11.2 rc1 when it was in the previous ones.
    Surely, more drivers would be added, rather than be taken away.
    Would it be possible for me to load the driver from my 11.1 DVD and if so, how do I do this.
    I don't know what to look for, or how to find my dvd drive in dolphin. Sorry, it will be some time before I can kick the windoze habit of doing things.
    I know my mx300 is not supported, but the Pixma mp150 is and this driver ran my mx300 without any problems.

  4. #4
    PV NNTP User

    Default Re: Canon driver

    On Mon October 19 2009 06:46 pm, garagestmarien wrote:

    >
    > Hi,
    > I tried downloading drivers from canon in rpm format, but have lots of
    > trouble with yast saying different things are missing.
    > What, I don't understand, is why is the Pixma range missing from 11.2
    > rc1 when it was in the previous ones.
    > Surely, more drivers would be added, rather than be taken away.
    > Would it be possible for me to load the driver from my 11.1 DVD and if
    > so, how do I do this.
    > I don't know what to look for, or how to find my dvd drive in dolphin.
    > Sorry, it will be some time before I can kick the windoze habit of doing
    > things.
    > I know my mx300 is not supported, but the Pixma mp150 is and this
    > driver ran my mx300 without any problems.
    >
    >

    garagestmarien;

    Have you looked at this link?
    http://openprinting.org/show_printer...on-PIXMA_MX300

    You might try just downloading the canon rpm and using the rpm command to
    install:
    Code:
    su
    rpm -Uvh <full path to the .rpm>
    If you have dependency problems you might try adding the missing libraries
    with YaST. Just what errors are you getting in YaST?
    --
    P. V.
    "We're all in this together, I'm pulling for you." Red Green

  5. #5

    Default Re: Canon driver

    Okay,
    I have solved the problem.
    Installing Gutenprint + gimp has brought up the missing drivers.
    Now I have been able to install the mp150 simplified driver and everything working.
    Hope this is a useful tip to anyone with a mx300 or mx series.
    Use the mp150 driver. You won't be able to use the scanner, but everything else works fine.
    John

  6. #6

    Default Re: Canon driver

    well done; thanks for the info

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,695
    Blog Entries
    1

    Default Re: Canon driver

    Based on this thread, it looks like later versions of sane have support this scanner device. You'll probably find it will work with openSUSE 11.2 ok.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •