Results 1 to 6 of 6

Thread: Headphones problem

  1. #1

    Default Headphones problem

    Hi, I discovered something strange in my Suse 11.1 - Gnome :

    when I plug the headphones they work, but there is also sound from the speakers. How can I fix this ?

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Headphones problem

    Quote Originally Posted by SpicyMcHaggis View Post
    Hi, I discovered something strange in my Suse 11.1 - Gnome :

    when I plug the headphones they work, but there is also sound from the speakers. How can I fix this ?
    USB headphones? Or regular headphones?

    With your PC connected to the Internet, can you run the following diagnostic script twice:
    Code:
    /usr/sbin/alsa-info.sh
    run it with root permissions the first time and select YES to the update question. You need to run the first time as root so it will update in /usr/sbin. Then run it again a second time as a regular user. Select YES to share/upload the diagnostic information. When it is complete it will provide you with a URL where the diagnostic information is posted. Please post that URL here. Just the URL.

    Please also provide the output of running in a terminal:
    rpm -qa '*alsa*'
    rpm -qa '*pulse*'
    rpm -q libasound2
    uname -a
    cat /etc/modprobe.d/sound

  3. #3

    Default Re: Headphones problem

    Regular Headphones

    http://www.alsa-project.org/db/?f=97...8c4ec5b5c75de7


    rpm -qa '*alsa*'
    Code:
    alsa-1.0.18-8.12.1
    alsa-oss-32bit-1.0.17-1.37
    alsa-utils-1.0.18-6.4
    alsa-plugins-pulse-1.0.18-6.13
    alsa-plugins-1.0.18-6.13
    alsa-oss-1.0.17-1.43
    agop@linux-t6bx:~> rpm -qa '*pulse*'
    pulseaudio-module-bluetooth-0.9.14-2.2.1
    pulseaudio-utils-0.9.14-2.2.1
    pulseaudio-0.9.14-2.2.1
    pulseaudio-module-zeroconf-0.9.14-2.2.1
    libpulse0-0.9.14-2.2.1
    libpulse-browse0-0.9.14-2.2.1
    pulseaudio-esound-compat-0.9.14-2.2.1
    libpulse0-32bit-0.9.14-2.2.1
    pulseaudio-module-lirc-0.9.14-2.2.1
    libpulse-mainloop-glib0-0.9.14-2.2.1
    pulseaudio-module-gconf-0.9.14-2.2.1
    alsa-plugins-pulse-1.0.18-6.13
    pulseaudio-lang-0.9.14-2.2.1
    pulseaudio-module-x11-0.9.14-2.2.1
    agop@linux-t6bx:~> rpm -q libasound2
    libasound2-1.0.18-8.12.1
    agop@linux-t6bx:~> uname -a
    Linux linux-t6bx 2.6.27.29-0.1-default #1 SMP 2009-08-15 17:53:59 +0200 x86_64 x86_64 x86_64 GNU/Linux
    agop@linux-t6bx:~> cat /etc/modprobe.d/sound
    #options snd-hda-intel model=targa-dig
    options snd slots=snd-hda-intel
    # u1Nb.rKsej8+9NRF:82801I (ICH9 Family) HD Audio Controller
    alias snd-card-0 snd-hda-intel
    rpm -qa '*pulse*'
    Code:
    pulseaudio-module-bluetooth-0.9.14-2.2.1
    pulseaudio-utils-0.9.14-2.2.1
    pulseaudio-0.9.14-2.2.1
    pulseaudio-module-zeroconf-0.9.14-2.2.1
    libpulse0-0.9.14-2.2.1
    libpulse-browse0-0.9.14-2.2.1
    pulseaudio-esound-compat-0.9.14-2.2.1
    libpulse0-32bit-0.9.14-2.2.1
    pulseaudio-module-lirc-0.9.14-2.2.1
    libpulse-mainloop-glib0-0.9.14-2.2.1
    pulseaudio-module-gconf-0.9.14-2.2.1
    alsa-plugins-pulse-1.0.18-6.13
    pulseaudio-lang-0.9.14-2.2.1
    pulseaudio-module-x11-0.9.14-2.2.1
    rpm -q libasound2
    Code:
    libasound2-1.0.18-8.12.1
    uname -a
    Code:
    Linux linux-t6bx 2.6.27.29-0.1-default #1 SMP 2009-08-15 17:53:59 +0200 x86_64 x86_64 x86_64 GNU/Linux
    cat /etc/modprobe.d/sound
    Code:
    #options snd-hda-intel model=targa-dig
    options snd slots=snd-hda-intel
    # u1Nb.rKsej8+9NRF:82801I (ICH9 Family) HD Audio Controller
    alias snd-card-0 snd-hda-intel

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Headphones problem

    Quote Originally Posted by SpicyMcHaggis View Post
    Thanks. I note a 64-bit openSUSE-11.1 with 1.0.17/1.0.18 of the alsa driver
    on a Sony VGN-NS140E , where the hardware audio codec is an ALC262.

    I checked the mixer settings. The settings look ok.

    But your /etc/modprobe.d/sound file appears to have a wrong model option specified.
    Quote Originally Posted by SpicyMcHaggis View Post
    cat /etc/modprobe.d/sound
    Code:
    #options snd-hda-intel model=targa-dig
    options snd slots=snd-hda-intel
    # u1Nb.rKsej8+9NRF:82801I (ICH9 Family) HD Audio Controller
    alias snd-card-0 snd-hda-intel
    When I checked the alsa-configuration.txt file for 1.0.18 of alsa, I noted these were the various model options for an ALC262:
    Code:
    	ALC262
    	  fujitsu	Fujitsu Laptop
    	  hp-bpc	HP xw4400/6400/8400/9400 laptops
    	  hp-bpc-d7000	HP BPC D7000
    	  hp-tc-t5735	HP Thin Client T5735
    	  hp-rp5700	HP RP5700
    	  benq		Benq ED8
    	  benq-t31	Benq T31
    	  hippo		Hippo (ATI) with jack detection, Sony UX-90s
    	  hippo_1	Hippo (Benq) with jack detection
    	  sony-assamd	Sony ASSAMD
    	  toshiba-s06	Toshiba S06
    	  toshiba-rx1	Toshiba RX1
    	  ultra		Samsung Q1 Ultra Vista model
    	  lenovo-3000	Lenovo 3000 y410
    	  nec		NEC Versa S9100
    	  basic		fixed pin assignment w/o SPDIF
    	  auto		auto-config reading BIOS (default)
    None of them correspond to targa-dig.

    My recommendation is to replace "targa-dig" in the /etc/modprobe.d/sound file with "auto", restart alsa with su -c 'rcalsasound restart' #enter root password when prompted, restart your mixer, and test your sound. If "auto" does not work, then retry each item in the list I quoted above, one at a time, restarting sound after each (restarting mixer and testing) to see if any work properly.

    Now its possible that does not work. When I did a search on the ALSA web site for the ALC262, I obtained this hit: Search results - AlsaProject where I note a fix going from 1.0.20 to 1.0.21 of alsa fixed the mute control with some ALC262 models. That may or may not be relevant to you.

    But if tuning the model option does not work, you could update to 1.0.21 of alsa following the guide here (being certain to send SIX zypper commands):
    Alsa-update - openSUSE
    that is 6 commands. Six. Please read that guide carefully to ensure you send the right six. You may wish to modify the command that updates "alsa, alsa-docs and libasound2" to also update your other alsa apps.

    Good luck.

  5. #5

    Default Re: Headphones problem

    thanks man. is there a way to mute the speakers manuali, so just the headphones to work

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Headphones problem

    Quote Originally Posted by SpicyMcHaggis View Post
    thanks man. is there a way to mute the speakers manuali, so just the headphones to work
    For a laptop? I don't know. I think you need to sort your current problem first. This is solvable .... if not by me, then by one of the alsa dev/packagers for openSUSE if I fail to help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •