Results 1 to 4 of 4

Thread: Need keyboard layout help

  1. #1
    kolosus NNTP User

    Default Need keyboard layout help

    Hello there folks. First time poster. Got this new(er) laptop and installed 11.1 on it and have been playing with it for a few days now...

    My problem is that I'm using the dvorak keyboard. During installation it went fine. Everything was grand. I set the layout up and all went well.

    But unfortunately once the latest updates were going in all went nuts (as far as the keyboard was concerned). I'm back to the "normal" US layout. It is a pain. True once I'm done logging in everything is dvorak but that's not good enough. This is my laptop and no one else will be using it so how can I set dvorak to be the default layout GLOBALLY? At the log in screen. At the terminals (alt+F1-6) etc?

    I usually setup a guest account where there is no password and once at the desktop the layout is set back to the default US... But I can live without that. I need dvorak at all costs. I'm used to PCLinuxOS and with that you can set the global layout very easily but I'm not having any luck here.

    Thanks for your input.

  2. #2
    Join Date
    Mar 2009
    Location
    London
    Posts
    426

    Default Re: Need keyboard layout help

    Hi,

    As far as I know all the keyboard settings are either done in 'Yast->Keyboard' or in 'System Settings->Keyboard'.

    Hope this helps,

    Barry.

  3. #3
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,611

    Default Re: Need keyboard layout help

    You don't say which version you are using but if you are trying out 11.2 there is a bug which resets the keyboard settings to US.

    Anyway, use YaST to set the hardware of the keyboard you are using and then in KDE4 use Configure Desktop>Regional and Language>Keyboard layout if you want to install one or more different software keyboards.

  4. #4
    Join Date
    Nov 2009
    Location
    Groningen, NL
    Posts
    243

    Default Re: Need keyboard layout help

    @john-hudson
    Hi, Since about 1 week I am using 11.2+KDE4 and I noticed yesterday that my keyboard has been reset to US, while us-intl had been selected during installation. Unfortunately, the keyboard mapping can not be changed in Yast, nor in KDE Configure. In 11.1 Yast had a module to do this (it went via Sax2). Should I just edit /etc/sysconfig/keyboard and change "us" into "us-intl" ?
    Thanks for helping me out!
    hws

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •