Results 1 to 4 of 4

Thread: OpenSuse installation to Vista System - Failure -

  1. #1
    Join Date
    Oct 2009
    Location
    London
    Posts
    8

    Exclamation OpenSuse installation to Vista System - Failure -

    before installing i had a vista system.
    and trying to make a dual boot with installing OpenSuse 10 SP1
    (Suse Linux Enterprise Server)

    when it came to 'installing settings' it was like:
    *shrink windows partition /dev/sda2 to 159.4GB (in red writing)
    *create extended partition /dev/sda3 to 131.2GB
    *create swap partition /dev/sda5 to 2.0GB
    *create root partition /dev/sda6 to 129.2GB with Reiserfs

    when proceeded to installation it even didnt came to %1. stopped like this and then i aborted (after 1 hour).

    so, problem seemed to be because HD was formatted with NTFS file system so i had to run scandisk or defrag before installation (on windows).

    but now, windows is not loading. when i put recovery discs of windows it says 'files loading' but nothing happens.
    situation: windows seems to be gone. suse can't install.

    and when i insist to install suse after all, partition table seems like:
    *delete partition /dev/sda1 (7.4GB)
    *delete windows partition /dev/sda2 (290.6GB). Resize impossible due to inconsistent fs. Try checking fs under windows.
    *create swap partition /dev/sda1 (2.0GB)
    *create root partition /dev/sda2 (296.0GB) with reiserfs.

    that's all.
    the question is first how i get my vista back. and then how do i proceed to Suse install and have dual boot working correctly.

    thanks :/

  2. #2
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,611

    Default Re: OpenSuse installation to Vista System - Failure -

    Firstly 10 SPE 1 is for SUSE Enterprise and not openSUSE. Not sure when SPE 1 was issued but SLED 10 is three years old.

    You should have a Vista recovery disk which will allow you to restore Vista to its original state.

    Then you need to decide whether you want to use the Enterprise version in which case you should really be installing 11 rather than 10 and also asking questions on the Enterprise forums which you can access elsewhere on the forum.

    If you want the community version, then you should try openSUSE 11.1 or wait until November and try openSUSE 11.2.

    There is some dispute as to the best way of installing openSUSE alongside Vista. Some people have had perfectly successful installs; others have found it better to ask Vista to create some free space before trying to install openSUSE.

    It may be safer given the problems you have had first time around to reinstall Vista and then ask it to create some space for openSUSE. Then when you install openSUSE it should identify the free space and use that. If it doesn't you may need to perform an expert partition.

    Note that, because you can only have four primary partitions and openSUSE needs three, openSUSE will normally create an extended partition in the space you have created for it and then create the three partitions it needs in that extended partition.

  3. #3

    Default Re: OpenSuse installation to Vista System - Failure -

    I have the following set up on my laptop :

    Mac OSX86 - Vista - Windows XP - opensuse 11.1.
    In between there is an EFI partition, a swap partition for Windows, a Data partition for datasharing, a ReiserFS partition containing a VMWare system with SBS2003 on it and the opensuse system is deviced in 4 partitions. Boot, Root, Home and Swap.

    I devided my hard disk with a hard disk manager (Paragon Disk Manager 2009). Then installed each system where it belongs, opensuse has Grub as bootloader and this is installed in the Boot partition of opensuse itself, not in the MBR.

    My bootloader is Acronis Boot Loader.

  4. #4
    Join Date
    Oct 2009
    Location
    London
    Posts
    8

    Default Re: OpenSuse installation to Vista System - Failure -

    ok i also should share how a screen i had when i try to install after all (after vista boot is not working and unsuccesfull try installing SUSE):

    -delete partition /dev/sda1 (7.4GB)
    -delete windows partition /dev/sda (290.6GB). Resize impossible due to incostinent fs. Try checking fs under windows.
    -create swap partition /dev/sda1 (2.06GB)
    -create root partition /dev/sda2 (296.0GB) with reiserfs.

    so. it says it. windows is somehow gone. nothing worked to bring it back, rescue discs or other things. so i gave the laptop to sony to take it back with vista, but they still didnt call so apparently they are having a problem by restoring it.

    and yes 'LRE' you are right, it was SUSE Linux Enterprise Desktop 10 SP1 for x86 that Novell sent me. not openSUSE, didnt know that they are different : ) so, i'll focus on it.

    and 'john_hudson': you have great stuff in your Laptop. i'll check Paragon Disk M as well. thanks.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •