Results 1 to 5 of 5

Thread: RC-1 - Cannot launch Firefox from Thunderbird

  1. #1
    Join Date
    Jul 2008
    Location
    Toronto, Canada
    Posts
    1,255

    Default RC-1 - Cannot launch Firefox from Thunderbird

    Using openSUSE RC-1. I'm having problems launching Firefox from Thunderbird. Whether it be an html link or browsing for extensions.

    I can launch Firefox from KMail.

    Anyone else?

    Cheers!
    My Linux Box
    OS:
    openSUSE 52.2 - Plasma 5.18.9
    OS:
    Tumbleweed Plasma 5.22
    ASUS P5Q | Intel Quad 6600 @3.02 GHz | 8GB G.SKILL RAM | Nvidia GeForce 750 Ti

  2. #2
    Join Date
    Jun 2008
    Location
    Kentucky, USA
    Posts
    466

    Default Re: RC-1 - Cannot launch Firefox from Thunderbird

    I've seen this before with Ubuntu. Open Thunderbird and go to edit ->prefs -> advanced -> general -> advanced configuration. Search for
    Code:
    network.protocol-handler.app.http
    and
    Code:
    network.protocol-handler.app.https
    Make sure both point to
    Code:
    /usr/bin/firefox
    Klaatu Barada Nikto

  3. #3
    Join Date
    Jul 2008
    Location
    Toronto, Canada
    Posts
    1,255

    Default Re: RC-1 - Cannot launch Firefox from Thunderbird 3.0b4

    In openSUSE 11.2 RC 1 -the problem with the fix is that Thunderbird 3.0b4 "about:config" no longer uses

    Code:
    network.protocol-handler.app.http
    and

    Code:
    network.protocol-handler.app.https
    I'm getting the following error message in the Error Console when selecting

    Tools --> Add-ons --> Browse All Add-ons or See All Recommended Add-ons

    Code:
    Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIExternalProtocolService.loadUrl]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://global/content/contentAreaUtils.js :: openURL :: line 924"  data: no]
    I didn't have this problem in Milestone 8.

    I'm sure this must be happening to other users??
    My Linux Box
    OS:
    openSUSE 52.2 - Plasma 5.18.9
    OS:
    Tumbleweed Plasma 5.22
    ASUS P5Q | Intel Quad 6600 @3.02 GHz | 8GB G.SKILL RAM | Nvidia GeForce 750 Ti

  4. #4
    Join Date
    Jun 2008
    Location
    Kentucky, USA
    Posts
    466

    Default Re: RC-1 - Cannot launch Firefox from Thunderbird

    I just looked, and it is Thunderbird 3 beta in the RC1 repos. The arguments I posted aren't even there anymore. I would delete the thunderbird folder in /home, reinstall and see if it works. If not, you need to file a bug report. I just installed it from the RC1 DVD, and it works fine here.
    Klaatu Barada Nikto

  5. #5
    Join Date
    Jul 2008
    Location
    Toronto, Canada
    Posts
    1,255

    Default Re: RC-1 - Cannot launch Firefox from Thunderbird 3.04b

    I have installed KDE 4.3.1 using the 64-bit DVD RC 1. Have you installed the 32-bit or 64-bit?
    No matter how many times I have deleted the .thunderbird folder, removed Thunderbird 3.04b, I cannot get Firefox started from an html link or browse for add-ons from Thunderbird.

    However, I found a workaround using "about:config" in Thunderbird 3.04b.

    Change from false to true the following:

    Code:
    network.protocal-handler.warn-external.http   user set   boolean   true
    Code:
    network.protocal-handler.warn-external.https   user set   boolean   true
    A window pops up asking which application the user wants to launch. I selected firefox.

    It now works!
    My Linux Box
    OS:
    openSUSE 52.2 - Plasma 5.18.9
    OS:
    Tumbleweed Plasma 5.22
    ASUS P5Q | Intel Quad 6600 @3.02 GHz | 8GB G.SKILL RAM | Nvidia GeForce 750 Ti

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •