Results 1 to 4 of 4

Thread: Wireless ALMOST working! But how to install firmware...?

  1. #1

    Default Wireless ALMOST working! But how to install firmware...?

    Fellow openSUSErs, my Wifi woes might almost be at an end!

    I would like to point out that I have read the stickies, worked through them as best I can, and searched for other posts relating to my brand and chipset of wireless USB device.

    Pertinent technical information is given at the end of the post. I am happy to add any more that may be useful, if people can provide me with the command necessary to retrieve it.

    I need advice on how to install the firmware (it came with a CD-ROM).

    The device is recognized by YaST.

    Which gives the following advice:

    "The device needs a firmware to function properly..."

    So-far, so-good.

    The device manufacturer's CD-ROM tells me in a Readme in the first directory I open in the zipped file:

    "The driver interface was developed on wpa_supplicant v.0.4.7.
    You can install the WPA Supplicant Free Edition development from website.

    Linux WPA Supplicant (IEEE 802.1X, WPA, WPA2, RSN, IEEE 802.11i)

    After download the package then go to wpa_supplicant directory"

    From here it gets very complicated (OK it's all relative, but for me...). I am having difficulty following the instructions, which are very poorly written.

    If I proceed in YaST without installing the firmware, it is capable of scanning for networks and identifies the network to which I wish to connection, but does not achieve connection.

    My questions are the following:

    Can I simply install RT2501 Firmware? What is WPA supplicant and do I need it? HOW do I install the firmware (yes I'm that much of a noob)?

    Device info.

    I have:
    Code:
    us 005 Device 005: ID 148f:2573 Ralink Technology, Corp. RT2501USB Wireless Adapter
    The kernel has the following to say:

    Code:
    sb 5-3: new high speed USB device using ehci_hcd and address 4
    usb 5-3: configuration #1 chosen from 1 choice
    phy1 -> rt2500usb_init_eeprom: Error - Invalid RT chipset detected.
    phy1 -> rt2x00lib_probe_dev: Error - Failed to allocate device.
    usb 5-3: New USB device found, idVendor=148f, idProduct=2573
    usb 5-3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
    usb 5-3: Product: 802.11 bg WLAN
    usb 5-3: Manufacturer: Ralink
    phy2: Selected rate control algorithm 'pid'
    Registered led device: rt73usb-phy2::radio
    Registered led device: rt73usb-phy2::assoc
    Registered led device: rt73usb-phy2::quality
    usbcore: registered new interface driver rt73usb
    wlan0 renamed to wlan1 by udevd [4789]
    udev: renamed network interface wlan0 to wlan1
    As always a big thank you in advance to those who having taken the trouble to read these are able to post a response.

  2. #2
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: Wireless ALMOST working! But how to install firmware...?

    As a quick Google run would have shown you, wpa_supplicant handles the
    encryption needed for WPA and WPA2 encryption.

    I don't even want to know what system the CD is meant to treat, but
    any set of instructions that tells you to install wpa_supplicant is
    really out of date. That piece of software is now included.

    I do not see a message that firmware loading failed, and I believe
    that it was found. Check directory /lib/firmware for a file named
    rt73.bin. If present, the firmware is available and you only need to
    configure the device. No, I will not tell you how to do that. It has
    been covered many, many times.

  3. #3

    Default Re: Wireless ALMOST working! But how to install firmware...?

    IwFinger

    Thanks man. I was confused as to why YaST would give me the message I described, not realizing it was a general disclaimer. Sure enough the file was in the place you suggested, and it configured directly through YaST.

    So WiFi is up and no more tripping over the cable that runs across my living room floor. You have no idea ho happy I am right now.

    To people in Switzerland/France and environs. I would recommend the "Intellinet Wireless G Adapter (Rev. 3.02)" It is virtually PnP and is the only one of the 3 USB devices that I've tried so far that I have been able to configure without unnecessary amount of fiddling.


  4. #4

    Default Re: Wireless ALMOST working! But how to install firmware...?

    well done on getting your wireless running; enjoy OpenSuse;

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •