Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: CPU Usage 100%

  1. #1
    userpdq NNTP User

    Question CPU Usage 100%

    Opensuse 11.1 (Gnome) Home Server, RAID 1, Back in Time (Backup).

    Help!

    CPU usage rises to 100% despite being idle. "Top" indicates tar and y2base are eating up the resources. When I kill tar/PID in "Top" CPU drops to 0%.

    What is causing the high CPU usage and how do I fix it? Any advise would be appreciated.

    Note: Screensaver disabled, no problems with Xorg, remote access is fine, all updates in place... server up and running smoothly for 1 Yr.

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,378

    Default Re: CPU Usage 100%

    Obviously tar uses this. What is that tar supposed to do? Maybe it is just working hard fot you to do what you asked it to do. Or do you fear it run into a tight loop?

    Edit: I see this is your first post here. Welcome to the Forums!
    Henk van Velden

  3. #3
    userpdq NNTP User

    Default Re: CPU Usage 100%

    Thanks for your reply hcw and welcoming me to the forum.

    I'm not very familiar with the tar command and I do fear that something is looping in the background but I'm struggling to identify what it could be. I'm wondering if it has something to do with the local Back in Time package which is automatically set to backup my server files at midnight... never had an issue with this until recently. Any further thoughts/comments would be appreciated.

  4. #4
    palladium NNTP User

    Default Re: CPU Usage 100%

    userpdq wrote:
    > Opensuse 11.1 (Gnome) Home Server, RAID 1, Back in Time (Backup).
    >
    > Help!


    i'm with Henk here: tar is a compressing and archiving tool which Back
    in Time is probably using to do the backups you asked it to do..


    > CPU usage rises to 100% despite being idle. "Top" indicates tar and
    > y2base are eating up the resources. When I kill tar/PID in "Top" CPU
    > drops to 0%.


    and, y2base is a program to fetch security and other updates from the
    openSUSE repo...it can be turned off forever, but then you never get
    the updates you need..

    both of those are (probably) set up to do very little until nothing
    else is going on (that is, if your 'server' is serving something to a
    net user then both the backup and updater probably falls silent...BUT,
    when it see the machine is idle, tar and y2base GET BUSY WORKING, and
    could easily go to 100% CPU....no problem since nothing else is going
    on..)


    > What is causing the high CPU usage and how do I fix it? Any advise
    > would be appreciated.


    tar and y2base...you could turn off your backup program and update
    programs, but why??

    what is your 'server' serving? has it stopped serving when tar and
    openSUSE Updater are busy?


    > Note: Screensaver disabled, no problems with Xorg, remote access is
    > fine, all updates in place... server up and running smoothly for 1 Yr.


    if it ain't broke, don't fix it..

    --
    palladium

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,378

    Default Re: CPU Usage 100%

    Like palladium (and like you) I am thinking of Back in Time. When it runs you could see (with ps -ef) who is the parent of the tar PID (and further upwards) to check this.

    For the moment we will suppose it is Back in Time. As you say it worked OK already for a longer amount of time (months I mean), please try to call back in your mind all recent changes in the file structure that is to be backed up. Like new database added, new structure of directories, symbolic links (they can loop when you are not coutious), etc.

    Also try to investigate what is already done during backup until you killed it (backup fiiles generated or missing). Any logging of the backup? Switch on as much as logging as possible at next midnight run, etc.

    Just suggestions for you to help in error searching.
    Henk van Velden

  6. #6
    userpdq NNTP User

    Default Re: CPU Usage 100%

    palladium,

    Thanks for the feedback and educating me about tar & y2base. Re: tar doing what Back In Time was asked to do... not likely. The settings I have for Back In Time have not changed since I configured it 1 yr ago. Maybe I got a bug from d/l recent updates.

    Still puzzled.

  7. #7
    userpdq NNTP User

    Default Re: CPU Usage 100%

    Like palladium (and like you) I am thinking of Back in Time. When it runs you could see (with ps -ef) who is the parent of the tar PID (and further upwards) to check this.

    Thanks hcw... good advise. I'll see what happens after midnight. I appreciate the help!

    For the moment we will suppose it is Back in Time. As you say it worked OK already for a longer amount of time (months I mean), please try to call back in your mind all recent changes in the file structure that is to be backed up. Like new database added, new structure of directories, symbolic links (they can loop when you are not coutious), etc.

    Also try to investigate what is already done during backup until you killed it (backup fiiles generated or missing). Any logging of the backup? Switch on as much as logging as possible at next midnight run, etc.

    Just suggestions for you to help in error searching.
    __________________
    Henk van Velden

  8. #8
    Join Date
    Jun 2008
    Location
    /dev/belgium
    Posts
    1,946

    Default Re: CPU Usage 100%

    @userpdq

    LOL, why do you have the signature of Henk? Is your name Henk van Velden too? And why are you all writing in blue? Color blindness?


  9. #9
    userpdq NNTP User

    Default Re: CPU Usage 100%

    LOL... Slip of the mouse. High CPU usage has got my head spinning. Even still, Linux ROCKS!!!

  10. #10
    Kevin Miller NNTP User

    Default Re: CPU Usage 100%

    userpdq wrote:
    > Opensuse 11.1 (Gnome) Home Server, RAID 1, Back in Time (Backup).
    >
    > Help!
    >
    > CPU usage rises to 100% despite being idle. "Top" indicates tar and
    > y2base are eating up the resources. When I kill tar/PID in "Top" CPU
    > drops to 0%.
    >
    > What is causing the high CPU usage and how do I fix it? Any advise
    > would be appreciated.
    >
    > Note: Screensaver disabled, no problems with Xorg, remote access is
    > fine, all updates in place... server up and running smoothly for 1 Yr.


    My guess is you've enabled backup in YaST. It will tar your files to a
    backup location.

    ....Kevin
    --
    Kevin Miller - http://www.alaska.net/~atftb
    Juneau, Alaska
    In a recent survey, 7 out of 10 hard drives preferred Linux
    Registered Linux User No: 307357, http://counter.li.org

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •