Results 1 to 8 of 8

Thread: gnome-terminal renders fonts not smoothly

  1. #1

    Default gnome-terminal renders fonts not smoothly

    Hi All,

    I have installed openSUSE 11.1 yesterday and found that the SubPixel feature is deactivated by default. After re-installing the freetype2-feature-subpixel and a modified cairo, most applications can render font smoothly.

    However, one of the most important application "Gnome Terminal" seems not to render font smoothly. Is there any way to solve this problem?

    I have chosen exactly the same font in Eclipse and in GnomeTerminal. But the same text looks definitively different.

  2. #2
    Camalen NNTP User

    Default Re: gnome-terminal renders fonts not smoothly

    stanleyxu2005 wrote:

    > I have installed openSUSE 11.1 yesterday and found that the SubPixel
    > feature is deactivated by default. After re-installing the
    > freetype2-feature-subpixel and a modified cairo, most applications can
    > render font smoothly.


    Huh? There is no need to touch freetype2 anymore.

    > However, one of the most important application "Gnome Terminal" seems
    > not to render font smoothly. Is there any way to solve this problem?
    >
    > I have chosen exactly the same font in Eclipse and in GnomeTerminal.
    > But the same text looks definitively different.


    Can you please send a link to a snapshot so we can get a sample of that bad
    font rendering?

    Greetings,

    --
    Camalen

  3. #3

    Default Re: gnome-terminal renders fonts not smoothly

    sure. please see below



    Two windows look really differently. The snapshot might cheat your eyes.

  4. #4
    Camalen NNTP User

    Default Re: gnome-terminal renders fonts not smoothly

    stanleyxu2005 wrote:

    > sure. see below
    >
    > [image: http://gosurfbrowser/~xuqan/font-rendering.png]


    O.k. Thanks :-)

    Correct link: http://gosurfbrowser.com/~xuqan/font-rendering.png

    Yes, the font inside gnome-terminal looks sightly different.

    In fact, it looks it renders in a different manner even if you compare it
    with the text that is being displayed in gnome-terminal tabs.

    Have you try...?

    1/ Tweaking font rendering under "Appearance settings -> fonts".

    2/ On gnome-terminal, select the specific font and size (I guess
    is "Monospace"), instead leaving the default setting that is [x] use system
    monospace font.

    :-?

    Greetings,

    --
    Camalen

  5. #5

    Default Re: gnome-terminal renders fonts not smoothly

    Quote Originally Posted by Camalen View Post
    Have you try...?

    1/ Tweaking font rendering under "Appearance settings -> fonts".

    2/ On gnome-terminal, select the specific font and size (I guess
    is "Monospace"), instead leaving the default setting that is [x] use system
    monospace font.
    Yes, I use "Bitstream Vera Sans Mono" in "Appearance settings -> fonts".

    In Gnome-Terminal and in Eclipse, I use the same font setting as well.

  6. #6

    Default Re: gnome-terminal renders fonts not smoothly

    up up

  7. #7

    Default Re: gnome-terminal renders fonts not smoothly

    According to the snapshot, the Auto Hinting is not enabled by Gnome-Terminal

  8. #8

    Default Re: gnome-terminal renders fonts not smoothly

    For some reason, gnome-terminal picks up the font rendering from xft and not cairo. Cairo is the default backend for all GTK apps and xft is preferred for Qt (I may be wrong here though about the xft).

    Try this and see if it helps ? Subpixel Hinting for 11.2- GTK Apps- Solution - openSUSE Forums It should work, as I was able to get perfect subpixel rendering for all GTK+ apps.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •