Results 1 to 4 of 4

Thread: suse not responding, help

  1. #1
    calumk NNTP User

    Default suse not responding, help

    Ok so heres the problem,
    I have an opensuse server, running opensuse 11.1
    I have apache, mysql, and ffmpeg installed, among other apps like blender and gimp etc... .

    Everything was working fine, untill 3 days ago, when, I ran a couple of system updates (from the official opensuse widget thing that pops up)

    At the same time howerver i tried to update to KDE 4, this turned out to be a bad idea, as i was already running it and forgot i had already upgraded...
    (I know its stupid... :s )

    Anyway, after a reboot (turned off over night)
    i have a problem....

    The computer boots, enters the opensuse boot screen where it lets me choose boot options, and then loads suse (keyboard works fine at this point)

    But once suse is booted and the desktop is displayed, i have no control over the computer. the mouse and keyboard are non functional.
    On top of this the server is no longer functioning, leading me to believe that the system may be frozen, not just not accepting input signals.

    The keyboard also doesn't work in runlevel 3.

    I have booted to a live cd and taken the important files off, but obviously i want to try and save it rather than do a server rebuild....

    I have also replaced the xorg.conf file with one from the live cd, but still no luck, just changed the screen resoulution a bit....

    Please help, need to get the server up and running, as it is hosting my schools Video Server....

    3GB RAM
    Intel Xeon
    1.5TB HDD

  2. #2
    Join Date
    Jun 2008
    The English Lake District. UK - GMT/BST
    Blog Entries

    Default Re: suse not responding, help

    Try booting to icewin desktop from the session option at the desktop login. This assumes you have auto-login disabled!
    My Articles Was I any help? If yes: Click the star below

  3. #3
    palladium NNTP User

    Default Re: suse not responding, help

    calumk wrote:
    > Ok so heres the problem, I have an opensuse server, running
    > opensuse 11.1 ... i tried to update to KDE 4, this turned out to be
    > a bad idea ... Please help, need to get the server up and running,
    > as it is hosting my schools Video Server...

    now you know why so many seasoned, professional Linux administrators
    run critical (must be up and running) "servers" *without* any desktop
    environment whatsoever..

    in my experience only M$-Windows even attempts to sell 'servers' with
    GUI applications and controls..

    the more you add, the less stable you will have....AND, electing to
    'update' to the most unstable desktop environment (KDE4) on the planet
    gives your 'server' a double dose of trouble..

    if the school wants stable, install SUSE Linux Enterprise Server 11
    (SLES 11) version from is like a rock, and has no X or KDE
    anywhere in sight..

    if the school wants to try to save that small amount each year in
    support costs, then install openSUSE 11.1 *without* the glitz and
    windows by selecting, on this page
    the item at the bottom, "Minimal Server Selection (Text Mode)" which
    is about as close to SLES as you are gonna get without purchase..


    in the mean time, you might try booting to runlevel three as there is
    a chance that it will serve videos from that runlevel..

    to get to runlevel three, when you see that first green screen where
    you can choose boot options just press the down arrow and then the
    number 3....and, the 3 should show up in the boot options blank at the
    bottom of the list....then press your enter key..

    if you are *lucky* the next thing you will see is a "have fun" log in
    screen where you need to do *nothing*, go to another computer and see
    if the server is serving video as it should be doing...if so, turn the
    servers' monitor off and leave it alone until you have to turn the
    machine off, then turn the monitor on, log in as root and type

    shutdown -h now

    and press enter...if you are lucky it power down..

    to add videos/users/etc see any of the free administrative guides on
    the favorite is
    but, more specific administrative details for openSUSE is probably
    available on the server at or near

    and, lots of folks administer their Linux servers from another
    computer using a program named Webmin, see


  4. #4
    Join Date
    Jul 2008
    in front of the keyboard

    Default Re: suse not responding, help

    In others short ways to say that... do the following
    1. Do no install gui on servers.
    now the real deal
    2. if it is a server that it has an ip on it. ping it to see if it responds to pings anymore... also try a ssh if you have the port opened.
    3. if you can ping it then maybe you can ssh in to it and see what seems to be the problem.
    type top at the console prompt to see if something is eating up your cpu/mem.
    also rcxdm stop will stop you GUI... helps a lot if kde causes the problems.
    anyway...the general ideea is to see if it is really dead or you just see it as dead...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts