Results 1 to 2 of 2

Thread: PXE booting problems

  1. #1
    nomiraged NNTP User

    Default PXE booting problems

    So I've installed a pxe server and configured ../pxelinux.cfg/default as follows:

    default harddisk
    # default
    label linux
    kernel linux
    append initrd=initrd splash=silent showopts
    install=http://192.168.2.217/openSUSE/CD1 insecure=1

    #failsafe
    label failsafe
    kernel linux
    append initrd=initrd
    ide=nodma
    apm=off
    acpi=off
    insmod=e100
    install=http://192.168.2.217/openSUSE/CD1 insecure=1

    # repair
    label repair
    kernel linux
    append initrd=initrd
    ramdisk_size=65536
    splash=silent repair=1 showopts

    # rescue
    label rescue
    kernel linux
    append initrd=initrd
    ramdisk_size=65536
    splash=silent rescue=1 showopts

    # mediacheck
    label mediachk
    kernel linux
    append initrd=initrd
    splash=silent mediacheck=1 showopts

    # memory test
    label memtest
    kernel memtest

    #harddisk
    # boots from the local hard disk
    harddisk
    label harddisk
    localboot 0x80

    implicit 1
    display message
    prompt 1
    timeout 100

    When I select linux - or failsafe it just boots into linuxrc and asks for the CD. I can then go and specify the location of the repository, however, I was under the impression that the install parameter passed that information to linuxrc. I would rather it boot the gui install than messing around in linuxrc before hand to find the repository. Any help on this issue would be appreciated.

  2. #2
    nomiraged NNTP User

    Default Re: PXE booting problems

    The problem was with all of the hard returns. The new file is as follows:

    default harddisk

    #OpenSUSE linux install
    label linux
    kernel linux
    append initrd=initrd ramdisk_size=65536 install=http://192.168.2.217/openSUSE/CD1 insecure=1

    #failsafe
    label failsafe
    kernel linux
    append initrd=initrd ide=nodma apm=off acpi=off ramddisk_size=65536 install=http://192.168.2.217/openSUSE/CD1 insecure=1

    # memory test
    label memtest
    kernel memtest

    #harddisk
    # boots from the local hard disk
    harddisk
    label harddisk
    localboot 0x80

    implicit 1
    display message
    prompt 1
    timeout 100

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •