Results 1 to 6 of 6

Thread: Modem, WvDial, Device Busy

  1. #1

    Default Modem, WvDial, Device Busy

    Well a noob wants to know, when he runs wvdial, why it says /dev/modem Device or Resource Busy?

    I don't have the ability to install anything else at the moment.

    Thanks
    Steve

  2. #2
    Vahis NNTP User

    Default Re: Modem, WvDial, Device Busy

    sarnone wrote:
    > Well a noob wants to know, when he runs wvdial, why it says /dev/modem
    > Device or Resource Busy?
    >
    > I don't have the ability to install anything else at the moment.
    >
    > Thanks
    > Steve
    >
    >


    As by default wvdial requires to be run as root.
    Try if it works that way.
    Try also sudo wvdial

    I can't remember what I've done with it.
    I'm running it cos I haven't been able to make my Huawei 169 work with
    NetworkManager in 11.2 versions. (It works fine in 11.0)

    Googling 'run wvdial as normal user' gives a lot of instructions. Here's
    one:
    http://wiki.archlinux.org/index.php/...al_with_wvdial

    Vahis
    --
    "Sunrise 8:02am (EEST), sunset 6:08pm (EEST) at Espoo, Finland (10:06
    hours daylight)"
    http://waxborg.servepics.com
    Linux 2.6.25.20-0.5-default #1 SMP 2009-08-14 01:48:11 +0200 x86_64
    8:42pm up 24 days 3:22, 15 users, load average: 0.31, 0.23, 0.20

  3. #3

    Default Re: Modem, WvDial, Device Busy

    Vahis,
    thanks for the help. I'm running 11.1 and I have been able to configure the modem with Yast. However, NetworkManager does not show it as a connection. Without the command line I would not know how to initiate a dialup connection. When I configured the modem, it asked to install smppp,wvdial and wstream. I assume that this should have done the trick. Is it common to resort to command line for this connection? Did you have luck in 11.1 using the NetworkManager to manage you modem connection?

    Steve

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,698
    Blog Entries
    1

    Default Re: Modem, WvDial, Device Busy

    If you don't like working from a console, then you could try kinternet instead. Download and install it via yast software manager.

  5. #5

    Default Re: Modem, WvDial, Device Busy

    Vahis,
    I have installed Kinternet and my modem is configured. When attempting to dial it subsequently fails and the log shows, "pppd[0] died: pppd options error (exit code 2)". I'm sure there is some configuration for pppd, I just have to find it, right?

    Thanks
    Steve

  6. #6

    Default Re: Modem, WvDial, Device Busy

    Thanks for the replies. Realized that this is a Winmodem, so I am going to skip the nightmare.

    Thanks
    Steve

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •