Results 1 to 5 of 5

Thread: Network Server Lag

  1. #1

    Question Network Server Lag

    I have an OpenSuSE 11.1 server that I use for SSH, FTP and Squid. When I connect to SSH or FTP, there is a strange 15 second delay before anything happens. This also happens on my desktop (11.1), but there was a previous installation on the server that did not have this lag. The delay is present from any computer on the network, and if I connect to SSH in verbose mode it says that the connection has been acknowledge before the delay. Any ideas?

    SSH Log:
    ....
    debug1: SSH2_MSG_SERVICE_ACCEPT received
    [Delay]
    debug1: Authentications that can continue: publickey,keyboard-interactive
    ....

    Note: In PuTTY under Windows, the delay ends just as the connection issue window displays.

  2. #2

    Default Re: Network Server Lag

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    Can you show the entire transaction, maybe with -vvv instead of just -v?
    Also anything in /var/log/messages on the server side that may be
    relevant? Are you doing anything other than logging in? Does it happen
    when you login to the machine from itself (ssh localhost)?

    Good luck.





    bamt wrote:
    > I have an OpenSuSE 11.1 server that I use for SSH, FTP and Squid. When I
    > connect to SSH or FTP, there is a strange 15 second delay before
    > anything happens. This also happens on my desktop (11.1), but there was
    > a previous installation on the server that did not have this lag. The
    > delay is present from any computer on the network, and if I connect to
    > SSH in verbose mode it says that the connection has been acknowledge
    > before the delay. Any ideas?
    >
    > SSH Log:
    > ....
    > debug1: SSH2_MSG_SERVICE_ACCEPT received
    > [Delay]
    > debug1: Authentications that can continue:
    > publickey,keyboard-interactive
    > ....
    >
    > Note: In PuTTY under Windows, the delay ends just as the connection
    > issue window displays.
    >
    >

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v2.0.9 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

    iQIcBAEBAgAGBQJK1oQ7AAoJEF+XTK08PnB5EzMP/iAzRG/+j6b8BDyG08OZWxRX
    5VV6B4UqsIl/S89DKZVxtFqIZqCfzGqN6jv1QbbMFuhU04Lr/bWz/KRb5ofNUoLE
    lSAHdvdk2Po5VCUmgDAcf42brD+H9XYxsu+lNNLW8Tluj/eQQcIylkUaEbreKVAf
    Dx5W42Yw2lHBnf3B2f12NJ/vIQZHwuIq1siSQdTp0y0CS8tPzeA5aTJzXUSEAlgQ
    EbBdlcALtbwoOIRPzktv4awN6YeubZZjnskDzMR6+Md/xKJ0rJkj+IY6dfiOOO86
    U0yCbhZ023/ebbMe+SyG3MuFNVGiifYeKobmLAj00gEjwfdk44/Yp93/olWuUefD
    KnepRoax1J98vFD3Dg7ul54zwonu/hgSXelNDxLCJtd8KXudUTCyVbHxB8xSaZtM
    NJA2TWveouWBDx3ZZZeGQR8YMwNZtn4ImEAJeYWY0PYA7I/vYJ8+5R+4P37BlfEq
    ec99lOPJb60ipFCFH16mpyMJim5SdplmlEopR0vo2kXXjgVgmwgdZsbGSwDX4ZF5
    zVV11F2eV79O+6gb78TBIyid9fVwl2oJoNZkqvMePb+oqakQGBKijUHf452Cofaa
    cWGYEHhNfAsu/sQ7w3BYfb9dXyGMMUXZhy4HDdLDCBgldAQ6QHbE5Wx6WER+8fCO
    CJtiA7Ul7VZ9xKNh8H2i
    =uYha
    -----END PGP SIGNATURE-----

  3. #3
    Join Date
    Oct 2008
    Location
    Manchester
    Posts
    128

    Default Re: Network Server Lag

    This could be a simple DNS issue on the server itself. If there is one. Do you use DNS ?

    Or does the ssh server have a correctly configured host file and resolv.conf file ? The resolv.conf file should also include the domain suffix relevent to the ssh server.

    I have seen delays as you describe caused by these issues, the local box is attempting to "find" itself, and eventually times out. Hence the lag.

    hth
    J
    Linux# makes_a_network_feel_good.sh

    Linux and BSD solutions

  4. #4

    Default Re: Network Server Lag

    When SSHing from localhost the password prompt is instant, as well as from the Internet; only local addresses are experiencing the delay. Perhaps it is my router that lacks DNS? (My PCs cannot look up names for each other with the current router, unlike the previous one.) How could I fix the DNS with resolv.conf or hosts?

    Also, neither the server side SSH log nor the client side log seem to contain anything related to the freeze. The server side simply says "Accepted keyboard-interactive/pam for [user] from 192.168.[#].[#] port [random]" and the client seems to do a normal connection procedure.

    Current resolv.conf:
    search local
    nameserver 192.168.0.1

    Current hosts:
    127.0.0.1 localhost
    .... (Generic IPv6 entries, but IPv6 is disabled)
    127.0.0.2 fileserver.home fileserver

  5. #5

    Default Re: Network Server Lag

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    If SSH cannot do a reverse lookup of the IP address to a DNS name then
    maybe that could be the problem. Does using 'dig -x' with the IP address
    come back at all? Quickly? You could hard-code any old hostname into
    /etc/hosts, sure, but doing that on every box you have could be a pain.
    You can also use public DNS servers assuming you are setup for DNS
    properly with those IP addresses but if you were you could probably use
    your own DNS servers as well (just specify them normally in Yast or
    directly in /etc/resolv.conf).

    Good luck.





    bamt wrote:
    > When SSHing from localhost the password prompt is instant, as well as
    > from the Internet; only local addresses are experiencing the delay.
    > Perhaps it is my router that lacks DNS? (My PCs cannot look up names for
    > each other with the current router, unlike the previous one.) How could
    > I fix the DNS with resolv.conf or hosts?
    >
    > Also, neither the server side SSH log nor the client side log seem to
    > contain anything related to the freeze. The server side simply says
    > "Accepted keyboard-interactive/pam for [user] from 192.168.[#].[#] port
    > [random]" and the client seems to do a normal connection procedure.
    >
    > Current resolv.conf:
    > search local
    > nameserver 192.168.0.1
    >
    > Current hosts:
    > 127.0.0.1 localhost
    > .... (Generic IPv6 entries, but IPv6 is disabled)
    > 127.0.0.2 fileserver.home fileserver
    >
    >

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v2.0.9 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

    iQIcBAEBAgAGBQJK4xp8AAoJEF+XTK08PnB5o+oP/R3EoUef02BdU5GptO4nhqFR
    Tt8ik6ra/RqKMB4HmnMuecwjhUm+0TvdgKr64AJ8140Ybo/EArCKfBxa/d4sANgP
    ptPnFP6Y+iUVn5ZZHLhPs7heUz5c2J60sfP8gQxmbBEmWIGGWBm2Z5+Vji19GkYX
    VUpUyUaKLapzZUFlMm49UCUOl1xJt7bu9MGc2NIxJEZgF4WKIoHKKukJmMcnWnjq
    RqVvEWl6jQt+sitJewvWJSyp6qKD/+JTo68sEaUQgAw7hRU4LDS8F3m8abvveHw1
    1exz5o3jZW54c4V6Bo1ntkzW6BBIEmygX4euDFMoZa8M+qIQTbsAy34fcoaJXUeK
    Y7ecBVktOAr8h8IwOxQMQj2WM99+nUZBwAPn7G55Csu23xa3piE3X9iJfjkylwRV
    5clqHGJuHkIbre3oSFT+eHWQuziBfnCyiLvVsVRHkKgAMMCfomLZS2TDV1gFwRTj
    t3t2mBK5mKfwqc+ULZjm6HwpJ+2KycvfCRbntXMHhsbWSZJBOatVO+EM/xqwNSit
    dYyrzr06jNVolutH6hEp18pQ0p2B7Ud1+8Xmuq0Ayazbge3RHmFlGZ/LZy0v0w4C
    JI4XUxTMGhAvNWYSWoqGZCoy5JhmQ6Lz85kPfA0G2C5l7BLo1ljQCwNqVhFEtUYB
    0AIZ5ngSGqNp2HNMoLvS
    =sj0g
    -----END PGP SIGNATURE-----

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •