Results 1 to 6 of 6

Thread: Trouble with nVidia driver and resolution

  1. #1
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    63

    Default Trouble with nVidia driver and resolution

    I've got an HP Pavilion dv6000 series with an nVidia GeForce 8400M GS graphics card. Everything is working fine with one exception: I can move my mouse off the screen to the left and it appears that the OS thinks I'm using two monitors (which I have done in the past). Some of my desktop icons aren't visible either. I'm sure there's a setting somewhere that controls this. Below is my xorg.conf file:

    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings: version 1.0 (buildmeister@builder58) Tue Nov 4 17:19:39 PST 2008

    # /.../
    # SaX generated X11 config file
    # Created on: 2008-12-20T15:21:49-0800.
    #
    # Version: 8.1
    # Contact: Marcus Schaefer <sax@suse.de>, 2005
    # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
    #
    # Automatically generated by [SaX2] (8.1)
    # PLEASE DO NOT EDIT THIS FILE!
    #

    Section "ServerLayout"
    Identifier "Layout[all]"
    Screen 0 "Screen0" 0 0
    InputDevice "Keyboard[0]" "CoreKeyboard"
    InputDevice "Mouse[1]" "CorePointer"
    InputDevice "Mouse[3]" "SendCoreEvents"
    EndSection

    Section "Files"
    InputDevices "/dev/gpmdata"
    InputDevices "/dev/input/mice"
    FontPath "/usr/share/fonts/misc:unscaled"
    FontPath "/usr/share/fonts/local"
    FontPath "/usr/share/fonts/75dpi:unscaled"
    FontPath "/usr/share/fonts/100dpi:unscaled"
    FontPath "/usr/share/fonts/Type1"
    FontPath "/usr/share/fonts/URW"
    FontPath "/usr/share/fonts/Speedo"
    FontPath "/usr/share/fonts/PEX"
    FontPath "/usr/share/fonts/cyrillic"
    FontPath "/usr/share/fonts/latin2/misc:unscaled"
    FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/Type1"
    FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
    FontPath "/usr/share/fonts/baekmuk:unscaled"
    FontPath "/usr/share/fonts/japanese:unscaled"
    FontPath "/usr/share/fonts/kwintv"
    FontPath "/usr/share/fonts/truetype"
    FontPath "/usr/share/fonts/uni:unscaled"
    FontPath "/usr/share/fonts/CID"
    FontPath "/usr/share/fonts/ucs/misc:unscaled"
    FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
    FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/misc:unscaled"
    FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/Type1"
    FontPath "/usr/share/fonts/misc/sgi:unscaled"
    FontPath "/usr/share/fonts/xtest"
    FontPath "/opt/kde3/share/fonts"
    EndSection

    Section "Module"
    Load "dri"
    Load "dbe"
    Load "freetype"
    Load "extmod"
    Load "glx"
    EndSection

    Section "ServerFlags"
    Option "AllowMouseOpenFail" "on"
    Option "ZapWarning" "on"
    Option "Xinerama" "0"
    EndSection

    Section "InputDevice"
    Identifier "Keyboard[0]"
    Driver "kbd"
    Option "Protocol" "Standard"
    Option "XkbLayout" "us"
    Option "XkbModel" "microsoftpro"
    Option "XkbRules" "xfree86"
    EndSection

    Section "InputDevice"
    Identifier "Mouse[1]"
    Driver "mouse"
    Option "Buttons" "7"
    Option "Device" "/dev/input/mice"
    Option "Name" "Microsoft IntelliMouse Optical"
    Option "Protocol" "explorerps/2"
    Option "Vendor" "Sysp"
    Option "ZAxisMapping" "4 5"
    EndSection

    Section "InputDevice"
    Identifier "Mouse[3]"
    Driver "synaptics"
    Option "Buttons" "5"
    Option "Device" "/dev/input/mice"
    Option "Emulate3Buttons" "on"
    Option "HorizScrollDelta" "0"
    Option "InputFashion" "Mouse"
    Option "Name" "Synaptics;Touchpad"
    Option "Protocol" "explorerps/2"
    Option "SHMConfig" "on"
    Option "Vendor" "Sysp"
    Option "ZAxisMapping" "4 5"
    EndSection

    Section "Modes"
    Identifier "Modes[0]"
    EndSection

    Section "Monitor"
    Identifier "Monitor[0]"
    VendorName "--> LCD"
    ModelName "800X600@60HZ"
    UseModes "Modes[0]"
    HorizSync 30.0 - 38.0
    VertRefresh 30.0 - 61.0
    Option "CalcAlgorithm" "XServerPool"
    Option "DPMS"
    Option "PreferredMode" "800x600"
    EndSection

    Section "Monitor"
    Identifier "Monitor0"
    VendorName "Unknown"
    ModelName "Chuntex"
    HorizSync 30.0 - 95.0
    VertRefresh 50.0 - 160.0
    EndSection

    Section "Device"
    Identifier "Device[0]"
    Driver "nvidia"
    VendorName "NVIDIA"
    BoardName "GeForce 8400M GS"
    EndSection

    Section "Device"
    Identifier "Device0"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    BoardName "GeForce 8400M GS"
    EndSection

    Section "Screen"
    Identifier "Screen[0]"
    Device "Device[0]"
    Monitor "Monitor[0]"
    DefaultDepth 24
    SubSection "Display"
    Depth 15
    Modes "800x600"
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "800x600"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "800x600"
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "800x600"
    EndSubSection
    EndSection

    Section "Screen"

    # Removed Option "metamodes" "CRT: nvidia-auto-select +0+0, DFP: 1280x800 +1600+0"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    Option "TwinView" "1"
    Option "TwinViewXineramaInfoOrder" "CRT-0"
    Option "metamodes" "CRT: 1280x1024 +0+0, DFP: 1280x800 +1280+0"
    SubSection "Display"
    Depth 24
    EndSubSection
    EndSection

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Trouble with nVidia driver and resolution

    If you go to Yast - Hardware - Graphics and Monitor

    Can you use the setup in there?
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    63

    Default Re: Trouble with nVidia driver and resolution

    Quote Originally Posted by caf4926 View Post
    If you go to Yast - Hardware - Graphics and Monitor

    Can you use the setup in there?
    First I get an error message: "Cannot Deactivate All Displays. At least one display must be active." Hitting OK, the X11 config screen comes up but only one display is shown and Dual Head Mode is not checked (and is also disabled).

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Trouble with nVidia driver and resolution

    Make sure you have disabled auto login
    Disable Auto-Login - openSUSE Forums

    Logout and from the lower left corner choose a console login.
    Login with your username and password
    Now switch to su
    enter root password.

    Do this:
    Code:
    sax2 -r
    reboot
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    63

    Default Re: Trouble with nVidia driver and resolution

    That fixed it, thanks!

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Trouble with nVidia driver and resolution

    Quote Originally Posted by DiskCrasher View Post
    That fixed it, thanks!
    Happy that sorted it for you
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •