Results 1 to 4 of 4

Thread: No sound in 64-bit SuSE 11.1 again

  1. #1
    Join Date
    Oct 2009
    Location
    Minsk
    Posts
    24

    Default No sound in 64-bit SuSE 11.1 again

    Dear oldcpu

    I have read some posts about sound problems here. I have same sound problem - I listen nothing.

    I have SuSE Linux 11.1 64-bit. I did steps describes in my start-up manual "openSuSE 11.1" chapter 2.4, but I have not any sounds.

    My system has next equipments:
    1. CPU - Intel Core 2 Quard 9550 (2.84 Ghz)
    2. RAM - DDR3 8 GB
    3. Motherboard - XFX nForce 790i ultra 3-way SLI. It has three slots PCI Express x16 for graphic cards. I made "dual-head" monitors system. It works.
    4. Two graphic cards - Palit GeForce 9500GT and two monitors - NEC LCD1970NX and HP LP2275w

    My system has two sound devices:
    - built-in to motherBoard - HDA MCP55 from nVidia;
    - sound card in PCI slot - Sound Blaster Audigy 4 [SB0610].

    The YAST recognized both devices, but when I runnig xWindow I have not any sounds and have the negative message from "Phonon" only.

    I did on my computer your advices to users: "sven25", "mhibist" and "road-movie", but hear nothing again.

    I send you my listing below. Can you help me some advices?


    1. speaker-test -Dplug:front -c2 -l5 -twav

    I see runnihg that command on screen but hear nothing.


    2. /usr/sbin/alsa-info.sh

    I have not this file.


    3. rpm -qa | grep alsa

    alsa-oss-1.0.17-1.43
    alsa-plugins-pulse-1.0.18-6.13
    alsa-utils-1.0.18-6.4
    alsa-oss-32bit-1.0.17-1.37
    alsa-devel-1.0.21-43.1
    alsa-plugins-1.0.18-6.13
    alsa-1.0.21-43.1
    alsa-firmware-1.0.17-1.42
    alsa-driver-kmp-default-1.0.21.20091014_2.6.27.29_0.1-1.1
    alsa-docs-1.0.18-8.12.1


    4. rpm -qa | grep pulse

    libpulse0-32bit-0.9.14-2.2.1
    pulseaudio-0.9.14-2.2.1
    pulseaudio-module-x11-0.9.14-2.2.1
    pulseaudio-esound-compat-0.9.14-2.2.1
    alsa-plugins-pulse-1.0.18-6.13
    libxine1-pulse-1.1.15-23.3.3
    pulseaudio-module-bluetooth-0.9.14-2.2.1
    libpulse-mainloop-glib0-0.9.14-2.2.1
    pulseaudio-module-gconf-0.9.14-2.2.1
    pulseaudio-utils-0.9.14-2.2.1
    pulseaudio-module-lirc-0.9.14-2.2.1
    pulseaudio-lang-0.9.14-2.2.1
    pulseaudio-module-zeroconf-0.9.14-2.2.1
    libpulse-browse0-0.9.14-2.2.1
    libpulse0-0.9.14-2.2.1
    pulseaudio-module-jack-0.9.14-2.2.1


    5. rpm -q libasound2

    libasound2-1.0.21-43.1


    6. uname -a

    Linux jr-14 2.6.27.29-0.1-default #1 SMP 2009-08-15 17:53:59 +0200 x86_64 x86_64 x86_64 GNU/Linux

    7.cat /etc/modprobe.d/sound

    options snd slots=snd-emu10k1,snd-hda-intel
    # ZvjX.up6Wra2JIU9:SB0400 Audigy2 Value
    alias snd-card-0 snd-emu10k1
    # rKvl.IkFmmAtuYDC:MCP55 High Definition Audio
    alias snd-card-1 snd-hda-intel

    I want to listen sounds in my system. Can you help me?

    Regards
    Dremu4ii

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: No sound in 64-bit SuSE 11.1 again

    Quote Originally Posted by Dremu4ii View Post
    2. /usr/sbin/alsa-info.sh

    I have not this file.
    Are you certain? If I type:
    Code:
    oldcpu@hal1000:~> rpm -qf /usr/sbin/alsa-info.sh
    I get:
    Code:
    alsa-1.0.21-43.1
    which tells me that script comes with alsa.

    I note you have alsa-1.0.21-43.1 so I suspect either you had a bad update to alsa-1.0.21-43.1 (in which case you should re-install it) or possibly you made a mistake in not finding the script?

    I would really like to see the output of that diagnostic script, as it gives useful information that is difficult to get otherwise.

    Also, reference your audigy, note it is very sensitive to mixer settings. Take a look at this thread: [Solution] Creative Audigy 1/2 + 11.0 + KDE/GNOME + ALSA - openSUSE Forums
    .. while written for an older openSUSE version, a lot is still applicable in 11.1.

  3. #3
    Join Date
    Oct 2009
    Location
    Minsk
    Posts
    24

    Default Re: No sound in 64-bit SuSE 11.1 again

    Yes, You are right.

    I type:
    rpm -qf /usr/sbin/alsa-info.sh

    and I get:
    alsa-1.0.21-43.1

    So, as I understand, - Must I remove alsa from my computer? And next? Must I re-install it... from where? From my distributive DVD disk openSuSE 11.1? or from other place?

    Yes I took my audigy card from the old 32-bit computer where was old openSuSE 10.1. It recognized audigy and I had sounds many years.

    Regards
    Dremu4ii

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: No sound in 64-bit SuSE 11.1 again

    Quote Originally Posted by Dremu4ii View Post
    I type:
    rpm -qf /usr/sbin/alsa-info.sh

    and I get:
    alsa-1.0.21-43.1

    So, as I understand, - Must I remove alsa from my computer? And next?
    First, please double check and ensure that alsa-info.sh file is not present. Surely it is present?

    If you must re-install alsa, then what I would do is roll back to the version of alsa (1.0.17 or 1.0.18), that came with openSUSE-11.1 (its on your installation CD/DVD) and then re-isntall again the alsa version you desire (currently you have alsa-1.0.21-43.1).

    After rolling back to the basic alsa (1.0.17 or 1.0.18) there is guidance here on how to update to the 1.0.21 version (note one MUST send six zypper commands): Alsa-update - openSUSE

    Once you have alsa-info.sh properly on your system, then please run in it via.
    /usr/sbin/alsa-info.sh

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •