Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Automatically start Knetworkmanager?

  1. #1

    Default Automatically start Knetworkmanager?

    I'm configuring a computer for someone and I don't know the wireless network they will be using. (They are not technical.) I've setup networking to use NetworkManager. It works just fine.

    However, Knetworkmanager won't startup at boot/login. Therefore, the network doesn't startup automatically. I have to click on the icon in the menu to start it. That works well, but it should be configurable to startup automatically.

    I've searched in this forum for answers and don't find any good ones. It seems there isn't an answer or there is a bug in KDE 4.x. (I'm using KDE 4.3.x) Any clues or help on this?

    Thanks,
    Clyde

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Automatically start Knetworkmanager?

    System Settings - Advanced - Autostart
    Add it in there
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Automatically start Knetworkmanager?

    Thanks for the reply. However, I can't find that. I can see the menu item "System" under which I can see "Administrator Settings". That is YaST, of course. The "System" tab under that has a bunch of stuff that doesn't line up with "Advanced" or "Autostart".

    Please point me in the right direction.

    Thanks,
    Clyde

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Automatically start Knetworkmanager?

    open a terminal and type: systemsettings
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: Automatically start Knetworkmanager?

    Thanks! That was perfect. It works great now.

    I don't know if that is a hidden feature of openSUSE or not, but it seems like it should be a little less hidden.

    Thanks,
    Clyde

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Automatically start Knetworkmanager?

    Check from the Menu - Application
    Bottom of the list - It's there for me, and in my Favs
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7
    Join Date
    Sep 2009
    Location
    Seattle, WA
    Posts
    276

    Default Re: Automatically start Knetworkmanager?

    When I enter systemsettings in a terminal nothing happens, goes right back to a prompt. Does this need a package installed? And yes, I'm trying to run it as root.

  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Automatically start Knetworkmanager?

    System settings should be run as user
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  9. #9
    Join Date
    Jun 2008
    Location
    wichita
    Posts
    990

    Default Re: Automatically start Knetworkmanager?

    Quote Originally Posted by caf4926 View Post
    System Settings - Advanced - Autostart
    Add it in there
    This doesn't work for me in 11.1. KNetworkmanager is added to the list of which programs start with KDE and 'Enabled startup' is checked but it doesn't start up at boot. I have to start it manually every time.

  10. #10
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Automatically start Knetworkmanager?

    Quote Originally Posted by pilotgi View Post
    This doesn't work for me in 11.1. KNetworkmanager is added to the list of which programs start with KDE and 'Enabled startup' is checked but it doesn't start up at boot. I have to start it manually every time.
    You are talking knetworkmanager from kde3 - correct?
    IIRC the settings in auto start are tricky. Just check it is enabled to auto start
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •