Results 1 to 9 of 9

Thread: vlc dependancies

  1. #1

    Default vlc dependancies

    Hi, I've just installed opensuse 11.1 kde 3.5x.
    When I goto install vlc from the packman repo I get this error :

    nothing provides libcv.so.1.2 needed by vlc-noX-1.0.2-0.pm.5.9.i586

    I tried the oneclick link on the packman webpage

    PackMan :: Package details for vlc

    with the same error.

    If I enable the videolan repo then installing from there gives no dependency issues but I don't want to go down that route if poss.

    Any ideas ?

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: vlc dependancies

    Don't install from VLC repo.

    The issue you report is there for me too. But I already have vlc installed, so I just left it. I sent a report to Packman but not sorted yet. You can also work round by choosing
    Do Not Install opencv-2.0.0.........
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Jun 2008
    Location
    /dev/swat
    Posts
    1,181

    Default Re: vlc dependancies

    Try to update your system and see if this can resolve the issue:

    Code:
    zypper up
    Also enable the oss,non-oss and update repo and disable all others. and run the above command in terminal as root.
    Linux[openSUSE, KDE], PHP, MySQL, Wordpress, Tech News, etc :
    http://anl4u.com

  4. #4

    Default Re: vlc dependancies

    I ran an update from konsole, and whilst I got some updates not handled by the updater applet (including yast2-online-update) the problem with vlc persists.

    Thanks for your quick replies.

    Incidentally I'm Installing 11.1 KDE 4x on another machine, it'll be interesting to see if the dependency is the same for that version of KDE.

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: vlc dependancies

    The packaging error is at Packman not openSUSE, so the error will be the same. I just deleted vlc and libcv.so.1.2 (which I did have). Now I get the same issue as you and vlc will not install.
    No matter, I never actually use vlc and it's sure to be fixed soon. There have been hundreds of package changes in Packman recently.
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: vlc dependancies

    This is the respose from Packman:

    opencv has been updated, vlc is in building queue and will be rebuilt on
    new opencv soon.
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7
    Join Date
    Jun 2008
    Location
    /dev/swat
    Posts
    1,181

    Default Re: vlc dependancies

    Thanks caf for the information.
    Linux[openSUSE, KDE], PHP, MySQL, Wordpress, Tech News, etc :
    http://anl4u.com

  8. #8

    Default Re: vlc dependancies

    All sorted now, I wish politicians were as responsive (and useful) as you guys.

    Cheers

  9. #9
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: vlc dependancies

    Quote Originally Posted by danceswithferrets View Post
    All sorted now, I wish politicians were as responsive (and useful) as you guys.

    Cheers
    That'll be the day. All help offered freely and happily.
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •