Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Suse11.1 no sound

  1. #1

    Default Suse11.1 no sound

    Helllo , I'm running Suse 11.1 and I have this problem:

    while running movie with mplayer from the terminal the sound is fine. But when I try to play something else there is no sound. Even in youtube there is no sound. The sound manager in Yast gets my sound card, but when try to make a tets sound - Nothing?Any suggestions please ??

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Suse11.1 no sound

    You have working sound? Just not when two applications are trying to use it? Correct?

    This can be a problem. oldcpu to the rescue me thinks.

    Hang on, he'll spot it, he's online.

    Something to do with this:
    SDB:AudioTroubleshooting - openSUSE
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Suse11.1 no sound

    Quote Originally Posted by SpicyMcHaggis View Post
    while running movie with mplayer from the terminal the sound is fine. But when I try to play something else there is no sound. Even in youtube there is no sound. The sound manager in Yast gets my sound card, but when try to make a tets sound - Nothing?Any suggestions please ??
    Ok, it appears you may have a couple of problems.

    First, I note you state you can play a movie with mplayer from the terminal. Great ! So basic sound works. ... As an aside - install smplayer from packman. Its a front end GUI to mplayer and it is great! Incredible even.

    Reference youtube. That could be your browsers ability to play flash. Some 32-bit and 64-bit users have discovered if they keep flash-player but remove libflashsupport, their audio will work. Try that. Maybe also let us know if your PC is a 32-bit or 64-bit ?

    As for YaST test sound not working - there is a known bug in YaST sound module where for some sound cards the test sound does not work.

    If you want to test your sound, take a look at step#1 here: SDB:AudioTroubleshooting - openSUSE - How to Test your sound

  4. #4

    Default Re: Suse11.1 no sound

    Thanks I will try my PC is 64bits

  5. #5

    Default Re: Suse11.1 no sound

    I have tried all of thise:
    11.1 NO sound with 82801I (ICH9 Family) HD Audio Controller - openSUSE Forums

    by the way, my sound card is the same ,when I tipped

    Code:
    speaker-test -c2 -l5 -twav
    There was sound. I also run
    Code:
    /usr/sbin/alsa-info.sh
    the result :http://www.alsa-project.org/db/?f=41...ff7a8249232afd

    rpm -qa | grep alsa
    rpm -qa | grep pulse
    rpm -q libasound2
    uname -a
    cat /etc/modprobe.d/sound

    this output is :

    Code:
    linux-ha2a:/home # rpm -qa | grep alsa
    alsa-oss-32bit-1.0.17-1.37
    alsa-plugins-1.0.18-6.13
    alsa-firmware-1.0.17-1.42
    alsa-oss-1.0.17-1.43
    alsa-utils-1.0.18-6.4
    alsa-1.0.18-8.9
    alsa-plugins-pulse-1.0.18-6.13
    java-1_5_0-sun-alsa-1.5.0_update20-0.1.1
    linux-ha2a:/home  # rpm -qa | grep pulse
    libpulse0-0.9.12-9.5
    libpulsecore4-0.9.12-9.5
    libpulse0-32bit-0.9.12-9.6
    pulseaudio-0.9.12-9.5
    alsa-plugins-pulse-1.0.18-6.13
    libxine1-pulse-1.1.15-23.3.3
    pulseaudio-esound-compat-0.9.12-9.5
    linux-ha2a:/home  # rpm -q libasound2
    libasound2-1.0.18-8.9
    linux-ha2a:/home # uname -a
    Linux linux-ha2a 2.6.27.7-9-default #1 SMP 2008-12-04 18:10:04 +0100 x86_64 x86_64 x86_64 GNU/Linux
    linux-ha2a:/home # cat /etc/modprobe.d/sound
    Still no sound

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Suse11.1 no sound

    I'm confused.

    You stated sound in mplayer. and stated:
    Quote Originally Posted by SpicyMcHaggis View Post
    by the way, my sound card is the same ,when I tipped
    Code:
    speaker-test -c2 -l5 -twav
    There was sound.
    So there IS sound in a test !

    But then you stated:
    Quote Originally Posted by SpicyMcHaggis View Post
    Still no sound
    No sound where? With flash and firefox? You may have a 64-bit PC flash problem - in which case, I probably don't know enough to help you there with wasting a lot of time hunting back and forth with various ideas. Someone else who can "cut to the chase" quicker with setting up flash on a 64-bit system should step in here.

    Did you try smplayer?

  7. #7

    Default Re: Suse11.1 no sound

    Yes I tried smplayer but again nothing . I didn;t get how when testing in terminal there is sound : mplayer, the test sound left, right.. but when I tried with vlc for example no sound?

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Suse11.1 no sound

    Quote Originally Posted by SpicyMcHaggis View Post
    Yes I tried smplayer but again nothing . I didn;t get how when testing in terminal there is sound : mplayer, the test sound left, right.. but when I tried with vlc for example no sound?
    There should be should in smplayer if there is sound in mplayer. Note smplayer lets one select the sound engine. Go to smplayer > options > preferences > audio and try different output drivers.

    Some with vlc. Go to vlc > tools > preferences > audio > output and try different settings.

    Also try it with different files, to ensure its no some obscure format that is causing the problem.

  9. #9

    Default Re: Suse11.1 no sound

    Hi, I think I get the problem. When I run a program Xmms to play a file - no sound , but when run it from terminal as su yes the sound is ok how to fix that??any ideas??

  10. #10
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Suse11.1 no sound

    Quote Originally Posted by SpicyMcHaggis View Post
    Hi, I think I get the problem. When I run a program Xmms to play a file - no sound , but when run it from terminal as su yes the sound is ok how to fix that??any ideas??
    Try adding your regular user to group audio. Follow the guidance here in step#6: SDB:AudioTroubleshooting - openSUSE - how to fix permissions problem - step#6

    Then restart your pc and test.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •