Results 1 to 4 of 4

Thread: Java problems on Opensuse 11.1

  1. #1

    Default Java problems on Opensuse 11.1

    Hello out there,

    I'm newbie, and I've successfully installed opensuse and gotten just about everything working very nicely. It's been several days now that I haven't used Windows, and it feels good.

    The one last big problem that I'm experiencing is with Java. When I get to a page with a java applet, Konqueror does nothing, and Firefox crashes. Updating from Java 1.5.0 to 1.6.0 through yast didn't help.

    If I run Firefox from a terminal, this is what it spits out during the crash:
    Code:
    java version "1.6.0_0"                                                            
    OpenJDK Runtime Environment (IcedTea6 1.6) (suse-0.1.3-i386)                      
    OpenJDK Client VM (build 14.0-b16, mixed mode)                                    
    Calling plugin_get_documentbase                                                   
    Calling plugin_get_documentbase                                                   
    java.lang.RuntimeException: Failed to handle message: GetJavaObject for instance 1 Thread[Thread-3,5,main]
            at sun.applet.PluginAppletViewer.handleMessage(PluginAppletViewer.java:533)                       
            at sun.applet.PluginStreamHandler.handleMessage(PluginStreamHandler.java:295)                     
            at sun.applet.PluginMessageHandlerWorker.run(PluginMessageHandlerWorker.java:72)                  
    Caused by: java.lang.NullPointerException                                                                 
            at sun.applet.PluginAppletViewer.handleMessage(PluginAppletViewer.java:592)                       
            at sun.applet.PluginAppletViewer.handleMessage(PluginAppletViewer.java:525)                                                      
            ... 2 more                                                                                                                       
    java.lang.RuntimeException: Failed to handle message: GetJavaObject for instance 1 Thread[Thread-5,5,main]                               
            at sun.applet.PluginAppletViewer.handleMessage(PluginAppletViewer.java:533)                                                      
            at sun.applet.PluginStreamHandler.handleMessage(PluginStreamHandler.java:295)                                                    
            at sun.applet.PluginMessageHandlerWorker.run(PluginMessageHandlerWorker.java:72)                                                 
    Caused by: java.lang.NullPointerException                                                                                                
            at sun.applet.PluginAppletViewer.handleMessage(PluginAppletViewer.java:592)                                                      
            at sun.applet.PluginAppletViewer.handleMessage(PluginAppletViewer.java:525)                                                      
            ... 2 more                                                                                                                       
    Error: Unable to fetch applet instance id from Java side.                                                                                
    Error: Unable to fetch applet instance id from Java side.                                                                                
    IcedTeaNPPlugin.cc:635: thread 0xb7913a30: Error: Unknown plugin value requested.                                                        
    /usr/bin/firefox: line 128:  3946 Segmentation fault      $MOZ_PROGRAM "$@"
    I'm running Firefox 3.5.3 on top of KDE 4.3.1 and Opensuse 11.1. Any suggestions would be greatly appreciated!

    Thanks,

    Daniel

  2. #2
    Camalen NNTP User

    Default Re: Java problems on Opensuse 11.1

    dmorgan4 wrote:

    > I'm newbie, and I've successfully installed opensuse and gotten just
    > about everything working very nicely. It's been several days now that I
    > haven't used Windows, and it feels good.
    >
    > The one last big problem that I'm experiencing is with Java. When I
    > get to a page with a java applet, Konqueror does nothing, and Firefox
    > crashes. Updating from Java 1.5.0 to 1.6.0 through yast didn't help.
    >
    > If I run Firefox from a terminal, this is what it spits out during the
    > crash:
    >
    > Code:
    > --------------------
    > java version "1.6.0_0"
    > OpenJDK Runtime Environment (IcedTea6 1.6) (suse-0.1.3-i386)


    It seems you are using IcedTea Java. Better try with "Sun's Java" which is
    far better.

    Greetings,

    --
    Camalen

  3. #3

    Default Re: Java problems on Opensuse 11.1

    Bravo! The Sun java plugin works great.

  4. #4
    balajicre NNTP User

    Default Re: Java problems on Opensuse 11.1

    Hi

    I was just wondering how you could get Icedtea6 rpm. I am searching this for the open suse platform, but i could never get it. I appreciate if you can tell me how you got it.

    Balaji.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •