Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: Sound in VLC keeps cutting out

  1. #1

    Default Sound in VLC keeps cutting out

    Hi,

    Recently started using openSUSE and everything's going swimmingly apart from this. Whenever I try to play a movie or piece of music in VLC the sound only plays for around a second every four seconds or so.

    Is it possibly a driver issue, or a problem with dependencies?

    Thanks guys.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,743
    Blog Entries
    20

    Default Re: Sound in VLC keeps cutting out

    Did you follow this: Multi-media and Restricted Format Installation Guide - openSUSE Forums

    Follow it carefully.

    Personally I prefer smplayer over vlc.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Sound in VLC keeps cutting out

    I'd just finished following that guide before I posted. Didn't seem to make any difference.

    SMplayer does work quite nicely but it would be nice to get VLC working.

    Thanks for the quick reply!

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,743
    Blog Entries
    20

    Default Re: Sound in VLC keeps cutting out

    Please post the result of this from a terminal

    Code:
    zypper lr -d
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,595
    Blog Entries
    38

    Default Re: Sound in VLC keeps cutting out

    Quote Originally Posted by caf4926 View Post
    Please post the result of this from a terminal

    Code:
    zypper lr -d
    In addition to providing the output of the command that caf4926 gave you, please also provide the output of:
    Code:
    rpm --query --all 'libav*' 'libpostproc*' 'libswscale*' '*xine*' '*gst*' '*layer*' '*vlc*' | grep -v avahi | sort
    ... also, do you have beagle enabled? It can really "suck" your CPU while it categorizes your hard drive. I recommend you remove beagle.

    ... also, if this is more choppy than cutting out, you could apply a pulse audio fix in case it is a pulse audio problem. Note the approach here in step-7:
    SDB:AudioTroubleshooting - openSUSE - step-7

  6. #6

    Default Re: Sound in VLC keeps cutting out

    for zypper lr -d:
    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    --+-----------------+-----------------------+---------+---------+----------+--------+-----------------------------------------------------------------+--------
    1 | Packman | Packman | Yes | Yes | 99 | rpm-md | Index of /packman/suse/11.1 |
    2 | Videolan_VLC | Videolan VLC | Yes | Yes | 99 | rpm-md | Index of /pub/vlc/SuSE/11.1/ |
    3 | openSUSE 11.1-0 | openSUSE 11.1-0 | Yes | No | 99 | yast2 | cd:///?devices=/dev/sr0 |
    4 | repo-debug | openSUSE-11.1-Debug | No | Yes | 100 | NONE | Index of /debug/distribution/11.1/repo/oss |
    5 | repo-non-oss | openSUSE-11.1-Non-Oss | Yes | Yes | 100 | yast2 | Index of /distribution/11.1/repo/non-oss |
    6 | repo-oss | openSUSE-11.1-Oss | Yes | Yes | 100 | yast2 | Index of /distribution/11.1/repo/oss |
    7 | repo-source | openSUSE-11.1-Source | No | Yes | 100 | NONE | Index of /source/distribution/11.1/repo/oss |
    8 | repo-update | openSUSE-11.1-Update | Yes | Yes | 20 | rpm-md | Index of /update/11.1
    for rpm --query --all 'libav*' 'libpostproc*' 'libswscale*' '*xine*' '*gst*' '*layer*' '*vlc*' | grep -v avahi | sort:

    banshee-1-backend-engine-gstreamer-1.4.3-1.2.1
    flash-player-10.0.32.18-0.1.1
    gstreamer-0_10-0.10.24-999.pm.1000.3
    gstreamer-0_10-ffmpeg-0.10.8-999.pm.1001.3
    gstreamer-0_10-fluendo-mp3-0.10.10-42.pm.1
    gstreamer-0_10-fluendo-mpegdemux-0.10.23-42.pm.1
    gstreamer-0_10-fluendo-mpegmux-0.10.4-42.pm.1
    gstreamer-0_10-lang-0.10.24-999.pm.1000.3
    gstreamer-0_10-plugins-bad-0.10.8-6.6.1
    gstreamer-0_10-plugins-bad-lang-0.10.8-6.6.1
    gstreamer-0_10-plugins-base-0.10.24-999.pm.1000.2
    gstreamer-0_10-plugins-base-lang-0.10.24-999.pm.1000.2
    gstreamer-0_10-plugins-good-0.10.10-3.22.1
    gstreamer-0_10-plugins-good-extra-0.10.10-3.22.1
    gstreamer-0_10-plugins-ugly-0.10.12-999.pm.1000.7
    gstreamer-0_10-plugins-ugly-lang-0.10.12-999.pm.1000.7
    gstreamer-0_10-schroedinger-1.0.5-42.pm.48.2
    gstreamer-0_10-utils-0.10.24-999.pm.1000.3
    gstreamer-utils-0.10.24-999.pm.1000.3
    libavc1394-0-0.5.3-129.3
    libavcodec52-0.5.0.20191-1.1
    libavformat52-0.5.0.20191-1.1
    libavutil50-0.5.0.20191-1.1
    libgstinterfaces-0_10-0-0.10.24-999.pm.1000.2
    libgstreamer-0_10-0-0.10.24-999.pm.1000.3
    libpostproc51-0.5.0.20191-1.1
    libswscale0-0.5.0.20191-1.1
    libvlc2-1.0.2-2.3
    libvlccore2-1.0.2-2.3
    libxine1-1.1.16.3-2.pm.6.7
    libxine1-codecs-1.1.16.3-2.pm.6.7
    libxine1-gnome-vfs-1.1.16.3-2.pm.6.7
    libxine1-pulse-1.1.16.3-2.pm.6.7
    MPlayer-1.0rc2_r29116-2.pm.29.8
    pullin-flash-player-11.1-1.1
    smplayer-0.6.8-0.pm.2.2
    vlc-1.0.2-2.3
    vlc-noX-1.0.2-2.3
    vlc-qt-1.0.2-2.3
    xinetd-2.3.14-129.28
    Thanks guys!

  7. #7
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,595
    Blog Entries
    38

    Default Re: Sound in VLC keeps cutting out

    caf4926 asked this:
    Quote Originally Posted by caf4926 View Post
    To which you replied this:
    Quote Originally Posted by IrrelevantElephant View Post
    I'd just finished following that guide before I posted. Didn't seem to make any difference.
    Last I read that guide, it stated you MUST disable videolan (or do I have my guides mixes up). But when I look at this:
    Quote Originally Posted by IrrelevantElephant View Post
    for zypper lr -d:

    Code:
    2 | Videolan_VLC | Videolan VLC | Yes | Yes | 99 | rpm-md | Index of /pub/vlc/SuSE/11.1/ |
    clearly videlan is enabled which means the advice in the link referenced in caf4926's post was ignored.

    There is a possibility that might be your problem. It will not be until I get home later and am able to check the rpm versions that I will be able to acertain that is the case, but it looks so to me. Clearly your vlc version is NOT a packman version, and you have mixed up packman and videolan versions likely causing all sorts of problems.

  8. #8

    Default Re: Sound in VLC keeps cutting out

    After following the guide, VLC did not appear to be installed, I added it from the VLC repository without any dependency warnings.

  9. #9
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,595
    Blog Entries
    38

    Default Re: Sound in VLC keeps cutting out

    Quote Originally Posted by IrrelevantElephant View Post
    After following the guide, VLC did not appear to be installed, I added it from the VLC repository without any dependency warnings.
    The guide warns to use videolan for only libdvdcss.

    There are no dependency warnings. This is a community hiccup with different packagers deciding NOT to work to have compatibility with each other's packages, and it is not within the "power" of this forum to do anything about but provide advice to warn users. If users ignore the warning then they will likely experience the consequences.

    The videolan packaged vlc is not compatible with packman packaged codecs nor other packman packaged apps.

    IMHO you should replace ALL videolan packaged applications with Packman packaged applications.

  10. #10
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,595
    Blog Entries
    38

    Default Re: Sound in VLC keeps cutting out

    ... also, do not forget to check into this:
    Quote Originally Posted by oldcpu View Post
    ... also, do you have beagle enabled? It can really "suck" your CPU while it categorizes your hard drive. I recommend you remove beagle.

    ... also, if this is more choppy than cutting out, you could apply a pulse audio fix in case it is a pulse audio problem. Note the approach here in step-7:
    SDB:AudioTroubleshooting - openSUSE - step-7

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •