Results 1 to 6 of 6

Thread: lost all audio -

  1. #1
    puffa NNTP User

    Default lost all audio -

    Newinstall of 11.1 x86 on laptop - - on first boot had audio (boot music) then installed flash plugin and since then i have no audio...I am almost a noobie..know just a little like su in a terminal...dunno if the flash broke the audio or not...

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: lost all audio -

    Quote Originally Posted by puffa View Post
    Newinstall of 11.1 x86 on laptop - - on first boot had audio (boot music) then installed flash plugin and since then i have no audio...I am almost a noobie..know just a little like su in a terminal...dunno if the flash broke the audio or not...
    Its not likely flash broke the audio. Its more likely that you installed something else at the same time as flash (such as a kernel update) that may have broke your laptop sound.

    The general advice I give for sound problems is to start trying to work your way through the openSUSE audio troubleshooting guide: SDB:AudioTroubleshooting - openSUSE .

    Do NOT use the startup system sound as your criteria for stating sound does not work. Also be certain to check your mixer. Its not uncommon for a mixer setting (master, pcm or speaker) to be muted upon boot. In KDE your mixer is "kmix" (the small speaker in right hand corner). In Gnome your mixer is "alsamixer".

    Note, when testing if you have sound, please copy and paste the following speaker-test into a Gnome terminal or a kde konsole:

    speaker-test -Dplug:front -c2 -l5 -twav

    Note Linux is case sensitive, and D is not the same as d. To stop the above test, while the konsole/xterm has the mouse focus, press <CTRL><C> on the keyboard. Note you should check your mixer settings (kmix if using KDE, and alsamixer if using Gnome) to ensure that PCM and Master Volume are set around 95%. Once you have basic sound established you can back off to lower volume levels. Note the test for surround sound is different.

    If that test yields errors (and its not uncommon to get errors there), try instead this more simple test:
    speaker-test -c2 -l5 -twav
    You should hear a female voice saying 'FRONT LEFT', 'FRONT RIGHT' five times. Its quite common that one of those speaker tests will work and one will NOT work, so don't be distressed if that is the case. IF that test gives sound, stop now, post that the sound test gives sound, and we will look at other possible causes for your applications not giving you the sound you want (such as missing codecs, using the wrong packaged version ... etc ... ).

    Or alternatively, for testing the simple playback, use aplay program. Prepare a WAV file and simply run like:
    Code:
    aplay -vv somefile.wav
    With the option -vv, aplay shows the verbose information of the PCM device, and a VU-peak meter during playing the file.

    Try those speaker-tests as both a regular user, and also with root permissions. If you have a headset, try with your headset plugged in, and also with your headset not plugged in (for speakers).

    Assuming no sound, can you provide more very detailed information so a good recommendation can be given? For openSUSE-11.1, you can do that, with your laptop connected to the internet, by opening a gnome-terminal or a kde konsole and twice copy and paste the following into that terminal/konsole
    Code:
    /usr/sbin/alsa-info.sh
    Run it the 1st time with root permissions. It will ask if you wish to do an update of the script. Select YES.

    Then run it again (as either a regular user or as root). This time it will diagnose your PC's hardware and software configuration for audio, and it will post its output on the Internet/web. It will give you the URL of the web site. Please post that URL here. JUST the URL.

    If you are not using openSUSE-11.1, please advise.

    Also, please copy and paste the following commands one line at a time into a gnome-terminal or a konsole and post here the output:
    rpm -qa | grep alsa
    rpm -qa | grep pulse
    rpm -q libasound2
    uname -a
    cat /etc/modprobe.d/sound
    ... with that information I may be able to make a recommendation.

    Also, do NOT waste too much time on this. Simply post on our forum if you get stumped, and continue to look for help that way.

    Also, before you start deep into troubleshooting you could read our "stickie" : NEWBIES - Suse-11.1 Pre-installation PLEASE READ - openSUSE Forums

    and also brush up on openSUSE concepts: Concepts - openSUSE ... the concepts are important. ... without a rough understanding of that, the reason why you are asked to do things will often be totally lost on you.

  3. #3
    puffa NNTP User

    Default Re: lost all audio -

    http://www.alsa-project.org/db/?f=6a...c9f2cd7813dda6

    ---------------------------------------------------

    this is the test results link

  4. #4
    puffa NNTP User

    Default Re: lost all audio -

    ray@linux-7qpj:~> rpm -qa | grep alsa
    alsa-oss-1.0.17-1.37
    alsa-tools-gui-1.0.18-1.13
    alsa-utils-1.0.18-6.4
    alsa-tools-1.0.18-1.13
    alsa-plugins-pulse-1.0.18-6.12
    alsa-plugins-1.0.18-6.12
    alsa-1.0.18-8.7
    alsa-firmware-1.0.17-1.42
    ray@linux-7qpj:~> rpm -qa | grep pulse
    pulseaudio-0.9.12-9.6
    pulseaudio-module-gconf-0.9.12-9.6
    pulseaudio-module-lirc-0.9.12-9.6
    libpulse-mainloop-glib0-0.9.12-9.6
    alsa-plugins-pulse-1.0.18-6.12
    libpulse-browse0-0.9.12-9.6
    pulseaudio-utils-0.9.12-9.6
    pulseaudio-module-zeroconf-0.9.12-9.6
    libpulse0-0.9.12-9.6
    libpulsecore4-0.9.12-9.6
    pulseaudio-esound-compat-0.9.12-9.6
    pulseaudio-module-x11-0.9.12-9.6
    pulseaudio-module-bluetooth-0.9.12-9.6
    ray@linux-7qpj:~> rpm -q libasound2
    libasound2-1.0.18-8.7
    ray@linux-7qpj:~> uname -a
    Linux linux-7qpj 2.6.27.7-9-pae #1 SMP 2008-12-04 18:10:04 +0100 i686 i686 i386 GNU/Linux
    ray@linux-7qpj:~> cat /etc/modprobe.d/sound

    options snd slots=snd-hda-intel
    # u1Nb.sBxdZWtb8gD:82801G (ICH7 Family) High Definition Audio Controller
    alias snd-card-0 snd-hda-intel
    ray@linux-7qpj:~>

  5. #5
    puffa NNTP User

    Default Re: lost all audio -

    the left-right "test" - - the first one didnt work, no errors

    the second one ran but no sound in root or regular user

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: lost all audio -

    Quote Originally Posted by puffa View Post
    http://www.alsa-project.org/db/?f=6a...c9f2cd7813dda6
    ---------------------------------------------------
    this is the test results link
    OK thanks. I note a 32-bit openSUSE-11.1 with the original (not updated) 2.6.27.9 kernel running with 1.0.17/1.0.18 of alsa on a Gateway ML6230 with a stac9250 hardware audio codec.

    Searching for the stac9250 on our forum, I also note another Gateway user had a sound problem which they solved: No Sound in OpenSUSE 11.1 - openSUSE Forums

    Searching on the alsa web site for the stac9250 I note an update in 1.0.19 of alsa: Search results for stac9250 - AlsaProject

    and when I compare the predefined alsa models available from 1.0.17/1.0.18 of alsa (for the stac9250) from the alsa-configuration.txt file to 1.0.18 of alsa:
    Code:
    	STAC9202/9250/9251
    	  ref		Reference board, base config
    	  m2-2		Some Gateway MX series laptops
    	  m6		Some Gateway NX series laptops
    	  pa6		Gateway NX860 series
    to that from the HD-Audio-Models.txt file for 1.0.21 of alsa:
    Code:
    STAC9202/9250/9251
    ==================
      ref		Reference board, base config
      m1		Some Gateway MX series laptops (NX560XL)
      m1-2		Some Gateway MX series laptops (MX6453)
      m2		Some Gateway MX series laptops (M255)
      m2-2		Some Gateway MX series laptops
      m3		Some Gateway MX series laptops
      m5		Some Gateway MX series laptops (MP6954)
      m6		Some Gateway NX series laptops
      auto		BIOS setup (default)
    its clear there have been some updates to how the stac9250 is handled since 1.0.17/1.0.18 of alsa.

    Still, before attempting an update of alsa to 1.0.21, it is likely useful to try get it work now by forcing one of the 1.0.17/1.0.18 options upon alsa start, in case the alsa autoprobe upon starting did not properly configure your alsa sound driver.

    Now the general advice I give in this thread is all documented in generic details in the openSUSE audio troubleshooting guide: SDB:AudioTroubleshooting - openSUSE .

    When testing your sound, please do NOT use the startup system sound as your criteria for stating sound does not work. Also be certain to check your mixer. Its not uncommon for a mixer setting (master, pcm or speaker) to be muted upon boot. In KDE your mixer is "kmix" (the small speaker in right hand corner). In Gnome your mixer is "alsamixer".

    Note, when testing if you have sound, please copy and paste the following speaker-test into a Gnome terminal or a kde konsole:

    speaker-test -Dplug:front -c2 -l5 -twav

    Note Linux is case sensitive, and D is not the same as d. To stop the above test, while the konsole/xterm has the mouse focus, press <CTRL><C> on the keyboard. Note you should check your mixer settings (kmix if using KDE, and alsamixer if using Gnome) to ensure that PCM and Master Volume are set around 95%. Once you have basic sound established you can back off to lower volume levels. Note the test for surround sound is different.

    If that test yields errors (and its not uncommon to get errors there), try instead this more simple test:
    speaker-test -c2 -l5 -twav
    You should hear a female voice saying 'FRONT LEFT', 'FRONT RIGHT' five times. Its quite common that one of those speaker tests will work and one will NOT work, so don't be distressed if that is the case. IF that test gives sound, stop now, post that the sound test gives sound, and we will look at other possible causes for your applications not giving you the sound you want (such as missing codecs, using the wrong packaged version ... etc ... ).

    Or alternatively, for testing the simple playback, use aplay program. Prepare a WAV file and simply run like:
    Code:
    aplay -vv somefile.wav
    With the option -vv, aplay shows the verbose information of the PCM device, and a VU-peak meter during playing the file.

    Try those speaker-tests as both a regular user, and also with root permissions. If you have a headset, try with your headset plugged in, and also with your headset not plugged in (for speakers).

    Quote Originally Posted by puffa View Post
    ray@linux-7qpj:~> cat /etc/modprobe.d/sound
    Code:
    options snd slots=snd-hda-intel
    # u1Nb.sBxdZWtb8gD:82801G (ICH7 Family) High Definition Audio Controller
    alias snd-card-0 snd-hda-intel
    ray@linux-7qpj:~>
    So assuming you have no sound with any of those tests (and if you had sound in anyone one, STOP now and advise) then please make a change to your PC's /etc/modprobe.d/sound file by adding a line at the start of that file. In essence, the idea is to try forcing each of the model options from the ALSA-Configuration.txt file, one at a time, in case one of them works: ie : ref, m2-2, m6, pa6 .

    You can make such a change
    • in gnome by typing: gnomesu gedit /etc/modprobe.d/sound #enter root password when prompted and make the edit
    • in kde by typing: kdesu 'kwrite /etc/modprobe.d/sound' #enter root password when prompted and make the edit

    and assuming you start with m2-2, then the edit consists of adding the line "options snd-hda-intel model=m2-2" such that the file now looks like:
    Code:
    options snd-hda-intel model=m2-2
    options snd slots=snd-hda-intel
    # u1Nb.sBxdZWtb8gD:82801G (ICH7 Family) High Definition Audio Controller
    alias snd-card-0 snd-hda-intel
    then save that, and restart your alsa sound driver with the command su -c 'rcalsasound restart' and enter root password when prompted, restart your mixer (kmix in kde and alsamixer in gnome0 and test your sound.

    If m2-2 does not work, then replace it with the next item in the list which is m6 such that file looks like:
    Code:
    options snd-hda-intel model=m6
    options snd slots=snd-hda-intel
    # u1Nb.sBxdZWtb8gD:82801G (ICH7 Family) High Definition Audio Controller
    alias snd-card-0 snd-hda-intel
    save, restart alsa sound driver with the command su -c 'rcalsasound restart' and enter root password when prompted, restart your mixer (kmix in kde and alsamixer in gnome0 and test your sound.

    Do that for m2-2, m6, pa6 and ref.

    If none of those 4 work, then advise, and we can try an alsa update.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •