Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Sound Blaster X-Fi Elite Pro and Yast

  1. #1
    Join Date
    Jun 2008
    Location
    netherlands
    Posts
    671

    Default Sound Blaster X-Fi Elite Pro and Yast

    I have a computer a Sound Blaster X-Fi Elite Pro
    sound card.(pci card and break out box)
    I have installed the CreativeXFi-kmp-pae driver
    found on opensuse search for opensuse 11.1 32 bits.
    Sound is working perfect but I can not see any soundcard under Yast hardware -sound device.
    I want to use the midi port but it is not working
    also the volume knob is not working.
    Doe anyone know how to solve this.

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Sound Blaster X-Fi Elite Pro and Yast

    Functional support for Sound Blaster X-Fi is relatively new under alsa in Linux, and I believe efforts are still being made to improve the driver.

    If you obtain no answers/satisfaction from this thread, you could raise a bug report on openSUSE use of the driver as I suspect the alsa driver developers are looking for feedback on the driver use with X-Fi. There is guidance here for raising bug reports on openSUSE: Submitting Bug Reports - openSUSE
    Please be raise the bug report against component "sound".

  3. #3
    Join Date
    Jun 2008
    Location
    netherlands
    Posts
    671

    Default Re: Sound Blaster X-Fi Elite Pro and Yast

    I do not know if it is a bug maybe there is no support for the break out box but only for the PCI sound card.
    Or it should be a bug that there is no sound device showing under Yast. I am just wondering.

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Sound Blaster X-Fi Elite Pro and Yast

    Quote Originally Posted by anton View Post
    I do not know if it is a bug maybe there is no support for the break out box but only for the PCI sound card.
    Or it should be a bug that there is no sound device showing under Yast. I am just wondering.
    First, I want to repeat, only if you obtain no answers/satisfaction from this thread, you should raise a bug report on openSUSE use of the driver.

    As to WHAT you raise it on, is up to you. BUT I note this:

    Quote Originally Posted by anton View Post
    ... but I can not see any soundcard under Yast hardware -sound device.
    I want to use the midi port but it is not working
    also the volume knob is not working.
    Doe anyone know how to solve this.
    I highlighed in 3 colours items you could note in your bug report, IF you obtain no insight from the contributions of others in this thread.

  5. #5
    Join Date
    Jun 2008
    Location
    netherlands
    Posts
    671

    Default Re: Sound Blaster X-Fi Elite Pro and Yast

    Well I did post the bug nr : 546440
    https://bugzilla.novell.com/show_bug.cgi?id=546440
    No Midi support is possible.
    Better look for another sound recording card for Linux.

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Sound Blaster X-Fi Elite Pro and Yast

    Quote Originally Posted by anton View Post
    Well I did post the bug nr : 546440
    https://bugzilla.novell.com/show_bug.cgi?id=546440
    No Midi support is possible.
    Better look for another sound recording card for Linux.
    Wow! That was a fast response. Those replying are THE guru's , ... its kind of neat to watch them post back and forth. Keep an eye on the thread, as they may ask you to run something to come up with the PCI ID ?

  7. #7
    Join Date
    Jun 2008
    Location
    netherlands
    Posts
    671

    Default Re: Sound Blaster X-Fi Elite Pro and Yast

    Yes but I am not very happy with the answer :
    MIDI isn't supported, too, due to lack of information from Creative.
    It is for a friend who wanted to switch from windows to Linux
    I think he is gonna stay by windows now. no thanks to creative

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Sound Blaster X-Fi Elite Pro and Yast

    Quote Originally Posted by anton View Post
    Yes but I am not very happy with the answer :
    MIDI isn't supported, too, due to lack of information from Creative.
    It is for a friend who wanted to switch from windows to Linux
    I think he is gonna stay by windows now. no thanks to creative
    Support for the X-Fi is very recent. Enormous strides have been made the past year. But for a person with only one PC, who wants Linux, I would recommend buy an interim audio card to use, until full X-Fi support is available. ... or stick with an OS where there is X-Fi support.

  9. #9
    Join Date
    Jun 2008
    Location
    netherlands
    Posts
    671

    Default Re: Sound Blaster X-Fi Elite Pro and Yast

    Yes it is for one person and I have recommended M-audio delta interface. But I do not think he is the only one with X-Fi.
    It was not a cheap X-Fi sound blaster card. Normally it is better to look for the right hardware supported by Linux before you buy it.
    .

  10. #10

    Default Re: Sound Blaster X-Fi Elite Pro and Yast

    Well i have this sound card and at least in openSUSE 11.2 automatically recognized and configured, but as you say there is no device in yast. At least it sound, but hope that Creative give us a new driver with full external module support (soon.... please xD ). About midi i didn't test, i think that there is no support for SoundFont yet.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •