Results 1 to 9 of 9

Thread: libplasma.so.2 cannot be provided

  1. #1
    Join Date
    Jun 2009
    Location
    Mt Vernon Ohio
    Posts
    227

    Default libplasma.so.2 cannot be provided

    Hello I just upgraded from kde 4.1 to 4.2 and everything is well except that when I go to install powerdevil I get the message in the Title. I've looked around for a suitable answer and the package but have yet to find one. So any ideas? Thanks

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: libplasma.so.2 cannot be provided

    Powerdevil does not need to be installed. That is an old 4.1.3 package. Powerdevil is now part of the kde4 base packages.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Jun 2009
    Location
    Mt Vernon Ohio
    Posts
    227

    Default Re: libplasma.so.2 cannot be provided

    ah well I ask because with out that package installed my notifications wont work...and even with it installed I'm not able to "click this message to block the suspend to ram process" so any ideas?

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: libplasma.so.2 cannot be provided

    Please post result of:
    Code:
    zypper lr -d
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5
    Join Date
    Jun 2009
    Location
    Mt Vernon Ohio
    Posts
    227

    Default Re: libplasma.so.2 cannot be provided

    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    ---+------------------------------+---------------------------------------+---------+---------+----------+--------+---------------------------------------------------------------------------------------+--------
    1 | 11.1 - Main Repository (OSS) | 11.1 - Main Repository (OSS) | Yes | Yes | 99 | yast2 | Index of /distribution/11.1/repo/oss |
    2 | 11.1 - VideoLan | 11.1 - VideoLan | Yes | Yes | 99 | rpm-md | Index of /pub/videolan/vlc/SuSE/11.1/ |
    3 | KDE4.2 | KDE4.2 | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/42/openSUSE_11.1 |
    4 | KDE:42 | KDE:42 | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/42/openSUSE_11.1 |
    5 | Virtualization:Appliances | Virtualization:Appliances | Yes | Yes | 99 | rpm-md | Index of /repositories/Virtualization:/Appliances/openSUSE_11.1 |
    6 | X11:Compiz | X11:Compiz | Yes | Yes | 99 | rpm-md | Index of /repositories/X11:/Compiz/openSUSE_11.1 |
    7 | devel:languageserl | devel:languageserl | Yes | Yes | 99 | rpm-md | Index of /repositories/devel:/languages:/perl/openSUSE_11.1 |
    8 | devel:tools:building | devel:tools:building | Yes | Yes | 99 | rpm-md | Index of /repositories/devel:/tools:/building/openSUSE_11.1 |
    9 | home:Akoellh | home:Akoellh | No | Yes | 99 | rpm-md | Index of /repositories/home:/Akoellh/openSUSE_11.1_Update |
    10 | home:BenderBendingRodriguez | home:BenderBendingRodriguez | No | Yes | 99 | rpm-md | Index of /repositories/home:/BenderBendingRodriguez/openSUSE_11.1 |
    11 | home:alazzurra | home:alazzurra | No | Yes | 99 | rpm-md | Index of /repositories/home:/alazzurra/openSUSE_11.1 |
    12 | home:cyberorg:livextra | home:cyberorg:livextra | No | Yes | 99 | rpm-md | Index of /repositories/home:/cyberorg:/livextra/openSUSE_11.1 |
    13 | home:dstoecker | home:dstoecker | No | Yes | 99 | rpm-md | Index of /repositories/home:/dstoecker/openSUSE_11.1 |
    14 | home:leo_eraly | home:leo_eraly | No | Yes | 99 | rpm-md | Index of /repositories/home:/leo_eraly/openSUSE_11.1 |
    15 | homebleser:Security | homebleser:Security | Yes | Yes | 99 | rpm-md | Index of /repositories/home:/pbleser:/Security/openSUSE_11.1 |
    16 | home:uljanow | home:uljanow | No | Yes | 99 | rpm-md | Index of /repositories/home:/uljanow/openSUSE_11.1 |
    17 | kde42 | kde42 | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/42/openSUSE_11.1 |
    18 | openSUSE 11.1-0 | openSUSE 11.1-0 | No | No | 99 | yast2 | cd:///?devices=/dev/sr0 |
    19 | openSUSE-11.1-Updates | openSUSE-11.1-Updates | Yes | Yes | 99 | rpm-md | Index of /update/11.1 |
    20 | openSUSE:11.1:Update | openSUSE:11.1:Update | Yes | Yes | 99 | rpm-md | Index of /update/11.1 |
    21 | repo | Main Repository (NON-OSS) | Yes | Yes | 99 | yast2 | Index of /distribution/11.1/repo/non-oss |
    22 | repo_1 | Main Repository (OSS) | Yes | Yes | 99 | yast2 | Index of /distribution/11.1/repo/oss |
    23 | repo_2 | openSUSE BuildService - Mozilla | No | Yes | 99 | rpm-md | Index of /repositories/mozilla/openSUSE_11.1 |
    24 | repo_3 | Packman Repository | Yes | Yes | 99 | rpm-md | Index of /pub/packman/suse/11.1 |
    25 | repo_4 | openSUSE BuildService - KDE:Community | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/Community/openSUSE_11.1 |
    26 | repo_5 | Main Update Repository | Yes | Yes | 99 | rpm-md | Index of /update/11.1 |
    27 | repo_6 | openSUSE BuildService - Mozilla | No | Yes | 99 | rpm-md | Index of /repositories/mozilla/openSUSE_11.1 |
    28 | repo_7 | openSUSE BuildService - KDE:Backports | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/Backports/openSUSE_11.1 |
    29 | security | security | Yes | Yes | 99 | rpm-md | Index of /repositories/security/openSUSE_11.1 |
    30 | server:ltsp | server:ltsp | Yes | Yes | 99 | rpm-md | Index of /repositories/server:/ltsp/openSUSE_11.1

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: libplasma.so.2 cannot be provided

    One too many repo's even though they are not all enabled.

    I would try creating a new user and see if it behaves the same. Report back.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7
    Join Date
    Jun 2009
    Location
    Mt Vernon Ohio
    Posts
    227

    Default Re: libplasma.so.2 cannot be provided

    sorry it took so long to post...I did just what you said and got the same results. (though I now have a close button in the notification window though closing it doesn't stop the process) Also why exactly is having a bunch of repos,enabled or not,a problem?

  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: libplasma.so.2 cannot be provided

    Just take it from someone who has at least a modicum of experience - 4 or 5 would be plenty.
    oss
    non-oss
    update
    packman
    (nvidia/ati?)

    NEW Users - Suse-11.1 Pre-installation PLEASE READ - openSUSE Forums

    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  9. #9
    Join Date
    Jun 2009
    Location
    Mt Vernon Ohio
    Posts
    227

    Default Re: libplasma.so.2 cannot be provided

    oh I'm not questioning your knowledge on the subject I'm just curious as to why it would cause problems,but anyway thanks for the advice.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •