Page 1 of 3 123 LastLast
Results 1 to 10 of 29

Thread: Xserver crashes on booting

  1. #1

    Default Xserver crashes on booting

    I have installed opensuse 11.1 on my new MD96852-noteboook (Medion). Installation without problems.
    Linux gm2009 2.6.27.29-0.1-pae #1 SMP 2009-08-15 17:53:59 +0200 i686 i686 i386 GNU/Linux
    Opensuse 11.1
    8280 1H (ICH8 family) HD Audio Controller
    GeForce 8600M GS

    On booting the system comes up "statistically", i.e. about 20% work, 80% produce a blank screen.
    The Xserver crashes right at the beginning. The splash screen doesn't come up.
    However, the system is obviously running as I can login via the LAN from another computer.
    I cannot see any helpful diagnostics. At the end of Xorg.0.log it just states:
    (EE) No devices detected.
    Fatal server error:
    no screens found

    Of course, these messages are missing in the file when it boots properly while the messages preceding are identical.
    boot.msg also doesn't help me. I can't see anything wrong or missing in xorg.conf.
    I suspect some timing is wrong in the start sequence. What can I do?

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Xserver crashes on booting

    You could switch to vesa to get you a reliable UI login and then we can look at installing nvidia drivers. To switch to Vesa follow this:

    Pause the boot by moving the down arrow, then back up to the default boot. But now press backspace, it should delete any text where you can see: vga=0x...
    Remove all text and now type just the number:
    3
    and hit enter
    at the login type your user name and then password
    now type:
    su
    then the root password
    now type this:
    sax2 -r -m 0=vesa
    (N.B. the 0 is a zero not a letter)
    now reboot: type: reboot
    if you don't get a gui login
    login as user at cli and try this at the cli
    startx
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Xserver crashes on booting

    No change with this variant. I don't think it's a driver problem. When I tried to start the Xserver remotely I got again the message "no screen found".

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Xserver crashes on booting

    Please post your /etc/X11/xorg.conf
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: Xserver crashes on booting

    # /.../
    # SaX generated X11 config file
    # Created on: 2009-10-13T18:08:53+1100.
    #
    # Version: 8.1
    # Contact: Marcus Schaefer <sax@suse.de>, 2005
    # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
    #
    # Automatically generated by [ISaX] (8.1)
    # PLEASE DO NOT EDIT THIS FILE!
    #

    Section "Files"
    FontPath "/usr/share/fonts/misc:unscaled"
    FontPath "/usr/share/fonts/local"
    FontPath "/usr/share/fonts/75dpi:unscaled"
    FontPath "/usr/share/fonts/100dpi:unscaled"
    FontPath "/usr/share/fonts/Type1"
    FontPath "/usr/share/fonts/URW"
    FontPath "/usr/share/fonts/Speedo"
    FontPath "/usr/share/fonts/PEX"
    FontPath "/usr/share/fonts/cyrillic"
    FontPath "/usr/share/fonts/latin2/misc:unscaled"
    FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/Type1"
    FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
    FontPath "/usr/share/fonts/baekmuk:unscaled"
    FontPath "/usr/share/fonts/japanese:unscaled"
    FontPath "/usr/share/fonts/kwintv"
    FontPath "/usr/share/fonts/truetype"
    FontPath "/usr/share/fonts/uni:unscaled"
    FontPath "/usr/share/fonts/CID"
    FontPath "/usr/share/fonts/ucs/misc:unscaled"
    FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
    FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/misc:unscaled"
    FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/Type1"
    FontPath "/usr/share/fonts/misc/sgi:unscaled"
    FontPath "/usr/share/fonts/xtest"
    FontPath "/opt/kde3/share/fonts"
    InputDevices "/dev/gpmdata"
    InputDevices "/dev/input/mice"
    EndSection

    Section "ServerFlags"
    Option "AllowMouseOpenFail" "on"
    Option "ZapWarning" "on"
    EndSection

    Section "Module"
    Load "extmod"
    Load "dbe"
    Load "glx"
    Load "freetype"
    Load "dri"
    EndSection

    Section "InputDevice"
    Driver "kbd"
    Identifier "Keyboard[0]"
    Option "Protocol" "Standard"
    Option "XkbLayout" "us"
    Option "XkbModel" "microsoftpro"
    Option "XkbRules" "xfree86"
    EndSection


    Section "InputDevice"
    Driver "mouse"
    Identifier "Mouse[1]"
    Option "Buttons" "7"
    Option "Device" "/dev/input/mice"
    Option "Name" "Chic Browser Mouse"
    Option "Protocol" "explorerps/2"
    Option "Vendor" "Sysp"
    Option "ZAxisMapping" "4 5"
    EndSection

    Section "InputDevice"
    Driver "synaptics"
    Identifier "Mouse[3]"
    Option "Buttons" "5"
    Option "Device" "/dev/input/mice"
    Option "Emulate3Buttons" "on"
    Option "HorizScrollDelta" "0"
    Option "InputFashion" "Mouse"
    Option "Name" "Synaptics;Touchpad"
    Option "Protocol" "explorerps/2"
    Option "SHMConfig" "on"
    Option "Vendor" "Sysp"
    Option "ZAxisMapping" "4 5"
    EndSection


    Section "Monitor"
    Option "CalcAlgorithm" "XServerPool"
    DisplaySize 305 230
    HorizSync 30-52
    Identifier "Monitor[0]"
    ModelName "1280X800@60HZ"
    Option "DPMS"
    Option "PreferredMode" "1280x800"
    VendorName "--> LCD"
    VertRefresh 50-60
    UseModes "Modes[0]"
    EndSection


    Section "Modes"
    Identifier "Modes[0]"
    EndSection


    Section "Screen"
    DefaultDepth 24
    SubSection "Display"
    Depth 15
    Modes "1280x800" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "1280x800" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1280x800" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "1280x800" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    Device "Device[0]"
    Identifier "Screen[0]"
    Monitor "Monitor[0]"
    EndSection


    Section "Device"
    BoardName "GeForce 8600M GS"
    Driver "nv"
    Identifier "Device[0]"
    Screen 0
    VendorName "NVidia"
    EndSection



    Section "ServerLayout"
    Identifier "Layout[all]"
    InputDevice "Keyboard[0]" "CoreKeyboard"
    InputDevice "Mouse[1]" "CorePointer"
    InputDevice "Mouse[3]" "SendCoreEvents"
    Option "Clone" "off"
    Option "Xinerama" "off"
    Screen "Screen[0]"
    EndSection


    Section "DRI"
    Group "video"
    Mode 0660
    EndSection

    Section "Extensions"
    Option "Composite" "off"
    EndSection

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Xserver crashes on booting

    So you are saying - sometimes you get a working desktop, but mostly it crashes?

    You have the nvidia driver installed by the looks of that xorg stuff.

    Please try booting with the Failsafe option.
    or
    Use the default boot, but type this in the boot arguments:
    acpi=off noapic

    Report back
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: Xserver crashes on booting

    He probably installed the driver before updating. If so, it has not been configured to be used by the X-server ('nv' driver is selected).
    Follow this, and you should be OK:

    Pre-NVIDIA install:
    Open Software Installer, choose PATTERN view.
    Check “Linux Kernel Development”
    Click Accept

    NVIDIA install (when reinstall, start at “++actual install” stop at “++Configure X...”)

    Open a terminal window and do:

    ++ prepare some things

    mkdir NVIDIA

    cd NVIDIA

    ++ a folder NVIDIA is created in /home/YOURUSERNAME and entered

    ++ now on a 32bit system do:

    wget ftp://download.nvidia.com/XFree86/Li...90.36-pkg1.run

    ++ on a 64bit system do:

    wget ftp://download.nvidia.com/XFree86/Li...90.36-pkg2.run

    ++ this downloads the driver from the NVIDIA site, into current folder

    ++ actual install

    ++ now on 32bit do:
    su -c 'sh NVIDIA-Linux-x86-190.36-pkg1.run -q'

    ++ on 64bit do:
    su -c 'sh NVIDIA-Linux-x86_64-190.36-pkg2.run -q'

    ++ Enter rootpassword when asked for. The installer will start, Accept the license, hit OK when asked for, until finished.

    ++ Configure X-server to use the driver :

    su -c 'sax2 -r -m0=nvidia'

    ++ Enter rootpassword. MIND: after the -m is a ZERO. Click Change Configuration, check values for videocard and monitor resolition. Save and exit.

    ++ Driver is now installed and configured. On next kernel update there's no need for the sax2 command, since Xorg is already configured to use the nvidia driver.

    ++ Now we need to change to runlevel 5 to get your gui back:

    su -c 'init 5 && exit'

    ++ Enter rootpassword and you should be presented with the kdm login screen.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  8. #8

    Default Re: Xserver crashes on booting

    The system boots regularly in 1 out of 5 cases on average. I still think the driver is not the problem. Nevertheless, I followed knurpht's instructions and reinstalled the nvidia-driver. The result is just the same, except that now I can't even choose my screen resolution anymore. Instead of 1280x800 I only get 1024x768 although the former is certainly the displayed parameter.
    So my original problem remains:how can I track the problem with the crashing xserver. The message 'No screen detected' indicates that the hardware recognition is not fast enough for the start of the xserver. Besides I find the popping up NVIDIA screen a nuisance.

  9. #9
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: Xserver crashes on booting

    Looks like you have remains of previous NVIDIA drivers on your system. Uninstall any NVIDIA packages from Yast, reinstall the driver, redo 'sax2 -r -m0=nvidia', change configuration, from the options of the card, tick NoLogo, that removes the NVIDIA logo from X startup.

    And...please post your current /etc/X11/xorg.conf
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  10. #10

    Default Re: Xserver crashes on booting

    There are lots of difficulties with nvidia and sax (I have wasted days on that) - but they can be made to work.

    see for example installed but sax2 wont change - openSUSE Forums
    http://en.opensuse.org/NVIDIA
    Last edited by cheongi; 20-Oct-2009 at 06:17. Reason: added
    HP ML110G5 E8400 2GB
    openSUSE 11.1, 11.2RC2 x86_64
    eVGA 8400GS PCI

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •