Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Failure to load grub

  1. #1

    Default Failure to load grub

    I was using vista and suse 11.1 on my dell inspiron but then windows didnt start and i had to repair it now whenever i start my pc it gets struck in grub how could i correct it?

  2. #2
    Join Date
    Jun 2008
    Location
    Ardrishaig, Argyll. Scotland UK - GMT/BST
    Posts
    36,874
    Blog Entries
    20

    Default Re: Failure to load grub

    Repair grub. There are various ways. A live linux CD or a Parted Magic CD. Or the SUSE install DVD.

    If you have a Linux Live CD, boot from it and log in. Then open a console window and enter su and you will be at the command prompt with root powers and ready to proceed. If on the other hand you have the openSUSE install DVD, boot from it and on the first menu of options select the Rescue System option. That will start an elementary Linux Live operating system and bring you to the login prompt. Enter the username root and you will be at the command prompt with root powers and ready to proceed. Whichever way you started (the openSUSE install DVD or a Linux Live CD) when you are at the root command prompt, first you find the partition containing openSUSE's bootloader. Then you reinstall Grub with a pointer to that partition. First find the openSUSE installation:
    You enter this ---------------- grub
    Computer returns like this ---- grub>
    You enter this ---------------- find /boot/grub/menu.lst
    Computer returns like this ---- (hd0,5)
    Here, (hd0,5) is Grub's pointer to my openSUSE installation. Your pointer will be different from my example (hd0,5). Substitute your values for my example (hd0,5). Now that you have the pointer, proceed like this:
    You enter this ---------------- root (hd0,5)
    Computer returns like this ---- Filesystem type is ext2fs, partition type 0x83
    You enter this ---------------- setup (hd0)
    You see several lines like this --- Checking if /boot/grub/stage1 exists ... yes Computer finally returns this-- Succeeded.......Done
    You enter this ---------------- quit
    You enter this ---------------- reboot
    HowTo Boot into openSUSE when it won't Boot from the Grub Code on the Hard Drive
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Failure to load grub

    i did every step
    now on rebooting the system from hard-disk it is again going to grub menu
    can the graphic grub be installed again?

  4. #4
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: Failure to load grub

    Quote Originally Posted by wormulove View Post
    i did every step
    now on rebooting the system from hard-disk it is again going to grub menu
    can the graphic grub be installed again?
    I suggest you use the tutorial linked by caf4926 to boot into openSUSE. When you get into openSUSE, first do the online updates (Yast Software module) and then use the method in the appendix to make a new Grub boot menu and to place new Grub code in the Master Boot Record.

    After that, if there are further problems with vista, do not repair vista. Instead repair the entry for booting vista in Grubs menu.lst file as discussed here: Fixing vista multiboot with openSUSE - openSUSE Forums
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  5. #5

    Default Re: Failure to load grub

    i am not able to boot any of the os from hdd
    i ve live cd from which i ve made the earlier changes as told by caf but now also the on booting from hdd "grub>" is shown and no other
    option.
    kdesu kwrite /boot/grub/menu.lst
    (from live cd) gives
    kdesu: can not connect to x server

  6. #6
    Join Date
    Jun 2008
    Location
    Ardrishaig, Argyll. Scotland UK - GMT/BST
    Posts
    36,874
    Blog Entries
    20

    Default Re: Failure to load grub

    Wha do you get at this point :
    Code:
    find /boot/grub/menu.lst
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7

    Default Re: Failure to load grub

    co-incidently
    all results are same as provided by u on 2nd link

  8. #8
    Join Date
    Jun 2008
    Location
    Ardrishaig, Argyll. Scotland UK - GMT/BST
    Posts
    36,874
    Blog Entries
    20

    Default Re: Failure to load grub

    Quote Originally Posted by wormulove View Post
    co-incidently
    all results are same as provided by u on 2nd link
    That seems a remarkable coincidence - so you mean you get this: (hd0,5)?
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  9. #9

    Default Re: Failure to load grub

    yes
    and also all other values r same

  10. #10
    Join Date
    Jun 2008
    Location
    Ardrishaig, Argyll. Scotland UK - GMT/BST
    Posts
    36,874
    Blog Entries
    20

    Default Re: Failure to load grub

    And this:
    You see several lines like this --- Checking if /boot/grub/stage1 exists ... yes Computer finally returns this-- Succeeded.......Done ?

    How about an
    Code:
    fdisk -l
    output so we can see your partitions
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •