Results 1 to 10 of 10

Thread: 11.2 M8 issues upgrading to KDE 4.3.2

  1. #1

    Exclamation 11.2 M8 issues upgrading to KDE 4.3.2

    I've seen a few threads where people have updated to 4.3.2 successfully, but I'm having a few problems.
    I recently switched to Suse and package management has me a little bit confused. So it may be that I don't have a necessary repo or the prioritization is screwed up or something.
    Basically what's happening for me is when I try to upgrade throught YAST, it's giving me the window with all of the conflicts and suggested resolutions. There are a ton of conflicts.

    Could someone tell me what a fresh install of M8 should be using for repos please? I'd like to get the desktop up to the latest available KDE version.

  2. #2

    Default Re: 11.2 M8 issues upgrading to KDE 4.3.2

    Here's my ridiculous conflicts list:

    #### YaST2 conflicts list - generated 2009-10-12 14:11:28 ####

    nothing provides libmysqlclient.so.15()(64bit) needed by amarok-2.2.0-8.1.x86_64

    [ ] do not install amarok-2.2.0-8.1.x86_64

    [ ] break amarok by ignoring some of its dependencies



    nothing provides libgnokii.so.3()(64bit) needed by kaddressbook-4.3.2-6.1.x86_64

    [ ] do not install kaddressbook-4.3.2-6.1.x86_64

    [ ] break kaddressbook by ignoring some of its dependencies



    nothing provides libexiv2.so.4()(64bit) needed by gwenview-4.3.2-4.2.x86_64

    [ ] do not install gwenview-4.3.2-4.2.x86_64

    [ ] break gwenview by ignoring some of its dependencies



    nothing provides libxklavier.so.12()(64bit) needed by kdebase4-workspace-4.3.2-6.1.x86_64

    [ ] do not install kdebase4-workspace-4.3.2-6.1.x86_64

    [ ] break kdebase4-workspace by ignoring some of its dependencies



    nothing provides libsgutils.so.1()(64bit) needed by libgpod-tools-0.7.2-2.1.x86_64

    [ ] do not install libgpod-tools-0.7.2-2.1.x86_64

    [ ] break libgpod-tools by ignoring some of its dependencies



    nothing provides libexiv2.so.4()(64bit) needed by strigi-0.7.0-2.2.x86_64

    [ ] do not install strigi-0.7.0-2.2.x86_64

    [ ] break strigi by ignoring some of its dependencies



    nothing provides libexiv2.so.4()(64bit) needed by libkexiv2-7-4.3.2-4.2.x86_64

    [ ] do not install libkexiv2-7-4.3.2-4.2.x86_64

    [ ] break libkexiv2-7 by ignoring some of its dependencies



    nothing provides libpoppler.so.4()(64bit) needed by okular-4.3.2-4.2.x86_64

    [ ] do not install okular-4.3.2-4.2.x86_64

    [ ] break okular by ignoring some of its dependencies



    nothing provides libxklavier.so.12()(64bit) needed by kdebase4-workspace-4.3.2-6.1.x86_64

    [ ] do not install kdebase4-session-4.3.2-7.1.x86_64

    [ ] break kdebase4-workspace by ignoring some of its dependencies



    kdm-4.3.2-6.1.x86_64 requires kdm-branding = 11.1, but this requirement cannot be provided
    uninstallable providers: kdm-branding-respin-11.1.1-67.3.x86_64[KDE_4.3.2]
    kdm-branding-openSUSE-11.1.2-67.3.x86_64[KDE_4.3.2]
    kdm-branding-upstream-4.3.2-6.1.x86_64[KDE_4.3.2]
    kdm-branding-respin-11.1.1-67.3.i586[KDE_4.3.2]
    kdm-branding-openSUSE-11.1.2-67.3.i586[KDE_4.3.2]
    kdm-branding-upstream-4.3.2-6.1.i586[KDE_4.3.2]
    kdm-branding-respin-11.1.1-73.6.x86_64[kde4_OpenSuse_Factory]
    kdm-branding-upstream-4.3.1-346.2.x86_64[kde4_OpenSuse_Factory]
    kdm-branding-openSUSE-11.1.2-78.7.x86_64[kde4_OpenSuse_Factory]
    kdm-branding-upstream-4.3.1-346.2.i586[kde4_OpenSuse_Factory]
    kdm-branding-openSUSE-11.1.2-78.7.i586[kde4_OpenSuse_Factory]
    kdm-branding-respin-11.1.1-73.6.i586[kde4_OpenSuse_Factory]
    [ ] do not install kdm-4.3.2-6.1.x86_64

    [ ] break kdm by ignoring some of its dependencies



    kwin-4.3.2-6.1.x86_64 requires kdebase4-workspace-branding = 11.1, but this requirement cannot be provided
    uninstallable providers: kdebase4-workspace-branding-openSUSE-11.1.2-67.3.x86_64[KDE_4.3.2]
    kdebase4-workspace-branding-respin-11.1.1-67.3.x86_64[KDE_4.3.2]
    kdebase4-workspace-branding-upstream-4.3.2-6.1.x86_64[KDE_4.3.2]
    kdebase4-workspace-branding-openSUSE-11.1.2-67.3.i586[KDE_4.3.2]
    kdebase4-workspace-branding-respin-11.1.1-67.3.i586[KDE_4.3.2]
    kdebase4-workspace-branding-upstream-4.3.2-6.1.i586[KDE_4.3.2]
    kdebase4-workspace-branding-upstream-4.3.1-346.2.x86_64[kde4_OpenSuse_Factory]
    kdebase4-workspace-branding-openSUSE-11.1.2-78.7.x86_64[kde4_OpenSuse_Factory]
    kdebase4-workspace-branding-respin-11.1.1-73.6.x86_64[kde4_OpenSuse_Factory]
    kdebase4-workspace-branding-openSUSE-11.1.2-78.7.i586[kde4_OpenSuse_Factory]
    kdebase4-workspace-branding-respin-11.1.1-73.6.i586[kde4_OpenSuse_Factory]
    kdebase4-workspace-branding-upstream-4.3.1-346.2.i586[kde4_OpenSuse_Factory]
    [ ] do not install kwin-4.3.2-6.1.x86_64

    [ ] break kwin by ignoring some of its dependencies



    nothing provides libxklavier.so.12()(64bit) needed by kdebase4-workspace-4.3.2-6.1.x86_64

    [ ] Following actions will be done:
    deinstallation of kdebase4-openSUSE-11.2-27.2.x86_64
    deinstallation of patterns-openSUSE-kde4_basis-11.2-18.31.x86_64
    do not install kdeartwork4-screensaver-4.3.2-4.1.x86_64
    do not install kdebase4-4.3.2-5.2.x86_64
    do not install kget-4.3.2-5.2.x86_64
    deinstallation of kget-4.3.1-3.2.x86_64
    do not install plasma-addons-4.3.2-7.1.x86_64
    deinstallation of kupdateapplet-packagekit-0.9.2-1.1.x86_64
    deinstallation of patterns-openSUSE-kde4-11.2-18.31.x86_64
    deinstallation of patterns-openSUSE-kde4_imaging-11.2-18.31.x86_64
    do not install kdebase4-nsplugin-4.3.2-5.2.x86_64
    deinstallation of compiz-kde4-0.7.8-42.1.x86_64
    deinstallation of plasmoid-quickaccess-0.8.1-3.16.x86_64
    deinstallation of ktorrent-3.2.4-39.2.x86_64
    deinstallation of kdebluetooth4-0.3-25.1.x86_64
    deinstallation of kdebase4-nsplugin-4.3.1-3.7.x86_64
    deinstallation of NetworkManager-kde4-libs-0.9.svn1028043-113.2.x86_64
    deinstallation of NetworkManager-kde4-0.9.svn1028043-113.2.x86_64
    deinstallation of plasma-addons-4.3.1-22.2.x86_64
    deinstallation of kdebase4-4.3.1-119.3.x86_64
    deinstallation of kdeartwork4-screensaver-4.3.1-59.1.x86_64
    deinstallation of NetworkManager-pptp-kde4-0.9.svn1028043-113.2.x86_64
    deinstallation of NetworkManager-vpnc-kde4-0.9.svn1028043-113.2.x86_64
    deinstallation of NetworkManager-openvpn-kde4-0.9.svn1028043-113.2.x86_64
    deinstallation of compiz-branding-openSUSE-0.7.8-42.1.x86_64
    [ ] do not install kde4-kgreeter-plugins-4.3.2-6.1.x86_64

    [ ] break kdebase4-workspace by ignoring some of its dependencies



    nothing provides libxklavier.so.12()(64bit) needed by kdebase4-workspace-4.3.2-6.1.x86_64

    [ ] Following actions will be done:
    deinstallation of kupdateapplet-0.9.2-1.1.x86_64
    deinstallation of patterns-openSUSE-kde4_basis-11.2-18.31.x86_64
    do not install kdeartwork4-screensaver-4.3.2-4.1.x86_64
    do not install kdebase4-4.3.2-5.2.x86_64
    do not install kget-4.3.2-5.2.x86_64
    deinstallation of kget-4.3.1-3.2.x86_64
    do not install plasma-addons-4.3.2-7.1.x86_64
    deinstallation of kupdateapplet-packagekit-0.9.2-1.1.x86_64
    deinstallation of patterns-openSUSE-kde4-11.2-18.31.x86_64
    deinstallation of patterns-openSUSE-kde4_imaging-11.2-18.31.x86_64
    do not install kdebase4-nsplugin-4.3.2-5.2.x86_64
    deinstallation of plasmoid-quickaccess-0.8.1-3.16.x86_64
    deinstallation of ktorrent-3.2.4-39.2.x86_64
    deinstallation of kdebluetooth4-0.3-25.1.x86_64
    deinstallation of kdebase4-nsplugin-4.3.1-3.7.x86_64
    deinstallation of NetworkManager-kde4-libs-0.9.svn1028043-113.2.x86_64
    deinstallation of NetworkManager-kde4-0.9.svn1028043-113.2.x86_64
    deinstallation of plasma-addons-4.3.1-22.2.x86_64
    deinstallation of compiz-kde4-0.7.8-42.1.x86_64
    deinstallation of kdebase4-4.3.1-119.3.x86_64
    deinstallation of kdeartwork4-screensaver-4.3.1-59.1.x86_64
    deinstallation of NetworkManager-pptp-kde4-0.9.svn1028043-113.2.x86_64
    deinstallation of NetworkManager-vpnc-kde4-0.9.svn1028043-113.2.x86_64
    deinstallation of NetworkManager-openvpn-kde4-0.9.svn1028043-113.2.x86_64
    deinstallation of compiz-branding-openSUSE-0.7.8-42.1.x86_64
    [ ] do not install kdebase4-workspace-ksysguardd-4.3.2-6.1.x86_64

    [ ] break kdebase4-workspace by ignoring some of its dependencies



    libtag-extras0-0.1.6-1.4.x86_64 requires taglib-extras = 0.1.6, but this requirement cannot be provided
    uninstallable providers: taglib-extras-0.1.6-7.1.i586[kde4_OpenSuse_Factory]
    [ ] deinstallation of libtag-extras0-0.1.6-1.4.x86_64

    [ ] do not install taglib-extras-1.0.1-3.1.x86_64

    [ ] break libtag-extras0 by ignoring some of its dependencies



    nothing provides libgnokii.so.3()(64bit) needed by kaddressbook-4.3.2-6.1.x86_64

    [ ] Following actions will be done:
    do not install kontact-4.3.2-6.1.x86_64
    deinstallation of kontact-4.3.1-3.7.x86_64
    [ ] break kaddressbook by ignoring some of its dependencies




    #### YaST2 conflicts list END ###

  3. #3
    Join Date
    Feb 2009
    Location
    Baton Rouge, LA, US
    Posts
    152

    Default Re: 11.2 M8 issues upgrading to KDE 4.3.2

    Don't know if this helps or not. The command to list repos is 'zypper lr' the '-v' is for verbose. This is mine currently:

    Code:
    # zypper -vvvvv lr
    Verbosity: 5
    # | Alias                               | Name                                | Enabled | Refresh
    --+-------------------------------------+-------------------------------------+---------+--------
    1 | Factory/repo/non-oss                | Factory/repo/non-oss                | Yes     | Yes
    2 | KDE4:/Community/openSUSE_Factory    | KDE4:/Community/openSUSE_Factory    | Yes     | Yes
    3 | KDE:/43/openSUSE_Factory            | KDE:/43/openSUSE_Factory            | Yes     | Yes
    4 | Mozilla/SUSE_Factory                | Mozilla/SUSE_Factory                | Yes     | Yes
    5 | Packman/suse/factory_1              | Packman/suse/factory                | Yes     | Yes
    6 | _Factory/repo/oss                   | Factory/repo/oss                    | Yes     | Yes
    7 | http-download.opensuse.org-efe0520c | http-download.opensuse.org-efe0520c | No      | No
    8 | openSUSE 11.2-0                     | openSUSE 11.2-0                     | No      | No
    9 | vlc/SuSE/11.2                       | vlc/SuSE/11.2                       | Yes     | Yes
    Unfortunately that command does not list them in priority order or show priority settings. That's an indication that there are more knowledgeable people on this forum regarding this subject.

    The highest priority currently is for Packman set at 90 followed by the KDE and Mozilla ones at 98 Then Factory-OSS and -NONOSS at 99 and finally VLC at 125. I just ran an update with no dependency conflicts though we all get them sometimes especially in a developer version. Before the update sysinfo listed me as 11.2 M-8 x86_64 with KDE 4.3.2 release 5. I doubt todays update would change any of that. I usually at some point in Factory partition will add Open Office repos as they are of much interest to me. Which repos you want are individual to your interests.
    Thanks,
    Dwight Paige

  4. #4
    Join Date
    Jun 2008
    Location
    wichita
    Posts
    990

    Default Re: 11.2 M8 issues upgrading to KDE 4.3.2

    Which repo are you using for KDE 4.3.2? Most of the errors you're getting are because the packages that are installed are newer than the one's the KDE packages are looking for.

    It looks to me like you can ignore all of those conflicts, but I'd still like to know which repos you have enabled.

    Could you post the output of zypper lr.

  5. #5

    Default Re: 11.2 M8 issues upgrading to KDE 4.3.2

    Code:
    Here's my zypper lr output:
    
    
    #  | Alias                               | Name                        | Enabled | Refresh
    ---+-------------------------------------+-----------------------------+---------+--------
    1  | KDE4_community_factory              | KDE4 community factory      | No      | Yes
    2  | KDE:KDE4:Playground                 | KDE:KDE4:Playground         | Yes     | Yes
    3  | KDE_4.3.2                           | KDE 4.3.2                   | Yes     | Yes
    4  | http-download.opensuse.org-69e17a58 | Updates for openSUSE 11.2-0 | No      | No
    5  | kde4_OpenSuse_Factory               | kde4 OpenSuse Factory       | Yes     | Yes
    6  | libdvdcss                           | libdvdcss                   | No      | No
    7  | openSUSE 11.2-0                     | openSUSE 11.2-0             | No      | No
    8  | packman_1                           | packman                     | Yes     | No
    9  | repo-debug                          | openSUSE-11.2-Debug         | No      | No
    10 | repo-non-oss                        | openSUSE-11.2-Non-Oss       | Yes     | No
    11 | repo-oss                            | openSUSE-11.2-Oss           | Yes     | No
    12 | repo-source                         | openSUSE-11.2-Source        | Yes     | No

  6. #6
    Join Date
    Jun 2008
    Location
    wichita
    Posts
    990

    Default Re: 11.2 M8 issues upgrading to KDE 4.3.2

    Disable KDE4:/Playground

    Disable KDE4:/openSUSE_Factory

    Disable 10, 11, 12

    Try the update again.

  7. #7

    Default Re: 11.2 M8 issues upgrading to KDE 4.3.2

    That seems to have done the trick. Thanks!

  8. #8
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: 11.2 M8 issues upgrading to KDE 4.3.2

    AFAICS it has not. It may run, but from the conflicts list, I get that you configured the 11.1 repo for KDE4 4.3.2:
    kdm-4.3.2-6.1.x86_64 requires kdm-branding = 11.1, but this requirement cannot be provided
    .

    In the Factory repo for 4.3.2 you'll see:
    http://download.opensuse.org/reposit...8.2.x86_64.rpm

    I bet that's not the one you installed, since it would never have mentioned dep. conflict.

    I suggest you change the repo from 11.1 to Factory, update unconditionally, then reenable the Playground and Community repos. That would be the real solution.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  9. #9

    Default Re: 11.2 M8 issues upgrading to KDE 4.3.2

    indeed, I changed my repositories to factory and then did a zypper dup. No problems with updating. Too bad KDE4.3.2 will not be included in the final version of 11.2

  10. #10

    Default Re: 11.2 M8 issues upgrading to KDE 4.3.2

    I did this same thing. Changed to factory and ran zypper dup and as far as I can tell everything is now on release 5 (KDE 4.3.2).

    Thanks for all of the help!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •