Results 1 to 8 of 8

Thread: How to update V4L-DVB?

  1. #1
    atcrank NNTP User

    Default How to update V4L-DVB?

    Howdy-ho good neighbours -

    I am getting a make error when I follow these instructions in OpenSUSE 11.1:
    "http://www.linuxtv.org/wiki/index.php/How_to_Obtain,_Build_and_Install_V4L-DVB_Device_Drivers.

    The error message is:
    "andrew@linux-m9e8:/v4l-dvb/v4l-dvb-5bc6ac2cc5b2/v4l-dvb> uname -r
    2.6.27.29-0.1-default
    andrew@linux-m9e8:/v4l-dvb/v4l-dvb-5bc6ac2cc5b2/v4l-dvb> make
    make -C /v4l-dvb/v4l-dvb-5bc6ac2cc5b2/v4l-dvb/v4l
    make[1]: Entering directory `/v4l-dvb/v4l-dvb-5bc6ac2cc5b2/v4l-dvb/v4l'
    Updating/Creating .config
    Preparing to compile for kernel version 2.6.27
    File not found: /lib/modules/2.6.27.21-0.1-default/build/.config at ./scripts/make_kconfig.pl line32, <IN> line 4.
    make[1]: *** No rule to make target `.myconfig', needed by `config-compat.h'. Stop.
    make[1]: Leaving directory `/v4l-dvb/v4l-dvb-5bc6ac2cc5b2/v4l-dvb/v4l'
    make: *** [all] Error 2"

    This bugzilla report seems to be the same problem:
    Bug 13749 &ndash; I can't install v4l-dvb on openSUSE

    But there's been no update since a recommendation to update kernel, source and headers using zypper, but that failed for me - file name.

    I have just updated the kernel and kernel source (having cloned V4l through mercurial) through YAST but no change in outcome.

    This worked flawlessly in Ubuntu Jaunty on my spare - I really want to keep Suse on my main machine!


    Andrew
    Last edited by atcrank; 10-Oct-2009 at 19:32. Reason: Clarify sentence

  2. #2
    atcrank NNTP User

    Default Re: How to update V4L-DVB?

    Woke up this morning realising I was making a foolish mistake, which I corrected by using root priveleges:

    linux-m9e8:/v4l-dvb/v4l-dvb-5bc6ac2cc5b2/v4l-dvb # make
    make -C /v4l-dvb/v4l-dvb-5bc6ac2cc5b2/v4l-dvb/v4l
    make[1]: Entering directory `/v4l-dvb/v4l-dvb-5bc6ac2cc5b2/v4l-dvb/v4l'
    Updating/Creating .config
    Preparing to compile for kernel version 2.6.27
    File not found: /lib/modules/2.6.27.21-0.1-default/build/.config at ./scripts/make_kconfig.pl line 32, <IN> line 4.
    make[1]: *** No rule to make target `.myconfig', needed by `config-compat.h'. Stop.
    make[1]: Leaving directory `/v4l-dvb/v4l-dvb-5bc6ac2cc5b2/v4l-dvb/v4l'
    make: *** [all] Error 2

    But as you can see, no difference...

    At this point I would be happy to get a reply of 'Dude, you have a problem - I just tried it, it works fine.'

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: How to update V4L-DVB?

    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  4. #4

    Default Re: How to update V4L-DVB?

    Quote Originally Posted by atcrank View Post
    Woke up this morning realising I was making a foolish mistake, which I corrected by using root priveleges:
    On the contrary, using root privileges trying to build external kernel modules was the foolish mistake.

    //Edit:

    Code:
     make
    make -C /tmp/v4l-dvb-5578cc977a13/v4l 
    make[1]: Entering directory `/tmp/v4l-dvb-5578cc977a13/v4l'
    No version yet, using 2.6.27.29-0.1-default
    make[1]: Leaving directory `/tmp/v4l-dvb-5578cc977a13/v4l'
    make[1]: Entering directory `/tmp/v4l-dvb-5578cc977a13/v4l'
    scripts/make_makefile.pl
    Updating/Creating .config
    Preparing to compile for kernel version 2.6.27
    VIDEOBUF_DMA_CONTIG: Requires at least kernel 2.6.31
    DISPLAY_DAVINCI_DM646X_EVM: Requires at least kernel 2.6.31
    VIDEO_VPSS_SYSTEM: Requires at least kernel 2.6.31
    VIDEO_VPFE_CAPTURE: Requires at least kernel 2.6.31
    VIDEO_DM6446_CCDC: Requires at least kernel 2.6.31
    VIDEO_DM355_CCDC: Requires at least kernel 2.6.31 
    
    ....................................
    No problems here.

  5. #5
    atcrank NNTP User

    Default Re: How to update V4L-DVB?

    Thanks for the web-pin link caf4926 - that's potentially useful, although I didn't have much luck. It installed a new kernel and new v4l, but not one with the specific fix I need. I am waiting for a change developed to the Af9015 module to percolate down to the final? production? open release? version of the V4L-DVB suite. I thought it was already there, but it would seem not. Possibly the build I used labelled current.,

    Akoellh - did you read my two posts where you would have seen that I got an identical failure with both accounts? I guess I have some idiosyncratic problem with my install, since it works for you. Is there a reason .config would be missing for me? I may have missed a very basic step...

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: How to update V4L-DVB?

    OneClick's are problematic sometimes, you as the user do need to think on your feet a bit. Look out for repo's it asks to add and make sure they sure not duplicates of what you already have.
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7
    caffeinehigh NNTP User

    Default Re: How to update V4L-DVB?

    I had it working fine on 11.1 using a version I had to build. I had hoped that the built in version in 11.2 so I would not have to go rebuild every kernel upgrade. Unfortunatlely I could not get the second tuner to lock on any channels, but it would show both tuners.

    I ended up having to build v4l to get both tuners on the af9015 working.

    I grabbed the latest from linuxtv with:

    hg clone v4l-dvb: log

    Did a make and make install and all is fine.

    The only challenge I had was that the version of the kernel headers did not match the kernel I had installed and I could not seem to find the one I was after.

    andrew@linux-gf1p:~/v4l-dvb> rpm --query --all '*kernel*'
    kernel-desktop-devel-2.6.31.5-0.1.1.x86_64
    kernel-source-2.6.31.5-0.1.1.noarch
    kernel-desktop-2.6.31.5-0.1.1.x86_64
    linux-kernel-headers-2.6.31-3.4.noarch
    kernel-desktop-base-2.6.31.5-0.1.1.x86_64

    I'd get an error running the make, so I just created a symlink to the allow me to do the make. I know that it far from the best solution but it is only for mythtv so I was not too worried.

    I've just been running 2 frontends at the same time on live TV and all seems good

  8. #8
    caffeinehigh NNTP User

    Default Re: How to update V4L-DVB?

    sorry, I forgot to mark that line as code

    Should be:

    Code:
    hg clone http://linuxtv.org/hg/v4l-dvb

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •