Results 1 to 4 of 4

Thread: No sound coming from USB speakers!

  1. #1

    Unhappy No sound coming from USB speakers!

    Hi, I have downloaded a 32bit openSUSE 11.1 (on a dual boot with Vista) and I am running the GNOME interface. My Acer Aspire 4530's internal speakers work, but they aren't very good quality.

    I used some NexXtech USB speakers (which work fine with Vista), to make the sound quality better.

    I added the USB sound card in YaST, and made it the default sound playback option in "Sound". When I pressed "Test", the speakers worked normally. But when I view a listen to a song on youtube, the internal speakers are used instead.

    I then went back to YaST, and made the USB sound card the default one, but then, no sound came at all!

    Please help, and thank you in advance

  2. #2

    Default Re: No sound coming from USB speakers!

    Edit: I just noticed that the speakers work with applications on openSUSE, but not with firefox.

  3. #3
    Join Date
    Mar 2008
    Phuket, Thailand
    Blog Entries

    Default Re: No sound coming from USB speakers!

    I don't have USB speakers nor USB headphones. But I try to help users generally with their sound, so to the audio troubleshooting guide I added this link: USB headphones - openSUSE

    You appear to have done the YaST part of that, but perhaps there are other tidbits there that might help? Have you restarted since adding YaST ? Is there any configuration selection in your desktop that you can change?

    I've noted other users with a similar problem: two sound cards / firefox - openSUSE Forums

    I do note some users with pulse audio and KDE 4.3, to have firefox use the correct speakers, needed to install pavucontrol and there turn off the internal audio of their PC (in pavucontrol). The same may be true with Gnome.

  4. #4

    Default Re: No sound coming from USB speakers!

    Hmm... I haven't tried Restarting after using YaST, I'll try that.

    Also,if that fails, can you tell me where to download pauvcontrol?

    Thanks in advance.

    EDIT: SOUND WORKS!!! I once again tried making the USB speakers default in YaST, and this time it worked!!!! YES
    Last edited by iPenguin; 11-Oct-2009 at 15:29. Reason: found answer

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts