Results 1 to 2 of 2

Thread: Mkinitrd thinking option is a module

  1. #1

    Default Mkinitrd thinking option is a module

    Hello experts,

    I'm having a strange problem when trying to build any new kernel. Or more exactly, when I try to install a new kernel. After running make, make modules and make modules_install, I want to run make install. When I do, I get the following output:

    Code:
    sh /usr/src/linux-2.6.31.3/arch/x86/boot/install.sh 2.6.31.3 arch/x86/boot/bzImage \
                    System.map "/boot"
    
    Kernel image:   /boot/vmlinuz-2.6.31.3
    Initrd image:   /boot/initrd-2.6.31.3
    Root device:    /dev/disk/by-id/ata-ST9320320AS_5SX2TX6Z-part3 (/dev/sda3) (mounted on / as ext3)
    Resume device:  /dev/sda2
    Kernel Modules: hwmon thermal_sys processor thermal scsi_mod libata ata_piix ata_generic ide-core ide-pci-generic fan jbd mbcache ext3 edd rtc-lib rtc-core rtc-cmos pata_oldpiix pata_radisys pata_efar pata_pdc202xx_old pata_cs5535 pata_atiixp pata_opti pata_pdc2027x pata_isapnp pcmcia_core pcmcia pata_pcmcia pdc_adma pata_hpt37x pata_ns87410 pata_acpi pata_ali pata_ns87415 pata_it8213 sata_uli sata_nv ahci pata_cmd64x pata_hpt366 sata_svw sata_promise sata_sil pata_sl82c105 pata_cs5520 sata_mv pata_it821x sata_inic162x pata_rz1000 pata_legacy pata_amd pata_cypress pata_artop pata_qdi pata_sil680 sata_sx4 pata_optidma pata_ninja32 pata_sc1200 pata_winbond pata_jmicron pata_cs5536 pata_hpt3x2n pata_mpiix pata_sis sata_sis sata_qstor sata_vsc pata_netcell sata_sil24 pata_marvell pata_hpt3x3 pata_cmd640 pata_serverworks pata_triflex pata_cs5530 pata_sch sata_via pata_via crc-t10dif sd_mod usbcore autosuspend=1 ssb ohci-hcd ehci-hcd uhci-hcd hid usbhid
    Module autosuspend=1 not found.
    Of course there is no modules 'autosuspend=1'. That all probably goes back to powertop's sugestion to add 'usbcore.autosuspend=1' as a kernel option in grub. But I must have added it somewhere else as well.

    Anyhow, I can't find a way to keep mkinitrd from adding that 'module'.

    Maybe anyone of you can give me a hint on a config file, I could try to search through or anything else that might be causing that odd behavior?

    Thanks in advance!

    Adrixan

  2. #2

    Default Re: Mkinitrd thinking option is a module

    Quote Originally Posted by Adrixan View Post
    Maybe anyone of you can give me a hint
    Yes, the hint goes like this:

    Code:
    su -c "grep -ri autosuspend /etc"
    At least, if it is a system wide config file, you probably find something in /etc, if not, search the whole disk with grep.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •