Results 1 to 7 of 7

Thread: Skype (Again??!)

  1. #1

    Default Skype (Again??!)

    Well, I've searched the internet, and the forums, and my exact problem doesn't seem to have come up before, so here goes:

    I've successfully installed Skype on OpenSuSE 11.1 before and had the sound and microphone working. I've just reinstalled 11.1 from scratch, and tried to install Skype, and I don't get any sound. Before, I used to just go into the Skype sound options and choose the hardware devices directly, but now all I get is PulseAudio in the devices dropdowns. Unfortunately, this doesn't seem to work! Sound works in all other applications, including Amarok, last.fm and flash.

    Any ideas?

  2. #2

    Default Re: Skype (Again??!)

    I forgot to mention the system I'm using: AMD 64 bit, ABIT KN9S mobo with onboard sound. I've installed OpenSuSE 64 bit. So is there something I now need to do (but didn't seem to have to do before) to make Skype (32 bit) work with Pulse Audio (64 bit)? I'd be quite happy to just make it see the raw hardware devices like it used to, as that seemed to work!

  3. #3

    Default Re: Skype (Again??!)

    Hi,

    seems I had the same issue. You probably are using new beta version of skype for linux. This version tries to take advantage of pulseaudio server, if any is running that why you do not see anything else in skype sound settings.

    So I've installed pavucontrol with yast and on the tabs output and input devices made some redirection of streams. Cannot give you any details now, since i cannot access my system.

    Drop a line if you have any changes.

    Regards.

  4. #4

    Default Re: Skype (Again??!)

    Yes, it's 2.1.0.47 (Beta). I think the version that seemed to work properly was 2.0.something, but I can't get hold of that one any more.

    This morning when I turned my computer on, Skype magically worked. Then it became intermittent, as did all the other audio stuff such as last.fm, flash, etc. So it looks like I'm now having PulseAudio issues! If I disable PulseAudio, Skype still only seems to see PulseAudio, which not surprisingly, doesn't work as it's disabled!

    Going away for a week, so will pick this up when I get back.

    Nick

  5. #5

    Default Re: Skype (Again??!)

    Are you sure you've disabled Pulseaudio? When it crashes, it happens from time to time because of skype.. then I just restart skype and it sees as earlier the long device list in comboboxes and works ok...

    Roman

  6. #6

    Default Re: Skype (Again??!)

    I've had some success by doing the following, though it's not really a good solution:

    1. Disable PulseAudio in the sound card settings in YaST.
    2. Create file ~/.pulse/client.conf and add the line autospawn = no.
    3. Kill pulse every time you log in and restart all sound applications.

    Obviously this isn't a very elegant solution, and is quite annoying to do every time you log in! As far as I can see at the moment, Skype doesn't play properly with PulseAudio - when it's using PulseAudio no sound comes out, and unless you run steps 1-3 above, it won't see any alternative hardware devices.

  7. #7
    JosephKK NNTP User

    Default Re: Skype (Again??!)

    On Sun, 18 Oct 2009 17:16:02 GMT, nickelarse
    <nickelarse@no-mx.forums.opensuse.org> wrote:

    >
    >I've had some success by doing the following, though it's not really a
    >good solution:
    >
    >1. Disable PulseAudio in the sound card settings in YaST.
    >2. Create file ~/.pulse/client.conf and add the line autospawn = no.
    >3. Kill pulse every time you log in and restart all sound
    >applications.
    >
    >Obviously this isn't a very elegant solution, and is quite annoying to
    >do every time you log in! As far as I can see at the moment, Skype
    >doesn't play properly with PulseAudio - when it's using PulseAudio no
    >sound comes out, and unless you run steps 1-3 above, it won't see any
    >alternative hardware devices.


    Based on reading from this NG to get reliable sound and Skype, you
    need to install the 32-bit execution environment, and non-pulse sound
    backends (32-bit mode). Pulse does not seem ready for prime time,
    please delete it after getting 32-bit sound going.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •