Results 1 to 4 of 4

Thread: nVidia GeFroce 9300M GS driver - openSUSE 11.2 M8

  1. #1

    Post nVidia GeFroce 9300M GS driver - openSUSE 11.2 M8

    notenook Lenovo SL500
    nVidia GeForce 9300M GS

    openSUSE 11.2 M8
    2.6.31-10-desktop #1 SMP PREEMPT 2009-09-29 11:18:23 +0200
    x86_64 x86_64 x86_64 GNU/Linux

    I want to install driver
    I've tried also to compile it:
    I donwloaded NVIDIA-Linux-x86_64-190.32-pkg2.run from nvidia web,
    configured kernel sources (folowing one turial):
    Code:
    cd /lib/modules/$(uname -r)/
    rm build                      # broken link
    ln -s source build
    cd build/
    make mrproper
    make cloneconfig
    make prepare-all
    after this I ran:
    Code:
    sh NVIDIA-Linux-x86_64-190.32-pkg2.run -k $(uname -r)
    driver claimed to be compiled successfully, but X server didn't start.
    /var/log/Xorg.0.log:
    Code:
    X.Org X Server 1.6.4
    Release Date: 2009-9-27
    X Protocol Version 11, Revision 0
    Build Operating System: openSUSE SUSE LINUX
    Current Operating System: Linux **** 2.6.31-10-desktop #1 SMP PREEMPT 2009-09-29 11:18:23 +0200 x86_64
    Build Date: 29 September 2009  08:44:20PM
     
    	Before reporting problems, check http://wiki.x.org
    	to make sure that you have the latest version.
    Markers: (--) probed, (**) from config file, (==) default setting,
    	(++) from command line, (!!) notice, (II) informational,
    	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.0.log", Time: Sat Oct 10 13:10:30 2009
    (==) Using config file: "/etc/X11/xorg.conf"
    (==) ServerLayout "Layout[all]"
    (**) |-->Screen "Screen[0]" (0)
    (**) |   |-->Monitor "Monitor[0]"
    (**) |   |-->Device "Device[0]"
    (**) |-->Input Device "Keyboard[0]"
    (**) |-->Input Device "Mouse[1]"
    (**) Option "ZapWarning" "on"
    (**) Option "AllowMouseOpenFail" "on"
    (**) Option "Xinerama" "off"
    (==) Automatically adding devices
    (==) Automatically enabling devices
    (WW) The directory "/usr/share/fonts/local" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/PEX" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/latin2/misc" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/latin2/75dpi" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/latin2/100dpi" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/latin2/Type1" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/latin7/75dpi" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/baekmuk" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/japanese" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/kwintv" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/uni" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/CID" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/ucs/misc" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/ucs/75dpi" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/ucs/100dpi" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/hellas/misc" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/hellas/75dpi" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/hellas/100dpi" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/hellas/Type1" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/misc/sgi" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/xtest" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/opt/kde3/share/fonts" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/TTF/" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/OTF" does not exist.
    	Entry deleted from font path.
    (**) FontPath set to:
    	/usr/share/fonts/misc:unscaled,
    	/usr/share/fonts/75dpi:unscaled,
    	/usr/share/fonts/100dpi:unscaled,
    	/usr/share/fonts/Type1,
    	/usr/share/fonts/URW,
    	/usr/share/fonts/Speedo,
    	/usr/share/fonts/cyrillic,
    	/usr/share/fonts/truetype,
    	/usr/share/fonts/misc:unscaled,
    	/usr/share/fonts/truetype/,
    	/usr/share/fonts/Type1/,
    	/usr/share/fonts/100dpi:unscaled,
    	/usr/share/fonts/75dpi:unscaled
    (**) Input device list set to "/dev/gpmdata,/dev/input/mice"
    (==) ModulePath set to "/usr/lib64/xorg/modules/updates,/usr/lib64/xorg/modules"
    (**) Extension "Composite" is disabled
    (WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
    (WW) Disabling Keyboard[0]
    (WW) Disabling Mouse[1]
    (II) Loader magic: 0x77c0
    (II) Module ABI versions:
    	X.Org ANSI C Emulation: 0.4
    	X.Org Video Driver: 5.0
    	X.Org XInput driver : 4.0
    	X.Org Server Extension : 2.0
    (II) Loader running on linux
    (--) using VT number 7
    
    (--) PCI:*(0:1:0:0) 10de:06e9:17aa:2107 rev 161, Mem @ 0xfc000000/16777216, 0xd0000000/268435456,
    0xfa000000/33554432, I/O @ 0x00006c00/128, BIOS @ 0x????????/131072
    (II) Open ACPI successful (/var/run/acpid.socket)
    (II) System resource ranges:
    	[0] -1	0	0xffffffff - 0xffffffff (0x1) MX[B]
    	[1] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
    	[2] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
    	[3] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
    	[4] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
    	[5] -1	0	0x00000000 - 0x00000000 (0x1) IX[B]
    (II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
    (II) "dbe" will be loaded. This was enabled by default and also specified in the config file.
    (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
    (II) "record" will be loaded by default.
    (II) "dri" will be loaded by default.
    (II) "dri2" will be loaded by default.
    (II) LoadModule: "dbe"
    (II) Loading /usr/lib64/xorg/modules//extensions/libdbe.so
    (II) Module dbe: vendor="X.Org Foundation"
    	compiled for 1.6.4, module version = 1.0.0
    	Module class: X.Org Server Extension
    	ABI class: X.Org Server Extension, version 2.0
    (II) Loading extension DOUBLE-BUFFER
    (II) LoadModule: "extmod"
    (II) Loading /usr/lib64/xorg/modules//extensions/libextmod.so
    (II) Module extmod: vendor="X.Org Foundation"
    	compiled for 1.6.4, module version = 1.0.0
    	Module class: X.Org Server Extension
    	ABI class: X.Org Server Extension, version 2.0
    (II) Loading extension MIT-SCREEN-SAVER
    (II) Loading extension XFree86-VidModeExtension
    (II) Loading extension XFree86-DGA
    (II) Loading extension DPMS
    (II) Loading extension XVideo
    (II) Loading extension XVideo-MotionCompensation
    (II) Loading extension X-Resource
    (II) LoadModule: "glx"
    (II) Loading /usr/lib64/xorg/modules//extensions/libglx.so
    (II) Module glx: vendor="NVIDIA Corporation"
    	compiled for 4.0.2, module version = 1.0.0
    	Module class: X.Org Server Extension
    (II) NVIDIA GLX Module  190.32  Wed Sep  2 03:29:24 PDT 2009
    (II) Loading extension GLX
    (II) LoadModule: "record"
    (II) Loading /usr/lib64/xorg/modules//extensions/librecord.so
    (II) Module record: vendor="X.Org Foundation"
    	compiled for 1.6.4, module version = 1.13.0
    	Module class: X.Org Server Extension
    	ABI class: X.Org Server Extension, version 2.0
    (II) Loading extension RECORD
    (II) LoadModule: "dri"
    (II) Loading /usr/lib64/xorg/modules//extensions/libdri.so
    (II) Module dri: vendor="X.Org Foundation"
    	compiled for 1.6.4, module version = 1.0.0
    	ABI class: X.Org Server Extension, version 2.0
    (II) Loading extension XFree86-DRI
    (II) LoadModule: "dri2"
    (II) Loading /usr/lib64/xorg/modules//extensions/libdri2.so
    (II) Module dri2: vendor="X.Org Foundation"
    	compiled for 1.6.4, module version = 1.1.0
    	ABI class: X.Org Server Extension, version 2.0
    (II) Loading extension DRI2
    (II) LoadModule: "nvidia"
    (II) Loading /usr/lib64/xorg/modules//drivers/nvidia_drv.so
    (II) Module nvidia: vendor="NVIDIA Corporation"
    	compiled for 4.0.2, module version = 1.0.0
    	Module class: X.Org Video Driver
    (EE) NVIDIA: Failed to load the NVIDIA kernel module. Please check your
    (EE) NVIDIA:     system's kernel log for additional error messages.
    (II) UnloadModule: "nvidia"
    (II) Unloading /usr/lib64/xorg/modules//drivers/nvidia_drv.so
    (EE) Failed to load module "nvidia" (module-specific error, 0)
    (EE) No drivers available.
    
    Fatal server error:
    no screens found
    
    Please consult the The X.Org Foundation support 
    	 at http://wiki.x.org
     for help. 
    Please also check the log file at "/var/log/Xorg.0.log" for additional information.
    Does anybody have any idea, how to solve it?

  2. #2

    Default Re: nVidia GeFroce 9300M GS driver - openSUSE 11.2 M8

    You must update xorg.conf. It is still using the nv driver,
    not the nvidia.
    Have fun.

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: nVidia GeFroce 9300M GS driver - openSUSE 11.2 M8

    Quote Originally Posted by cscarfo View Post
    You must update xorg.conf. It is still using the nv driver,
    not the nvidia.
    Have fun.
    Here's how it's done, I copy it from one of my files, so pick what you need:

    Pre-NVIDIA install:
    Open Software Installer, choose PATTERN view.
    Check “Linux Kernel Development”
    Click Accept

    NVIDIA install (when reinstall, start at “++actual install” stop at “++Configure X...”)

    Open a terminal window and do:

    ++ prepare some things

    mkdir NVIDIA

    cd NVIDIA

    ++ a folder NVIDIA is created in /home/YOURUSERNAME and entered

    ++ now on a 32bit system do:

    wget ftp://download.nvidia.com/XFree86/Li...90.36-pkg1.run

    ++ on a 64bit system do:

    wget ftp://download.nvidia.com/XFree86/Li...90.36-pkg2.run

    ++ this downloads the driver from the NVIDIA site, into current folder

    ++ actual install

    ++ now on 32bit do:
    su -c 'sh NVIDIA-Linux-x86-190.36-pkg1.run -q'

    ++ on 64bit do:
    su -c 'sh NVIDIA-Linux-x86_64-190.36-pkg2.run -q'

    ++ Enter rootpassword when asked for. The installer will start, Accept the license, hit OK when asked for, until finished.

    ++ Configure X-server to use the driver :

    su -c 'sax2 -r -m0=nvidia'

    ++ Enter rootpassword. MIND: after the -m is a ZERO. Click Change Configuration, check values for videocard and monitor resolition. Save and exit.

    ++ Driver is now installed and configured. On next kernel update there's no need for the sax2 command, since Xorg is already configured to use the nvidia driver.

    ++ Now we need to change to runlevel 5 to get your gui back:

    su -c 'init 5 && exit'

    ++ Enter rootpassword and you should be presented with the kdm login screen.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4

    Default Re: nVidia GeFroce 9300M GS driver - openSUSE 11.2 M8

    Hi ,

    I installed the driver but when I was running the sax2 I got a problem. Looking at the /var/log/SaX.log showed this error

    NVIDIA: could not open the device file /dev/nvidia0 (Input/output error).

    Do you know what the problem can be?

    I have a laptop XPS 1340, with an integrated graphic card + an NVIDIA G210M-512Mb. The operating system is Linux, opensuse 11.2.

    Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •