Results 1 to 5 of 5

Thread: openCV

  1. #1
    Join Date
    Oct 2009
    Location
    Slovakia
    Posts
    38

    Default openCV

    Hi, I install openCV with YAST, and now I try to run some simple programs. The problem is that the compilation give me a lot of misktakes. I think that the program couldnt find the libraries. Do someone know how could I do that?

  2. #2
    Join Date
    Oct 2009
    Location
    Slovakia
    Posts
    38

    Default Re: openCV

    I also try it to install with this Midnight Engineering: Installing OpenCV 1.1.1 on OpenSUSE 11.1. Then the compilation of the program is good, but when I run the program, it says
    Code:
    OpenCV Error: Unspecified error (The function is not implemented. Rebuild the library with Windows, GTK+ 2.x or Carbon support. If you are on Ubuntu or Debian, install libgtk2.0-dev and pkg-config, then re-run cmake or configure script) in cvNamedWindow, file /home/pison/programs/opencv/src/highgui/window.cpp, line 100

  3. #3

    Default Re: openCV

    Your first message is just not detailed enough for anybody to be able to help you. As rule of thumb... if you need help because something gives you an error message... **COPY** (I mean, an *exact* copy) that error message in any help request.

    About "I install openCV with YAST". Well, that's like saying you downloaded it with Firefox... doesn't helps. You should say from which URL you downloaded with Firefox or, in this case, which is the exact package you downloaded ("libopencv1-1.2.0-0.pm.7.11 x86-64 from Packman" is something helpful).


    About the second message... the error message says it all: you compiled opencv without GTK support and your program needs it. Solution? Recompile with GTK support or simply install the Packman package that already provides it.

  4. #4
    Join Date
    Oct 2009
    Location
    Slovakia
    Posts
    38

    Default Re: openCV

    I think that I installed "libopencv1-1.2.0-0.pm.7.11 x86-64 from Packman" with yast. How could I recompile it with GTK support, because I cant find a package "libgtk2.0-dev".

  5. #5

    Default Re: openCV

    It is gtk2-devel in openSUSE.

    But you don't need to compile. Or:
    a) The Packman package works.
    So you just need to install it
    b) The Packman package doesn't works.
    So you should inform about the problem to Packman and they will fix it.


    Without knowing the error message I can't help you. But note that opencv is splitted in *four* packages in Packman (PackMan :: Informationen zum Paket opencv). If you want to compile a C/C++ program that uses opencv you will need "opencv-devel" (and "python-opencv" if your program is written in Python).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •