Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: No sound on reboot

  1. #1
    Join Date
    Aug 2008
    Location
    Florida USA
    Posts
    26

    Question No sound on reboot

    I tried the audio troubleshooting guide but didn't see my problem. I don't have a problem getting sound to work. It's keeping it working after a reboot that's the problem.

    I have a Gigabyte 790X-UD4P mobo, with HDA ATI SB, ALC883 Digital (IEC958 (S/PDIF) Digital Audio Output)
    Realtec ALC889A codec
    YAST says the sound card is a: SBx00Azalia (Intel HDA).

    I'm using opensuse 11.1 with KDE4.3.1 with the spdif optical connected to my home amp.

    I lose sound after every reboot. I get startup and shutdown tones, but Firefox (Hulu, youtube, etc.) and vlc are silent. I found by trial and error that if I delete the sound card in YAST then click yes to the KDE warnings about not deleting the various sound devices (I don't delete them) then I can configure the card with YAST using normal configuration and everything works, UNTIL the next reboot. Test sounds work but the sound from any apps is missing.

    I've tried the multimedia tab in the configure desktop settings and moved the entries that work to the top, but no still sound on reboot, at least till I delete and reconfigure my sound card again.

    There's 2 default entries in the multimedia tab, neither one makes any sound when tested. One labeled default The other labeled default:card=0

    There's a hw:0,1 sound tests OK. This is the ALC 883 digital.

    There's a hw:0,0 no sound. That's the ALC883 analog so not surprising.

    The ALC digital and digital spdif entries work fine.

    There's also 2 entries identified only by a musical note symbol. One gave test sounds and the other didn't. I just retried them and now neither one will select much less test. The mouse over box say the device is currently not available. The remove tab stays greyed out other wise I'd have removed the non-performing entries.

    I'm getting pretty fast at deleting then reconfiguring the sound card to get sound but it is getting old. As I said at the beginning, I get the opensuse startup and shutdown chords always, but nothing in between from any apps unless I play with YAST and the sound card.

    Thanks for any help.
    Last edited by zeterian; 09-Oct-2009 at 19:47.

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: No sound on reboot

    Quote Originally Posted by zeterian View Post
    I tried the audio troubleshooting guide but didn't see my problem. I don't have a problem getting sound to work. It's keeping it working after a reboot that's the problem.

    I lose sound after every reboot. I get startup and shutdown tones, but Firefox (Hulu, youtube, etc.) and vlc are silent. I found by trial and error that if I delete the sound card in YAST then click yes to the KDE warnings about not deleting the various sound devices (I don't delete them) then I can configure the card with YAST using normal configuration and everything works, UNTIL the next reboot. Test sounds work but the sound from any apps is missing.
    If the startup sound works, and if the test sound works, this suggests to me that upon boot some application has seized your audio device and is not letting it go for other devices to use. By restarting your sound driver with yast, you in effect are 'killing' that device's instance that has seized the audio.

    Try the following (which is in the audio troubleshooting guide, but the method/logic is not laid out in detail) to determine what application may have seized your sound device ...

    When you have your sound working properly, run:
    Code:
     lsof /dev/dsp* /dev/audio* /dev/mixer* /dev/snd/*
    and copy the output to a text file, and save that file, making note as to that being the file when sound works.

    Then after a reboot when sound does not work, again run:
    Code:
     lsof /dev/dsp* /dev/audio* /dev/mixer* /dev/snd/*
    and copy that output to a text file and save the file. And then compare the two files. What is the difference? That may show what application has seized your audio.

    Dependant on what you see there, may help you come up with a way forward.

    Also, note that Linux is not particularly good at allowing multiple applications to share the audio device, which is one reason why pulse audio is being introduced (however pulse audio is buggy, and it "might" be the culprit of your problem, although we do not know that yet). The alsa api also allows the sharing of audio. Hence for vlc go to "tools > preferences > audio " and change the "output" to "alsa audio output" and see if that makes a difference. Try that for any other multimedia application that provides a menu for changing the audio output module.

    In case you are curious about openSUSE Linux sound concepts, there is a page here: Sound-concepts - openSUSE

  3. #3
    Join Date
    Aug 2008
    Location
    Florida USA
    Posts
    26

    Question Re: No sound on reboot

    Hi, thanks for the help. I ran the code while the sound was working and after a reboot. May not be important but in system settings/multimedia one of the musical note devices tests with sound and can be moved up or down after reboot, everything else there works or doesn't the same as when the sound card is reconfigured and sound is working.

    The results of the code:

    When the Audio is working:

    pulseaudi 5558 len mem CHR 116,6 22405 /dev/snd/pcmC0D0p
    pulseaudi 5558 len 24u CHR 116,9 0t0 22417 /dev/snd/controlC0
    pulseaudi 5558 len 25u CHR 116,9 0t0 22417 /dev/snd/controlC0
    pulseaudi 5558 len 26u CHR 116,6 0t0 22405 /dev/snd/pcmC0D0p
    pulseaudi 5558 len 27u CHR 116,9 0t0 22417 /dev/snd/controlC0

    Audio after reboot, not working:

    COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
    knotify4 4079 len mem CHR 116,4 4934 /dev/snd/pcmC0D1p
    knotify4 4079 len 22r CHR 116,2 0t0 4740 /dev/snd/timer
    knotify4 4079 len 23u CHR 116,4 0t0 4934 /dev/snd/pcmC0D1p
    pulseaudi 4251 len 20u CHR 116,9 0t0 4964 /dev/snd/controlC0
    pulseaudi 4251 len 27u CHR 116,9 0t0 4964 /dev/snd/controlC0
    kmix 4273 len 11u CHR 116,9 0t0 4964 /dev/snd/controlC0

    Audio after killing kmix and updater applet, still not working:

    COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
    knotify4 4079 len mem CHR 116,4 4934 /dev/snd/pcmC0D1p
    knotify4 4079 len 22r CHR 116,2 0t0 4740 /dev/snd/timer
    knotify4 4079 len 23u CHR 116,4 0t0 4934 /dev/snd/pcmC0D1p
    pulseaudi 4251 len mem CHR 116,6 4946 /dev/snd/pcmC0D0p
    pulseaudi 4251 len 19u CHR 116,9 0t0 4964 /dev/snd/controlC0
    pulseaudi 4251 len 20u CHR 116,9 0t0 4964 /dev/snd/controlC0
    pulseaudi 4251 len 25u CHR 116,6 0t0 4946 /dev/snd/pcmC0D0p
    pulseaudi 4251 len 27u CHR 116,9 0t0 4964 /dev/snd/controlC0

    I ran this immediately after reboot and after checking for updates was finished. The results were the same for all. I don't know what knotify is doing. I tried killing kmix, and the update notifier in the taskbar, still no sound. I ran the code again, last entry, slightly different results but still no sound. I would guess that knotify4 is the culprit, but I don't know what to do about it. I tried setting the systems notification to no audio, but that had no effect.

    I'm using phonon gstreamer backend. I assume that's the default. It's the only choice. The sound-concepts-linux article you linked to has xine listed first and says gstreamer is used a lot by Gnome. Maybe installing xine and uninstalling gstreamer would help?

    Thanks for the help. I'm going to bed now. I'll be back tomorrow afternoon/evening. I found a solution to my sloowww internet problems on the forums in another post, so it's a lot easier to navigate now.

    len

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: No sound on reboot

    It does appear that knotify is the culprit. It was completely re-written for KDE4. I assume it is knotify that gives you your startup sound ? ... and then maybe it does not let go of the audio device after the startup sound?

    Here are some entries with words about it:
    But neither of those offer any solutions nor suggestions as to the problem you have encountered.

    I note you have KDE-4.3.1 on openSUSE-11.1. I suspect the problem lies with your KDE-4.3.1 update (from the basic KDE-4.1.3 that comes with 11.1). However I do not have KDE-4.3.1 with 11.1 on any PC, as my PCs with KDE4 are my sandbox PC which now has openSUSE-11.2 milestone8 and my other PC with KDE4 is my laptop, and I updated it to KDE-4.3.2 last weekend. Hence I can not produce the appropriate version numbers of KDE4 desktop applications for you.

    I think you should focus your investigation on KDE-4.3.1 and determine what is the proper version of the application that contains knotify for KDE-4.3.1 and ensure you have that correct. Possible check the KDE4 destkop to see if there is a place where you can change the desktop output video mode to alsa (from possibly "auto" if there is such a setting - there may not be) and then see after a restart if that helps.

  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: No sound on reboot

    I checked my KDE-4.3.2 install on my Dell Studio 1537 (which I updated last night to KDE-4.3.2 from KDE-4.3.1) and typed:
    Code:
    oldcpu@dell:~> rpm -qa | grep notif
    startup-notification-0.9-59.60
    notification-daemon-0.3.7-185.21
    libknotificationitem-1-1-4.3.2-3.1
    libnotify-0.4.4-173.8
    libnotify1-0.4.4-173.8
    which indicates, I believe, the applications that may be associated with knotify.

    I then checked to see when they may have been installed, and I typed:
    Code:
    oldcpu@dell:~> rpm -qa --last | grep otify
    libnotify1-0.4.4-173.8                        Sat 26 Sep 2009 06:32:36 PM CEST
    libnotify-0.4.4-173.8                         Sat 26 Sep 2009 06:32:36 PM CEST
    which notes a 26-Sep-09 installation date. From what I recall, that was when I installed KDE-4.3.1. Hence it appears to me none of those applications updated when I installed KDE-4.3.2 and hence those version numbers may be applicable to your KDE-4.3.1. What versions do you have?

    I then took a look at my Dell Studio 1537's KDE-4.3.2 destkop settings for audio:

    First, nothing earth shattering here:

    and I have the xine backend selected:

    and I have xine set to use alsa as its sound engine:


    I use libxine1 as packaged by packman on my laptop.

  6. #6
    Join Date
    Aug 2008
    Location
    Florida USA
    Posts
    26

    Default Re: No sound on reboot

    Hi, thanks. Knotify is definitely the culprit. I used system monitor to suspend it, no results, same with terminate. When I killed it, the sound started working. At least I have an easy workaround now. I can let sysmonitor start minimized and kill knotify after the system starts. That's much easier than reconfiguring the sound card.

    I ran the code and got this:

    len@linux-14ki:~> rpm -qa | grep notif
    libnotify-0.4.4-173.8
    notification-daemon-0.3.7-185.21
    startup-notification-0.9-59.60
    libnotify1-0.4.4-173.8
    libknotificationitem-1-1-4.3.1-24.1
    startup-notification-devel-0.9-59.60
    len@linux-14ki:~> rpm -qa --last | grep otify
    libnotify1-0.4.4-173.8 Mon 10 Aug 2009 03:33:20 AM EDT
    libnotify-0.4.4-173.8 Mon 10 Aug 2009 03:32:31 AM EDT

    It appears that you have a later libnotificationitem:
    mine is: libknotificationitem-1-1-4.3.1-24.1
    yours is: libknotificationitem-1-1-4.3.2-3.1

    I also have 2 entries for:
    startup-notification-0.9-59.60
    startup-notification-devel-0.9-59.60
    Maybe the second entry is interfering with sound. I'll uninstall it. Uninstalling it uninstalled several gnome-devel as well. Hopefully I didn't hose the system, but maybe those packages were causing problems too. I'm not sure where they came from.

    I had many problem with KDE4.1 and used the one-click install to get 4.2 which was better, but still problematic. I went to a one-click install with 4.3 too. I think I updated a plasmoid and got the 4.3.1 version that way, when it updated 4.3 with it.

    I'd like to update to KDE4.3.2. but it's not in the repositories and following the download links at KDE.org and clicking suse finally gets me too a mostly blank page showing:
    Apache/2.2.8 Server at kde.mirrors.tds.net Port 80

    I'm not sure what's happening there, but I'm going to post this and restart the computer to see if uninstalling the devel packages helped or hurt. I could install xine-ui if that's the correct package. Right now I have some xine components, but KDE only has gstreamer listed for a backend.

    Thanks, for the help. I get back after restarting and checking for sound.
    len

    Thanks for the help.

  7. #7
    Join Date
    Aug 2008
    Location
    Florida USA
    Posts
    26

    Default Re: No sound on reboot

    Hi, back again. Same problem on reboot, no sound until I kill knotify. That's very easy though.

    I went back to KDE.org and found and downloaded the 4.3.2 packages, but I couldn't install them. They kept asking for packages I'd already downloaded but the installer couldn't find. I guess I'll wait for a one click install. I don't understand why the KDE upgrade isn't in the repositories, especially bug fixes.

    I found phonon-backend-xine I expect that's the one I want. I may install that later to see if it works any better than gstreamer.

    Thanks for the help,
    len

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: No sound on reboot

    Quote Originally Posted by zeterian View Post
    Hi, back again. Same problem on reboot, no sound until I kill knotify. That's very easy though.

    I went back to KDE.org and found and downloaded the 4.3.2 packages, but I couldn't install them. They kept asking for packages I'd already downloaded but the installer couldn't find. I guess I'll wait for a one click install. I don't understand why the KDE upgrade isn't in the repositories, especially bug fixes.

    I found phonon-backend-xine I expect that's the one I want. I may install that later to see if it works any better than gstreamer.

    Thanks for the help,
    len
    I'm no expert in updating KDE. In fact, I refused to do it for years, and until KDE4. Prior to KDE4, the last time I did it with KDE3 was over 5 years ago, and I ended up hosing my system, primarily because to update successfully (with the myriad of possibilities of things that could go wrong) required a level of knowledge that I didn't have. My Linux knowledge is better know, but I still do not know what the vast majority of the updating KDE packages do, and hence a KDE update is not something I would recommend to someone who uses their openSUSE Linux with KDE for work.

    Still, in the case of KDE4, if one succeeds, the update pays dividends in obtaining a more stable system. This is primarily IMHO due to the relative immaturity of KDE4.

    In my case, I installed KDE4.3.1 from the liveCD here: "KDE Four Live" CD . Back in mid-September that liveCD provided KDE-4.3.1. Now its no longer the case, and the liveCD has been replaced with one that provides KDE-4.3.2. So that is where I obtained the relevant knotify packages. I updated to KDE-4.3.2 (from KDE-4.3.1) following caf4926's guide here: KDE 4.3.2 HowTo for 11.1 - openSUSE Forums

    I'm not a believer in the one-click install. It opens the door (IMHO) for far too many things to go wrong where a user has no control.

    But if one looks at the URL in the directory in caf4926's how-to, it has the appropriate version of libknotificationitem:
    Code:
    http://download.opensuse.org/repositories/KDE:/43/openSUSE_11.1/
    You could download that specific rpm to your hard drive and try to install it. It may or may not have dependencies, and if it has dependencies, you could briefly add the URL as a repos, install libknotificationitem, and then remove the repos.

    I'm not a believer in keeping more than OSS, Non-OSS, Update and Packman in my active repos. Too many things can go wrong. Instead I prefer much tighter control on my system's updates, and I add other repos briefly only on an a very limited as required basis.

  9. #9
    Join Date
    Aug 2008
    Location
    Florida USA
    Posts
    26

    Smile Re: No sound on reboot

    Hi, thanks for the links. I'll investigate that update post more later. It seems to be a good explanation. I've never added a repository manually, but it doesn't seem too hard. The one-click install added some repositories as well. For me, at least, it did what it said it would, update KDE4. At the moment killing knotify after boot seems to take care of the sound problem, so it's no longer a priority, but I'm assuming that not having it running will not affect system stability? I guess I'll find out. It doesn't seem like it should, but then sometimes changing one thing changes something seemingly completely unrelated. Changing monitor refresh rates moves my taskbar from one monitor to another.

    I also disabled audio notifications. I'll see if that does anything. Your xine pictures show a lot more options than gstreamer does. I may install that before trying to update and see what happens.

    You hit the nail on the head here:

    "Still, in the case of KDE4, if one succeeds, the update pays dividends in obtaining a more stable system. This is primarily IMHO due to the relative immaturity of KDE4."

    I've tried the versions from 4.0 and later. The advances in usability from one point update to the next have been very noticeable. This is a big reason why they should push the updates out to all users through the update repository. IMHO there's a good case to be made labeling all the KDE4.x updates as bug fixes. It's only now it's getting stable and useful enough that I want to keep using it. I am starting to pick up more and more knowledge of linux along the way too.

    Thanks for the help.
    Len

  10. #10
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: No sound on reboot

    Quote Originally Posted by zeterian View Post
    I've never added a repository manually, but it doesn't seem too hard.
    With zypper it is fairly easy. One does
    • zypper ar <URL-of-REPOSITORY> arbitrary-name #to add the repository
    • zypper install application #to install the application
    • zypper rr arbitrary-name #to remove the repository

    For example:
    Code:
    zypper ar http://download.opensuse.org/repositories/KDE:/43/openSUSE_11.1/ KDE43
    Code:
    zypper install libknotificationitem
    Code:
    zypper rr KDE43
    For those who like GUI's (much much slower and not as intuitive in this case) there is this guide: Repositories/11.1 - openSUSE-Community

    Again, I recommend users keep only OSS, Non-OSS, Update and Packman repositories enabled, and disable or remove all others as a default setup (adding other repositories briefly on an adhoc basis for a specific install, and then removing). I recommend that to keep a system simple and clean.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •