Results 1 to 9 of 9

Thread: installed but sax2 wont change

  1. #1

    Default installed but sax2 wont change

    I installed my nVidia drives "the hard way" and everything seemed to go fine. When I go to My Computer I can see my display info it shows the Vendor as NVIDIA Corperation, Model as nForce 750a SLI/PC/SSE2, and the Driver as 2.1.2 NVIDIA 177.80 which is all correct.

    However, when I open up Yast>Hardware>Graphics Card and Monitor it says my card is VESA Framebuffer Graphics.

    What is wrong? I tried runing the sax2 -r -m 0=nvidia again, but I still get the same thing.

    What gives? Is it installed right, but just wont show up? Thanks.

  2. #2

  3. #3

    Default Re: installed but sax2 wont change

    I've spent days and days trying to get my Nvidia card working (EVGA 8400GS). Lots of fiddling, failsafe boots, crashes, hangs, installs, looking, reading.

    In the end it looks like:
    1. the opensuse nvidia 1-click installer probably works (I did a Yast install as well along the way).
    2. Running the application "NVIDIA X Server Settings" gave good information on status.
    3. nvidia-xconfig is required, possibly from a shell when X is not running.
    4. When "NVIDIA X Server Settings" finally thinks everything is OK, "Graphics cards and monitors" reports the onboard graphics hardware is in use (even though the monitor is not plugged in to that).

    So it looks like although Hardare Information will happily detect the two graphics devices, something else can't get that information into /etc/X11/xorg.conf

    xorg.conf
    Section "Device"
    Identifier "Device[0]"
    Driver "nvidia"
    VendorName "Matrox"
    BoardName "G200 SE A (PCI)"
    Screen 0
    EndSection

    Hardware Information:
    65: udi = '/org/freedesktop/Hal/devices/pci_10de_6e4'
    pci.subsys_product_id = 46884 (0xb724)
    info.subsystem = 'pci'
    pci.subsys_vendor_id = 14402 (0x3842)
    info.product = 'GeForce 8400 GS'
    pci.device_class = 3 (0x3)
    info.udi = '/org/freedesktop/Hal/devices/pci_10de_6e4'
    pci.device_subclass = 0 (0x0)
    pci.device_protocol = 0 (0x0)
    pci.vendor = 'nVidia Corporation'
    linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:1e.0/0000:11:00.0/0000:12:00.0'
    info.vendor = 'nVidia Corporation'
    info.parent = '/org/freedesktop/Hal/devices/pci_10b5_8112'
    pci.product = 'GeForce 8400 GS'
    pci.linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:1e.0/0000:11:00.0/0000:12:00.0'
    pci.subsys_vendor = 'eVga.com. Corp.'
    pci.product_id = 1764 (0x6e4)
    linux.hotplug_type = 2 (0x2)
    pci.vendor_id = 4318 (0x10de)
    linux.subsystem = 'pci'

  4. #4

    Default Re: installed but sax2 wont change

    Code:
    # sax2 -p
    Chip: 0  is -> Matrox G200 SE A (PCI)           13:00:0 0x102b 0x0522 AGP mga
    Chip: 1  is -> NVIDIA GeForce 8400 GS           18:00:0 0x10de 0x06e4 AGP nvidia
    Sax2 also sees two graphics devices. Sax2 gui manual suggests both should be visible, but they're not.
    SDB Server Configuration with SaX2 (8.1 or Higher) - openSUSE

    Looks like the generally recommended fudge:
    Code:
    # sax2 -r -m 0=nvidia
    ...fools the system to use the right driver attached to the wrong card id.

    Anyone got any ideas?
    HP ML110G5 E8400 2GB
    openSUSE 11.1, 11.2RC2 x86_64
    eVGA 8400GS PCI

  5. #5
    Join Date
    Jun 2008
    Location
    Kentucky, USA
    Posts
    466

    Default Re: installed but sax2 wont change

    Just try
    Code:
    nvidia-xconfig
    as root. It will create it's own xorg. I had to do this with 11.2 M8 for some reason. Sax2 wouldn't pick up the nvidia module. If you need compositing, then run
    Code:
    nvidia-xconfig --composite
    Klaatu Barada Nikto

  6. #6

    Default Re: installed but sax2 wont change

    Quote Originally Posted by 67GTA View Post
    Just try
    Code:
    nvidia-xconfig
    as root. It will create it's own xorg. I had to do this with 11.2 M8 for some reason. Sax2 wouldn't pick up the nvidia module. If you need compositing, then run
    Code:
    nvidia-xconfig --composite
    From what I read sax2 isnt needed when you install nVidia the hard way? It is replaced with nvidia-xconfig. Would I need to install nvidia-xconfig --composite?

    It seems that my computer's desktop effects are running slow - when I know the graphics should be able to handle it with hardly an effort.

    Aslo, just to comfirm - I SHOULD see Vesa Framebuffer Graphics in sax2 after I install nVidia the hard way correct?

    By the way...G7GTA - weren't you on the Ubuntu forums before? I think you helped me with my buggy DSTD?

  7. #7

    Default Re: installed but sax2 wont change

    Quote Originally Posted by HolyShnikes View Post
    From what I read sax2 isnt needed when you install nVidia the hard way? It is replaced with nvidia-xconfig. Would I need to install nvidia-xconfig --composite?

    It seems that my computer's desktop effects are running slow - when I know the graphics should be able to handle it with hardly an effort.

    Aslo, just to comfirm - I SHOULD see Vesa Framebuffer Graphics in sax2 after I install nVidia the hard way correct?

    By the way...G7GTA - weren't you on the Ubuntu forums before? I think you helped me with my buggy DSTD?
    Disregard sax2 .
    Open a terminal su and fire nvidia-settings configure and save.
    People who do not break things first will never learn to create anything

  8. #8
    Join Date
    Jun 2008
    Location
    Kentucky, USA
    Posts
    466

    Default Re: installed but sax2 wont change

    By the way...G7GTA - weren't you on the Ubuntu forums before? I think you helped me with my buggy DSTD?
    Yes that's me. For at least 4 years I've been back and forth between Mint and Opensuse. I can't make up my mind Nvidia-xconfig is a utility that comes with the Nvidia driver. You just need to run it as root in a terminal to automatically generate a xorg.conf file. You can also do as Oldcpu suggested and run nvidia-settings as root in a terminal. This will open a graphical app to change the nvidia settings and then save them to the xorg.conf file.
    Klaatu Barada Nikto

  9. #9

    Default Re: installed but sax2 wont change

    Thanks to both of you.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •