Results 1 to 5 of 5

Thread: Yast2: Cannot find PHP 5.2.x?? Please help!

  1. #1
    sam1am NNTP User

    Default Yast2: Cannot find PHP 5.2.x?? Please help!

    Hello, I was trying to install the php soap extension and it updated my php install to 5.3.1. This version breaks a bunch of stuff so I need to get back to 5.2.11. Problem is, I don't see anything from the 5.2.x branch in yast - only 5.3.1 and 5.1.

    I've searched and searched online but I can't find any repositories or anything for yast that appears to deal with 5.2.x.

  2. #2
    sam1am NNTP User

    Default Re: Yast2: Cannot find PHP 5.2.x?? Please help!

    Really? Is it really that hard to install php 5.2.x from yast?

  3. #3
    Join Date
    Aug 2008
    Location
    127.0.0.1
    Posts
    22

    Default Re: Yast2: Cannot find PHP 5.2.x?? Please help!

    (i assume this was on 11.1)

    sam1am wrote:
    > Hello, I was trying to install the php soap extension and it updated my
    > php install to 5.3.1. This version breaks a bunch of stuff so I need to
    > get back to 5.2.11. Problem is, I don't see anything from the 5.2.x
    > branch in yast - only 5.3.1 and 5.1.
    >
    > I've searched and searched online but I can't find any repositories or
    > anything for yast that appears to deal with 5.2.x.
    >
    >


    i don't know how to get php 5.2.11, but there is a php 5.2.6 in OSS and
    5.2.9 in update repositories.

    To downgrade your php version, select the version that you want to
    install at the "Versions" tab in Yast - Software Management.

    or, (does not try this myself)

    # zypper in php=5.2.9

    and please make sure you already add/enable OSS or Update repo, and
    disable other php specific repo.

  4. #4
    pfelsted NNTP User

    Default Re: Yast2: Cannot find PHP 5.2.x?? Please help!

    I have the same trouble

    I found a distro that has has 5.2.4

    Index of /distribution/10.3/repo/oss/suse

    However, when I add this and try to install this via Yast - Yast core dumps - nice!

    Tried zypper but i can not delete the old url I had because for some reason it tries to resolve it first and wont get past it when i type: zypper sd 2

    Any other ideas?

    Thanks.

  5. #5
    Join Date
    Aug 2008
    Location
    127.0.0.1
    Posts
    22

    Default Re: Yast2: Cannot find PHP 5.2.x?? Please help!

    pfelsted wrote:
    >
    > Tried zypper but i can not delete the old url I had because for some
    > reason it tries to resolve it first and wont get past it when i type:
    > zypper sd 2
    >
    > Any other ideas?
    >
    > Thanks.
    >
    >


    have you try,

    # zypper removerepo 2
    or,
    # zypper modifyrepo --disable 2

    ?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •