Results 1 to 4 of 4

Thread: PackageKit Error of the day

Hybrid View

  1. #1
    Join Date
    Jun 2008
    Location
    Delta Quadrant
    Posts
    1,445

    Default PackageKit Error of the day

    PackageKit Error dep-resolution-failed: patch:compiz-1005.noarch conflicts
    with compiz.i586

    # | Alias | Name | Enabled | Refresh
    --+-----------------+-----------------------+---------+--------
    1 | KDE:43 | KDE:43 | Yes | Yes
    2 | Nvidia | Nvidia | Yes | Yes
    3 | Packman | Packman | Yes | Yes
    4 | openSUSE 11.1-0 | openSUSE 11.1-0 | No | No
    5 | repo-non-oss | openSUSE-11.1-Non-Oss | Yes | Yes
    6 | repo-oss | openSUSE-11.1-Oss | Yes | Yes
    7 | repo-source | openSUSE-11.1-Source | Yes | Yes
    8 | repo-update | openSUSE-11.1-Update | Yes | Yes

    I think is related to adding the KDE:43 repo which must have a compiz
    version that differs from that in repo-update.


  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,811
    Blog Entries
    20

    Default Re: PackageKit Error of the day

    I worked round this in 2 ways and both worked.


    1. Using unconditional update in kde43 selected do not install the Compiz conflict. Repos were all 99, including updates. This keeps the Updates Compiz package and so you have a mix of compiz from updates and kde43.
    2. Switch priority to give kde43 higher priority than Updates and everything is forced to kde43. All compiz is from kde43.
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Jun 2008
    Location
    Delta Quadrant
    Posts
    1,445

    Default Re: PackageKit Error of the day

    > - Using unconditional update in kde43 selected do not install the
    > Compiz conflict. Repos were all 99, including updates. This keeps the
    > Updates Compiz package and so you have a mix of compiz from updates
    > and kde43.

    Not sure this is the best setup, think I would rather have one or the other.

    > - Switch priority to give kde43 higher priority than Updates and
    > everything is forced to kde43. All compiz is from kde43.

    Well it seems I have already tried the 2nd one. I have KDE43 set to 95 and
    Update is 99.

  4. #4
    Join Date
    Jun 2008
    Location
    Delta Quadrant
    Posts
    1,445

    Default Re: PackageKit Error of the day

    >> - Switch priority to give kde43 higher priority than Updates and
    >> everything is forced to kde43. All compiz is from kde43.

    > Well it seems I have already tried the 2nd one. I have KDE43 set to 95
    > and Update is 99.


    I think I'll just wait it out. No amount of changing it seems to be helping.
    If I set them all to 99 it wants to downgrade the whole mess to 4.1.3.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •