Results 1 to 6 of 6

Thread: Yelp !!!

  1. #1
    jasondsouza NNTP User

    Default Yelp !!!

    Dear Users of Opensuse..

    I'm new to opensuse and linux in general and do not know much about linux. I thought of installing fedora but then turned my entire attention to opensuse because I heard it is easier to use than fedora. I've got some problems in relation to my installation.

    Firstly the parameters that you may need.
    OS :- OpenSuse 11.1
    Device :- Laptop more info click the link below.
    Show Box
    D. E :- GNome

    I updated all the upgrades and also put a new kernel which came along with the upgrades. Restarted the PC twice. Two applications fail to work. 1) Terminal and 2) Appearance

    I need to install the latest version of firefox which I have in the tar.gz format but terminal doesn't seem to start. I'm a software developer and this will hamper my work to a great extent if in case no help is rendered. Please do send a solution. Also sound doesn't seem to play and when I recently restarted my pc the entire interface changed. I mean the colour of the title bar . the window colour etc. It looks like an ancient os ...

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: Yelp !!!

    Re-boot and remove all boot arguments by pressing backspace, then just type the number 3

    At the prompt login with username and password
    then type su
    and root password

    next type:

    zypper ref

    then
    zypper up

    reboot
    If nothing gets updated, post back.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,574
    Blog Entries
    38

    Default Re: Yelp !!!

    Quote Originally Posted by jasondsouza View Post
    ... Also sound doesn't seem to play a
    The general advice I give for sound problems is to start trying to work your way through the openSUSE audio troubleshooting guide: SDB:AudioTroubleshooting - openSUSE .

    Do NOT use the startup system sound as your criteria for stating sound does not work. Also be certain to check your mixer. Its not uncommon for a mixer setting (master, pcm or speaker) to be muted upon boot. In KDE your mixer is "kmix" (the small speaker in right hand corner). In Gnome your mixer is "alsamixer".

    Note, when testing if you have sound, please copy and paste the following speaker-test into a Gnome terminal or a kde konsole:

    speaker-test -Dplug:front -c2 -l5 -twav

    Note Linux is case sensitive, and D is not the same as d. To stop the above test, while the konsole/xterm has the mouse focus, press <CTRL><C> on the keyboard. Note you should check your mixer settings (kmix if using KDE, and alsamixer if using Gnome) to ensure that PCM and Master Volume are set around 95%. Once you have basic sound established you can back off to lower volume levels. Note the test for surround sound is different.

    If that test yields errors (and its not uncommon to get errors there), try instead this more simple test:
    speaker-test -c2 -l5 -twav
    You should hear a female voice saying 'FRONT LEFT', 'FRONT RIGHT' five times. Its quite common that one of those speaker tests will work and one will NOT work, so don't be distressed if that is the case. IF that test gives sound, stop now, post that the sound test gives sound, and we will look at other possible causes for your applications not giving you the sound you want (such as missing codecs, using the wrong packaged version ... etc ... ).

    Or alternatively, for testing the simple playback, use aplay program. Prepare a WAV file and simply run like:
    Code:
    aplay -vv somefile.wav
    With the option -vv, aplay shows the verbose information of the PCM device, and a VU-peak meter during playing the file.

    Try those speaker-tests as both a regular user, and also with root permissions. If you have a headset, try with your headset plugged in, and also with your headset not plugged in (for speakers).

    Assuming no sound, can you provide more very detailed information so a good recommendation can be given? For openSUSE-11.1, you can do that, with your laptop connected to the internet, by opening a gnome-terminal or a kde konsole and twice copy and paste the following into that terminal/konsole
    Code:
    /usr/sbin/alsa-info.sh
    Run it the 1st time with root permissions. It will ask if you wish to do an update of the script. Select YES.

    Then run it again (as either a regular user or as root). This time it will diagnose your PC's hardware and software configuration for audio, and it will ask if you wish to share the information (select YES), and it will post its diagnostic output on the Internet/web. It will give you the URL of the web site. Please post that URL here. JUST the URL.

    Also, please copy and paste the following commands one line at a time into a gnome-terminal or a konsole and post here the output:
    rpm -qa | grep alsa
    rpm -qa | grep pulse
    rpm -q libasound2
    uname -a
    cat /etc/modprobe.d/sound
    ... with that information I may be able to make a detailed recommendation. (but try the alsa-firmware installation/reboot first)

    Also, do NOT waste too much time on this. Simply post on our forum if you get stumped, and continue to look for help that way.

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,574
    Blog Entries
    38

    Default Re: Yelp !!!

    Quote Originally Posted by jasondsouza View Post
    I'm new to opensuse and linux in general and do not know much about linux.
    Since you state you are new, here is a link to our New Users stickie:
    NEW Users - Suse-11.1 Pre-installation PLEASE READ - openSUSE Forums

    and here is a link to some basic openSUSE concepts: Concepts - openSUSE

  5. #5
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,937

    Default Re: Yelp !!!

    Quote Originally Posted by jasondsouza View Post
    Dear Users of Opensuse..
    I need to install the latest version of firefox which I have in the tar.gz format but terminal doesn't seem to start.
    As a new user you may want to avoid tar.gz packages until you get more familiar with linux packages.

    The latest update for the FF version supported in your opensuse release is always in the update repository. For example, in OS 11.0 the version is 3.0.x.

    If you want the latest stable version you should add the mozilla repository, it currently have FF 3.5.x if I'm not mistaken.

    I very, very rarely need to compile something from tar.gz packages, it's much easier to use the pre-compiled rpm packages from the repos. Yast software manager does this for you, taking care of all the dependencies.

  6. #6

    Default Re: Yelp !!!

    Quote Originally Posted by jasondsouza View Post
    Dear Users of Opensuse..

    I'm new to opensuse and linux in general and do not know much about linux. I thought of installing fedora but then turned my entire attention to opensuse because I heard it is easier to use than fedora. I've got some problems in relation to my installation.

    Firstly the parameters that you may need.
    OS :- OpenSuse 11.1
    Device :- Laptop more info click the link below.
    Show Box
    D. E :- GNome

    I updated all the upgrades and also put a new kernel which came along with the upgrades. Restarted the PC twice. Two applications fail to work. 1) Terminal and 2) Appearance

    I need to install the latest version of firefox which I have in the tar.gz format but terminal doesn't seem to start. I'm a software developer and this will hamper my work to a great extent if in case no help is rendered. Please do send a solution. Also sound doesn't seem to play and when I recently restarted my pc the entire interface changed. I mean the colour of the title bar . the window colour etc. It looks like an ancient os ...
    Which terminal you can't open. is it the gnome terminal?
    Have you tried the xterminal? Try hitting alt-f2 and when the run command show-up, type xterm. Inside the xterm if you can get it work try firing up the terminal that is not working and look for the generated errors and try analyzing it you might find some info that will help solving the problem.
    People who do not break things first will never learn to create anything

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •