Results 1 to 3 of 3

Thread: Problem with ICH9 HD 82801 sound card

  1. #1

    Default Problem with ICH9 HD 82801 sound card

    I have a Fujitsu Siemens Esprimo 6535 laptop with a soundcard ICH 9 HD 82801 realtek. I found on google that there are many problems about this card on SuSE, but anything I tried didn't worked. There is no sound playing, and when I try to launch kamix it says there is no sound card. But when I enter YAST, while the window about configuration remains open suddenly I do have sound. But when I click next, and it shows those messages about running suseconfig etc, sound stops and remains this way. Where can I find a driver, or what steps must I make to make sound working? I really don't want to return to windows... Thanks in advance.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Problem with ICH9 HD 82801 sound card

    @oldcpu our sound Guru is away, but he may have Internet access I'm not sure.
    Have you been here:
    SDB:AudioTroubleshooting - openSUSE
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Problem with ICH9 HD 82801 sound card

    Quote Originally Posted by johnn2400 View Post
    I have a Fujitsu Siemens Esprimo 6535 laptop with a soundcard ICH 9 HD 82801 realtek. I found on google that there are many problems about this card on SuSE, but anything I tried didn't worked. There is no sound playing, and when I try to launch kamix it says there is no sound card. But when I enter YAST, while the window about configuration remains open suddenly I do have sound. But when I click next, and it shows those messages about running suseconfig etc, sound stops and remains this way. Where can I find a driver, or what steps must I make to make sound working? I really don't want to return to windows... Thanks in advance.
    Sometimes that behaviour can be indicative of a permissions problem. What happens if you add your regular users to group audio and then restart? Guidance here in step-6: SDB:AudioTroubleshooting - openSUSE - How to fix a permissions problem

    Now the general advice I give for sound problems is to start trying to work your way through the openSUSE audio troubleshooting guide, which is the URL caf4926 provided: SDB:AudioTroubleshooting - openSUSE .

    Do NOT use the startup system sound as your criteria for stating sound does not work. Also be certain to check your mixer. Its not uncommon for a mixer setting (master, pcm or speaker) to be muted upon boot. In KDE your mixer is "kmix" (the small speaker in right hand corner). In Gnome your mixer is "alsamixer".

    Note, when testing if you have sound, please copy and paste the following speaker-test into a Gnome terminal or a kde konsole:

    speaker-test -Dplug:front -c2 -l5 -twav

    Note Linux is case sensitive, and D is not the same as d. To stop the above test, while the konsole/xterm has the mouse focus, press <CTRL><C> on the keyboard. Note you should check your mixer settings (kmix if using KDE, and alsamixer if using Gnome) to ensure that PCM and Master Volume are set around 95%. Once you have basic sound established you can back off to lower volume levels. Note the test for surround sound is different.

    If that test yields errors (and its not uncommon to get errors there), try instead this more simple test:
    speaker-test -c2 -l5 -twav
    You should hear a female voice saying 'FRONT LEFT', 'FRONT RIGHT' five times. Its quite common that one of those speaker tests will work and one will NOT work, so don't be distressed if that is the case. IF that test gives sound, stop now, post that the sound test gives sound, and we will look at other possible causes for your applications not giving you the sound you want (such as missing codecs, using the wrong packaged version ... etc ... ).

    Or alternatively, for testing the simple playback, use aplay program. Prepare a WAV file and simply run like:
    Code:
    aplay -vv somefile.wav
    With the option -vv, aplay shows the verbose information of the PCM device, and a VU-peak meter during playing the file.

    Try those speaker-tests as both a regular user, and also with root permissions. If you have a headset, try with your headset plugged in, and also with your headset not plugged in (for speakers).

    Assuming no sound, can you provide more very detailed information so a good recommendation can be given? For openSUSE-11.1, you can do that, with your laptop connected to the internet, by opening a gnome-terminal or a kde konsole and twice copy and paste the following into that terminal/konsole
    Code:
    /usr/sbin/alsa-info.sh
    Run it the 1st time with root permissions. It will ask if you wish to do an update of the script. Select YES.

    Then run it again (as either a regular user or as root). This time it will diagnose your PC's hardware and software configuration for audio, and it will post its output on the Internet/web. It will give you the URL of the web site. Please post that URL here. JUST the URL.

    If you are not using openSUSE-11.1, please advise.

    Also, please copy and paste the following commands one line at a time into a gnome-terminal or a konsole and post here the output:
    rpm -qa | grep alsa
    rpm -qa | grep pulse
    rpm -q libasound2
    uname -a
    cat /etc/modprobe.d/sound
    ... with that information I may be able to make a recommendation.

    Also, do NOT waste too much time on this. Simply post on our forum if you get stumped, and continue to look for help that way.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •