My system; openSUSE 11.1, i386, running 2.6.27.25-0.1-pae.

I'm trying to set up automatic updates on a daily interval (YaST > Software > Online Update Configuration > Automatic Online Update). The Current Update Repository shows "(none)" and updates are not being applied automatically.

I can, however, check for updates with 'zypper -v pchk' - and there are updates needed - this is the output:

# zypper -v pchk
Verbosity: 1
Initializing Target
Checking whether to refresh metadata for openSUSE-11.1-Updates
Checking whether to refresh metadata for openSUSE-11.1-Non-Oss
Checking whether to refresh metadata for openSUSE-11.1-Oss
Loading repository data...
Reading installed packages...
Force resolution: No
15 patches needed (7 security patches)

There are various threads describing this problem, I've gone through all of them and still haven't found the answer.

I only use the vanilla repositories, 'zypper lr --details' gives this:

# | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
--+-----------------------+-----------------------+---------+---------+----------+--------+-----------------------------------------------------------------+--------
1 | openSUSE 11.1-0 | openSUSE 11.1-0 | No | No | 99 | yast2 | cd:///?devices=/dev/sr0 |
2 | openSUSE-11.1-Updates | openSUSE-11.1-Updates | Yes | Yes | 99 | rpm-md | Index of /update/11.1 |
3 | repo-debug | openSUSE-11.1-Debug | No | Yes | 100 | NONE | Index of /debug/distribution/11.1/repo/oss |
4 | repo-non-oss | openSUSE-11.1-Non-Oss | Yes | Yes | 100 | yast2 | Index of /distribution/11.1/repo/non-oss |
5 | repo-oss | openSUSE-11.1-Oss | Yes | Yes | 100 | yast2 | Index of /distribution/11.1/repo/oss |
6 | repo-source | openSUSE-11.1-Source | No | Yes | 100 | NONE | Index of /source/distribution/11.1/repo/oss |

I've tried deleting the 'updates' repository and re-registering it, that doesn't solve the problem.

Does anyone have any advice?

Jim